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1. TUTORIAL 1 - Simple Benchmark Example for Testing of Software - 

A Strut under Axial Force 

 

The column of CHS 88.9x3.2, grade S275 steel and length 5m has a boundary 

condition as one end pin and one end fixed. Determine the axial load resistance and 

buckling load of the column by second order analysis. Do not assume effective length 

for the column as it is unknown for most compression members in real frames.  

 

 

 

 

 

1.1 Step 1 – Start NIDA 

Double click the “NIDA” icon on the desktop or in the corresponding folder upon 

successful installation of NIDA. 

 

 

1.2 Step 2 – Create a new project file  

Click the File > New command,  

 

or find the <New> shortcut button in the toolbar;  

 

Enter the new project <Title> ‘Tutorial 1’ in the popped window and select the 

<Gravity Direction> to be ‘-Y’, <Force Unit> ‘kN’ and <Length Unit> ‘m’.  

 

 

CHS 88.9x3.2, S275 

 

5 m 

 

P 
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Click OK to continue. 

 

Click the Analysis > Analysis & Design Parameters setting command, 

 

The parameters already set could also be viewed or changed in the <General Settings> 

window; 

Select the steel design code HKSC (2011); 
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Activate all the degrees of freedom under ‘Active DOFs’; 

 

Click Apply and then OK to continue. 
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1.3 Step 3 – Create material 

Click the Construct > New Material command, 

 

or right click <Materials> in the Properties window and then click <New Materials>; 

 

Default steel grade set up in the program is S275;  

 

Double click <S275> to view and change the material properties in the <Materials> 

window if required, such as changing the material colour only for this tutorial; 

 

Click OK to continue. 
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1.4 Step 4 – Add nodes 

Click the Construct > New Nodes command, 

 

or click the <Add Node> shortcut in the Properties window; 

 

 

Enter the x, y and z coordinates for node No. 1 and click Apply to continue adding 

nodes; 

 

    

On completion of the last node construction, click Apply and then Close to finish this 

step. 

To view the details of a particular node, click the node, then all the details including 

coordinates, boundary conditions, loadings, etc, are displayed in the Details window; 
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or double click the node to view the node details under ‘Coordinates’, ‘Boundary’, 

‘Support Spring’ and ‘Loading’ menus, make changes in the Node window if needed; 

 

Click OK to continue. 

 

1.5 Step 5 – Add sections 

Click the Construct > New Frame Section > New Sections command,  

 

or click the <Add Section> shortcut in the Properties window; 
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or right click <Frame Sections> in the Properties window and then click <New Frame 

Sections>; 

 

Click <Import> button in the <New Sections> window to import a new cross section; 

 

Select cross sections under different categories, country or shape; 



Tutorials – Step by Step 
 

NIDA – Nonlinear Integrated Analysis & Design  8 

    

Select ‘CHS 88.9x3.2~’ in the <Section Table>; 

 

Click OK, then all the section properties are displayed in the <New Sections> window; 

 

Select a different colour for each section, check all the section properties and make 

changes if required; 

 

Change the plastic modulus S about both axes from 2.3500e-005 to 2.1360e-005; 

Select ‘Use Plastic (S)’ for second order analysis; 

 

P – δ imperfections of the member in this section are generated automatically by the 

software according to the design code in use, but could be manually adjusted as well to 

fulfil special requirement. 
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Click Apply to continue importing different sections and OK to finish adding sections. 

 

There is a default frame section ‘UB 305 x 127 x 42’ generated by the software. 

Delete it or change the properties if needed. 

 

 

 

1.6 Step 6 – Add members 

Click the Construct > New Members command,  
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or click the <Add Member> shortcut in the Properties window; 

 

or click the <Add Member> shortcut in the toolbar; 

 

Select the ‘Section’ and ‘End Condition’ in the < Member Properties > window;  

 

Click the start node and then the end node; if this end node is connected to other 

members, continue to click the next end node and right click to stop adding members. 

 

 

Click Close in dialog or press Esc in keyboard to finish this step. 
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1.7 Step 7 – Add boundary conditions 

Double click the boundary node, set the restraints of displacement in Y and Z axes 

manually in the Node window for this pin end node;   

  

Click Apply and OK to continue; 

or select the node to be restrained; 

 

and click the <Boundary Conditions> shortcut in the Properties window; 

 

 

Set the other end node to be fixed by using ‘Fast Restraints’; 

 

Click Apply and OK to finish this step. 
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1.8 Step 8 – Set visible/invisible 

Click the View > Visible/Invisible command,  

 

or click the <Visible/Invisible> shortcut in the toolbar; 

 

Tick ‘Member’, ‘Member-Number’, ‘Node’, ‘Node-Number’, ‘Node-Boundary 

Condition’, ‘Global Axis’ and select ‘By Section’ in the <Visible/Invisible Settings> 

window; 

 

Click Apply and OK to view the structure with properties constructed. 
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1.9 Step 9 – Add load cases 

Click the Construct > New Load Cases command,  

 

or right click <Load Cases> in the Properties window and then click <New Load 

Case>; 

 

or click the <Add Load Case> shortcut in the Properties window; 

 

Enter the ‘Name’ of new load case, select the load ‘Type’ and ‘Factor’ in the <New 

Load Cases> window; 
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Click Apply to continue adding new load cases and OK to finish this step. 

There are four load cases set as default in the software; 

 

Double click any load case to view or change the settings of this load case or right 

click and select ‘delete’ as requirement. 

 

1.10 Step 10 – Add loadings 

Select node No. 1 and click the <Add Load> shortcut in the Properties window; 

 

Select ‘Load Case’, ‘Load Type’, ‘Axis’ and enter 100 kN ‘Force’ in positive X 

direction in the <Loading Properties> window; 
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Click Apply to continue. 

 

1.11 Step 11 – Set visibility of loadings 

Click the <Set Visibility of Loadings> shortcut in the toolbar; 

 

Select the ‘Load Case’, ‘Load Type’ and tick ‘Show Values’ in the <Show Loading> 

window; 
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Click Apply and Close to finish setting. Loading is then visible. 

 

 

1.12 Step 12 – Set and run analysis cases 

Click the Analysis > Set Analysis Cases command; 

 

Add ‘Nonlinear Analysis’ to determine axial load resistance;  
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Select ‘Nonlinear Analysis + Design’, enter the ‘Total Load Cycles’ to be 120, 

‘Incremental Load Factor’ to be 0.01 and select ‘Imperfection Method & Direction’  

in the <NONLINEAR> window; 

 

Apply ‘Load Case – Axial Load’ to this analysis case; 
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Click OK to go back to the <Analysis Cases> window; 

 

 

Click Run Now to run the analysis case or click OK to close this window and click the 

Analysis > Run command. 
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When the analysis is completed, click OK to close the <Analysis complete!> window; 

 

and the post analysis toolbar will appear under the function toolbar; 

 

 

1.13 Step 13 – View result: structural deformation 

Click the Post > Show Deformed & Undeformed command; 

 

or click the <Show Undeformed and Deformed Shape> shortcut in the toolbar; 

 

Change the load factor in the sliding bar to view the deformed shape under different 

load factors; 
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The deformed shape of the structure under 100kN * (LF=1.2) is shown as below; 

 

 

1.14 Step 14 – View result: show load-deflection curve 

Click the Post > Show Nodal Results > Load Deflection Curve/Reaction command; 

 

or click the <Show Load-Deflection Curve/Reaction> shortcut in the toolbar; 

 

Select the node for which the Load (y) – Deflection (x) curve is determined, tick 

‘Draw with Line’ and ‘Draw with Symbol’;  

 

For this tutorial, the Load – Deflection curve for horizontal deflection along X axis of 

node 1 and rotation about Z axis of node 1 are both obtained in the <Nodal Deflection 

/ Reaction> windows as below. 
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2. TUTORIAL 2 – A Braced and an Unbraced Portal – Second Order 

Analysis and Elastic Critical Load Factor Analysis 

 

The section used for both columns and beam is UC356x368x153 and grade S275 steel. 

Assume the portal is braced and unbraced as two cases. Cross brace of channel 230 x 

90 x 32 of same steel grade is used for the braced case. 

 

 

 

 

 

 

 

 

 

1. Determine Elastic Critical Load Factor λcr for both cases. 

2. Carry out P-Δ-δ analysis and perform member check as per clause 8.9.1 of the CoP 

for the Structural Use of Steel 2011 for both cases 

- P-δ effects are considered by incorporating Table 6.1 during analysis 

- P-Δ effects are considered by iterative procedure of adding deflections to 

the original structural geometry 

- Most unfavorable direction such as through the use of the elastic buckling 

mode for the initial bow be established when using Table 6.1 

 

2.1 Step 1 – Start NIDA 

Double click the “NIDA” icon on the desktop or in the corresponding folder upon 

successful installation of NIDA. 

 

 

 

 

 

30 m 

10 m 
Moment Joints 

Pinned Joints 

All members: UC356x368x153, S275 

1000 kN 

 

60 kN 
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2.2 Step 2 – Create a new project file  

Click the File > New command,  

 

or find the <New> shortcut button in the toolbar;  

 

 

Enter the new project <Title> ‘Tutorial 2 Braced’ in the popped window and select the 

<Gravity Direction> to be ‘-Y’, <Force Unit> ‘kN’ and <Length Unit> ‘m’.  

  

Click OK to continue. 

 

Click the Analysis > Analysis & Design Parameters setting command, 

 

The parameters already set could also be viewed or changed in the <General Settings> 

window; 

Select the steel design code HKSC (2011); 
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Select ‘Fast DOFs – X-Y Plane’ under ‘Active DOFs’ for a plane portal frame; 

 

Click Apply and then OK to continue. 
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2.3 Step 3 – Create material 

Click the Construct > New Material command, 

 

or right click <Materials> in the Properties window and then click <New Materials>; 

 

Default steel grade set up in the program is S275;  

 

Double click <S275> to view and change the material properties in the <Materials> 

window if required, such as changing the material colour only for this tutorial; 

 

Click OK to continue. 
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2.4 Step 4 – Add nodes 

Click the Construct > New Nodes command, 

 

or click the <Add Node> shortcut in the Properties window; 

 

 

 

Enter the x, y and z coordinates for node No. 1 and click Apply to continue adding 

nodes; 

    

On completion of the last node construction, click Apply and then Close to finish this 

step. 

To view the details of a particular node, click the node, then all the details including 

coordinates, boundary conditions, loadings, etc, are displayed in the Details window; 

Node No. 
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or double click the node to view the node details under ‘Coordinates’, ‘Boundary’, 

‘Support Spring’ and ‘Loading’ menus, make changes in the Node window if needed; 

  

Click OK to continue. 

 

2.5 Step 5 – Add sections 

Click the Construct > New Frame Section > New Sections command,  

 

or click the <Add Section> shortcut in the Properties window; 
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or right click <Frame Sections> in the Properties window and then click <New Frame 

Sections>; 

 

Click <Import> button in the <New Sections> window to import a new cross section; 

 

Select cross sections under different categories, country or shape; 
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Select ‘UC 356 x 368 x 153#’ in the <Section Table>; 

 

Click OK, then all the section properties are displayed in the <New Sections> window; 

 

Select a different colour for this UC section, check all the section properties and make 

changes if required; 



Tutorials – Step by Step 
 

NIDA – Nonlinear Integrated Analysis & Design  30 

  

 

P – δ imperfections of the member in this section are generated automatically by the 

software according to the design code in use, but could be manually adjusted as well to 

fulfil special requirement. 

 

Click Apply and Import to continue to add a new section Channel 230 x 90 x 32; 

 

Find the Channel 230 x 90 x 32 in the <Section Table> window under the 

‘UK-Channel’ category;  
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Click OK, then all the section properties are displayed in the <New Sections> window; 
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Select a different colour for this channel section, check all the section properties; 

 

Change the cross sectional area from 4.1600e-003 to 4.1000e-003; 

 

Click OK to finish adding sections. 

 

There is a default frame section ‘UB 305 x 127 x 42’ generated by the software. 

Delete it or change the properties if needed. 

 

 

2.6 Step 6 – Add members 

Click the Construct > New Members command,  

 

or click the <Add Member> shortcut in the Properties window; 

 

or click the <Add Member> shortcut in the toolbar; 

 

Select the ‘Section’ and ‘End Condition’ in the <Properties of Member> window;  
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Click the start node and then the end node; if this end node is connected to other 

members, continue to click the next end node and right click to stop adding members. 

 

Change the member to channel section with both ends rigid,  

 

Click the left top node, the centre point and the right bottom node to add two rigidly 

connected bracing members;  

 

 

Add the other two bracing members with both ends pin connected; 

 

Click Close in dialog or press Esc in keyboard to finish this step. 
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2.7 Step 7 – Add boundary conditions 

Double click the left boundary node, use the ‘Fast Restraints’ option to automatically 

set this pin node in the Node window;   

 

Click Apply or OK to continue; 

or select the node to be restrained; 

 

and click the <Boundary Conditions> shortcut in the Properties window; 

 

Set the this node to be pin end using ‘Fast Restraints’; 

 

Click Apply or OK to finish this step. 
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2.8 Step 8 – Set visible/invisible 

Click the View > Visible/Invisible command,  

 

or click the <Visible/Invisible> shortcut in the toolbar; 

 

Tick ‘Member’, ‘Member-Number’, ‘Node’, ‘Node-Number’, ‘Node-Boundary 

Condition’, ‘Global Axis’ and select ‘By Section’ in the <Visible/Invisible Settings> 

window;  

 

Tick ‘Bending Stiffness about y-y/z-z axes’ to view the end releases of member 4 and 

5; or press the buttons  in toolbar. 

Click Apply or OK to view the structure with properties constructed. 
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2.9 Step 9 – Add load cases 

Click the Construct > New Load Cases command,  

 

or right click <Load Cases> in the Properties window and then click <New Load 

Case>; 

 

or click the <Add Load Case> shortcut in the Properties window; 

 

Enter the ‘Name’ of new load case, select the load ‘Type’ and ‘Factor’ in the <New 

Load Cases> window; 



Tutorials – Step by Step 
 

NIDA – Nonlinear Integrated Analysis & Design  37 

 

Click Apply to continue adding more load cases; 

 

Click OK to finish this step. 

 

There are four load cases set as default in the software; 
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Double click any load case to view or change the settings of this load case or right 

click and select ‘delete’ as requirement. 

 

2.10 Step 10 – Add loadings 

Select node No. 3 and click the <Add Load> shortcut in the Properties window; 

 

Select ‘Load Case’, ‘Load Type’, ‘Axis’ and enter 1000 kN ‘Force’ in negative Y 

direction in the <Loading Properties> window; 

 

Click Apply and Close to continue adding loads; 

 

Select node 2 and apply the same procedure as for node 3; 
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Click Apply and Close to finish this step. 

 

2.11 Step 11 – Set visibility of loadings 

Click the <Set Visibility of Loadings> shortcut in the toolbar; 

 

Select the ‘Load Case’, ‘Load Type’ and tick ‘Show Values’ in the <Show Loading> 

window; 
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Click Apply and Close to finish setting. Loading is then visible. 

 

 

2.12 Step 12 – Set and run analysis cases 

Click the Analysis > Set Analysis Cases command; 

 

 

Add ‘Eigen-Buckling Analysis’ to determine elastic critical load factor λcr for the 

braced frame;  
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Enter the name of analysis to be ‘Braced EIGEN-BUCKLING’ in the 

<EIGEN-BUCKLING> window; 
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Apply ‘Load Case – Vertical/Horizontal Load’ to this analysis case; 

 

Click OK to go back to the <Analysis Cases> window; 

Add ‘Nonlinear Analysis’ to carry out P-Δ-δ analysis and perform member check;  
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Select ‘Nonlinear Analysis + Design’, enter the ‘Name’ to be ‘Braced NONLINEAR’, 

the ‘Total Load Cycles’ to be 1000, ‘Incremental Load Factor’ to be 0.001 and select 

‘Imperfection Method & Direction’ in the <NONLINEAR> window; 

 

 

To fulfil the requirement of implementing P-Δ imperfection, click Setting, enter the 

‘Magnitude of Imperfection for Global Eigenvalue Mode’ in the <Set Eigenmode 

Imperfection> window or select an ‘Auto Cal. Option’ according to the design code 

applied, which is H/200 for this tutorial and click Auto Cal to obtain the value of 

‘Magnitude’; 

Apply ‘Load Case – Vertical/Horizontal Load’ to this analysis case; 
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Click OK to go back to the <Analysis Cases> window; 

 

 

Click Run Now to run both analysis cases or click OK to close this window and click 

the Analysis > Run command. 



Tutorials – Step by Step 
 

NIDA – Nonlinear Integrated Analysis & Design  45 

 

When the analysis is completed, click OK to close the <Analysis complete!> window; 

 

and the post analysis tool bar will appear under the function tool bar; 

 

 

2.13 Step 13 – View result: eigen-buckling mode 

 

For more than one analysis case, the first analysis case will display automatically upon 

completion of program running. For this tutorial, the Eigen-Buckling Analysis result 

displays the 6 eigen-modes firstly; 

 

The mode could be selected through the sliding bar and the corresponding ‘Buckling 

LF’ could be viewed in the tool bar, so the elastic critical load factor for the braced 

case, which is also the first mode buckling load factor, is  

λcr = 14.6793; 

 

Click the Post > Export Eigen-Buckling Load Factors command, 



Tutorials – Step by Step 
 

NIDA – Nonlinear Integrated Analysis & Design  46 

 

 

or click <Export Eigen-Buckling Load Factors> shortcut in the post analysis toolbar; 

 

Select the ‘Source File’ direction, click Load Info in the <Export Eigen-Buckling 

Load Factor> window to select the analysis case to be exported; 

 

 

 

 

 

Click Select and choose the analysis case in the <Select Analysis Case> window; 
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Click OK to go back to the <Export Eigen-Buckling Load Factor> window; 

Click Export , an excel spreadsheet titled ‘***_loadfactor’ will pop up including load 

factors for all the eigen-buckling modes;  

 

 

Click the Post > Show Deformed & Undeformed command; 
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or click the <Show Undeformed and Deformed Shape> shortcut in the toolbar; 

 

 

To view the first eigen-buckling mode deformation in a larger scale, click the Post > 

Display command; 

 

or click the <Adjust Scaling Factor> shortcut in the toolbar; 

 

Enter scaling factors of ‘Delta’ and ‘Angle’ in the <Scaling> window; 

 

The first eigen-buckling mode deformation of the structure is shown as below; 

 

Change the load factor in the sliding bar to view the deformed shapes of higher 

buckling modes. 

 

2.14 Step 14 – View result: nonlinear analysis 

 

To view the other analysis result, click <Select Analysis Case> shortcut near the 

sliding bar in the post analysis toolbar; 
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Select the ‘Braced NONLINEAR’ case from the <Show Analysis Case> window; 

 

 

Click the Post > Show Deformed & Undeformed command; 

 

or click the <Show Undeformed and Deformed Shape> shortcut in the toolbar; 

 

 

To view the nonlinear deformation in a larger scale, click the Post > Display Scale 

command; 

 

or click the <Adjust Scaling Factor> shortcut in the toolbar; 
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Enter scaling factors of ‘Delta’ and ‘Angle’ in the <Scaling> window; 

 

Click the <Member Sect. Capa. Factor> shortcut in the post analysis toolbar, the range 

of section capacity from +1.0 to -1.0 will be displayed in the <Member> toolbar; 

 

Color of each member in the deformed structure indicates its range of section capacity 

at different load factor; 

 

At load factor = 1.000, the deformed shape of structure and the section capacities of 

deformed members is shown as below; 

 

 

2.15 Step 15 – View result: Show analysis procedure of nonlinear analysis 

 

Click the Post > Show Result Files command; 

 

Select the <*.log> file for the ‘Braced NONLINEAR’ analysis case from the <Result 

Files> window; 
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Click Open, a text document showing load stage, load cycle, load increment and 

convergence and so on. The possible warning and error messages will be also printed 

here for checking model; 

Part of messages has been extracted as below; 
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2.16 Step 16 – Delete members for unbraced case 

 

Click the Post > Show Undeformed Shape command; 

 

or click the <Show Undeformed Shape> shortcut in the post analysis toolbar; 

 

The structure returns back to its undeformed shape; 
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Click the Select > Sections command; 

 

Choose the channel section 230 x 90 x 32 in the <Select by Section> window; 

 

Click OK to continue, four bracing members (4) – (7) are then selected, or simply 

select the members on the screen; 

 

Click the Edit > Delete command; 
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The four bracing members disappear leaving only the node 5; 

Click on the node 5 and repeat the above deleting procedure or press the ‘Delete’ 

button on the keyboard directly; 

 

or left click and hold the mouse to select all the members and nodes to be deleted; 

 

Release the mouse, then members (4) – (7) and node 5 are selected; 

 

Repeat the deleting procedure above, the unbraced frame is then constructed; 
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2.17 Step 17 – Unbraced portal frame 

 

All the other properties and load cases of the unbraced frame remain the same as the 

braced one, perform the Eigen-Buckling Analysis and the Nonlinear Analysis again, 

the analysis result is then obtained. 
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3. TUTORIAL 3 – Space Frame 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

For vertical members, local y-axis in global Y-direction; 

For horizontal members, local xy plane parallel to global z axis. 

Determine the elastic critical load factor λcr and check the structural adequacy by 

second-order analysis under the following load combinations: 

- LC1: 1.4 Dead Load + 1.6 Live Load 

- LC2: 1.4 Dead Load + 1.4 Wind Load 

- LC3: 1.2 Dead Load + 1.2 Live Load + 1.2 Wind Load 

 

3.1 Step 1 – Start NIDA 

Double click the “NIDA” icon on the desktop or in the corresponding folder upon 

successful installation of NIDA. 

 

 

 

3 m 3 m 

3 m 

3 m 
Section: 

[1] UB152x89x16 

[2] UB203x102x23 

 

Steel : S275 
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3.2 Step 2 – Create a new project file  

Click the File > New command,  

 

or find the <New> shortcut button in the toolbar;  

 

Enter the new project <Title> ‘Tutorial 2 Braced’ in the popped window and select the 

<Gravity Direction> to be ‘-Y’, <Force Unit> ‘kN’ and <Length Unit> ‘m’.  

 

Click OK to continue. 

Click the Analysis > Analysis & Design Parameters Setting command, 

 

The parameters already set could also be viewed or changed in the <General Settings> 

window; 

Select the steel design code HKSC (2011); 
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Select ‘Fast DOFs – Active All’ under ‘Active DOFs’ for a plane portal frame; 

 

Click Apply and then OK to continue. 

 

3.3 Step 3 – Create material 

Click the Construct > New Material command, 
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or right click <Materials> in the Properties window and then click <New Materials>; 

 

Default steel grade set up in the program is S275;  

 

Double click <S275> to view and change the material properties in the <Materials> 

window if required, such as changing the material color only for this tutorial; 

  

Click OK to continue. 
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3.4 Step 4 – Set gravity direction 

 

Click the View > Set 3D View command, 

 

Enter 90 for ‘Angle’, click the up arrow of X and Apply to rotate the existing 

coordination 90 degrees about X axis; 

 

Click the up arrow of Z and Apply to further rotate the existing coordination 90 

degrees about Z axis; 

 

Click Close in dialog or Cancel button to finish rotation; 

 

Click the Analysis > Analysis & Design Parameters Setting command, 

 

Change the ‘Gravity Direction’ to be ‘-Z’ in the <General Settings> window; 
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Click OK to finish this step. 

 

3.5 Step 5 – Add nodes 

Click the Construct > New Nodes command, 

 

or click the <Add Node> shortcut in the Properties window; 

 

Enter the x, y and z coordinates for node No. 1 and click Apply to continue adding 

nodes on the xy plane with z = 0; 
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On completion of the last node within this plane, click Apply and then Close the <New 

Node> window;  

 

Click the View > Rotate command to view the overlapping nodes in a different angle 

of view, 

Node No. 
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or click the <Rotate> shortcut in the toolbar; 

 

 

Click the View > Zoom In / Zoom Out / Fit to Screen adjust the size of the structure 

on the screen; 

 

or click the <Fit to Screen / Zoom In / Zoom Out> shortcut in the toolbar; 

 

 

  

or roll mouse wheel up and down to zoom in and out to obtain the best fit view; 

 

To view the details of a particular node, click the node, then all the details including 

coordinates, boundary conditions, loadings, etc, are displayed in the Details window; 
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or double click the node to view the node details under ‘Coordinates’, ‘Boundary’, 

‘Support Spring’ and ‘Loading’ menus, make changes in the Node window if needed; 

 

Click OK to continue. 

 

3.6 Step 6 – Copy and paste nodes  

 

Click the Select > Select All command,  

 

or left click and hold the mouse to frame all the nodes in, 
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Click the Edit > Copy command; 

 

or click the <Copy> shortcut in the toolbar; 

 

Click the Edit > Paste command; 

 

or click the <Paste> shortcut in the toolbar; 

 

Select ‘Linear’, enter the ‘Increment’ along Z axis and ‘Num of Inc.’ in the <Paste> 

window; 
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Click OK, then a message box will pop up recommending merging duplicate nodes; 

 

Click Yes to proceed and the message box will close; 

 

 

Click Merge, a new message box will pop up to show the number of nodes merged; 

 

Click OK , and Close the <Merge Duplicate Nodes> window to finish this step; 
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Then all the nodes are constructed as shown below. 

 

 

3.7 Step 7 – Add sections 

Click the Construct > New Frame Section > New Sections command,  

 

or click the <Add Section> shortcut in the Properties window; 

 

or right click <Frame Sections> in the Properties window and then click <New Frame 

Sections>; 
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Click <Import> button in the <New Sections> window to import cross sections; 

 

Select cross sections under different categories, country or shape; 

    

 

Choose a UB section UB 152 x 90 x 16 from the <Section Table> window; 
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Click OK to import UB 152 x 89 x 16 and then all the section properties are displayed 

in the <New Sections> window; 
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Select a different colour for this UB section, check all the section properties and make 

changes to the area, second moment of area and torsional constant as requirement; 

 

P – δ imperfections of the member in this section are generated automatically by the 

software according to the design code in use, but could be manually adjusted as well to 

fulfil special requirement. 

 

Click Apply and Import to continue to add a new section for the column; 

 

Choose a UB section UB 203 x 102 x 23 from the <Section Table> window with 

similar section properties to those required for the columns; 

 

 

Click OK to import UB 203 x 102 x 23, then all the section properties are displayed in 

the <New Sections> window; 
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Select a different color for this section for columns and check all the section 

properties; 

 

Click OK to finish adding sections. 

 

There is a default frame section ‘UB 305 x 127 x 42’ generated by the software. 

Delete it or change the properties if needed. 

 

 

3.8 Step 8 – Add members 

Click the Construct > New Members command,  
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or click the <Add Member> shortcut in the Properties window; 

 

or click the <Add Member> shortcut in the toolbar; 

 

Select the ‘Section’ and ‘End Condition’ for the column members in the <Properties of 

Member> window;  

 

 

Click the start node and then the end node; if this end node is connected to other 

members, continue to click the next end node and right click to stop adding members. 

 

Change the member to beam section with both ends rigid,  

 

Add members to form the lower level beams first and then click Close in dialog or 

press Esc in keyboard; 

 

Apply copy and paste procedure to the beams for the upper level ones; 

Click the Select > Sections command; 
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Select beam section UB 152 x 89 x 16 from the <Select by Section> window; 

 

Click OK to close the window then the beam members are selected, or simply select 

the beam members on the screen; 

 

Click the <Copy> shortcut and the <Paste> shortcut in the toolbar; 
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Select ‘Linear’, enter the ‘Increment’ along Z axis and ‘Num of Inc.’ in the <Paste> 

window; 

 

Click OK, then a message box will pop up recommending merging duplicate nodes; 

 

Click Yes to proceed and the message box will close; 

 

Click Merge, a new message box will pop up to show the number of nodes merged; 

 

Click OK , and Close the <Merge Duplicate Nodes> window to finish this step; 
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Then all the nodes are constructed as shown below. 

 

Check the numberings of this structure and change them according to a successive 

sequence if needed. 

 

3.9 Step 9 – Add boundary conditions 

 

Click the Select > Multi-Select Objects command, 

 

Select ‘Node’ and enter ‘1-4’ to the ‘List of Objects’; 
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Click Select then the selected nodes are shown as below; 

 

Click the Gr-Assign > Nodes > Boundary Conditions command to assign boundary 

conditions to the nodes in a group; 

 

Click the ‘Fast Restraints – Fixed’ to restrain all the degrees of freedom for these 

nodes in the <Assign Node Properties> window; 

 

Click OK to finish this step. 
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3.10 Step 10 – Set visible/invisible 

Click the View > Visible/Invisible command,  

 

or click the <Visible/Invisible> shortcut in the toolbar; 

 

Tick ‘Member’, ‘Member-Number’, ‘Node’, ‘Node-Number’, ‘Node-Boundary 

Condition’, ‘Global Axis’ and select ‘By Section’ in the <Visible/Invisible Settings> 

window;  

 

Click Apply and OK to view the structure with properties constructed. 
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3.11 Step 11 – Rotate member local axis  

 

Click the View > Extrude View command,  

 

or click the <Extrude View> shortcut in the toolbar;  

 

For the vertical members, local y-axis should lie in global Y-direction; 
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For the horizontal members, local xy plane should parallel to global z axis; 

As shown in the following extrude view of the structure, the beams cannot meet the 

requirement; 

 

Click the <Show Member Local Axis> shortcut in the toolbar to view the local axis of 

each member; 

 

 

Red arrow indicates local x axis, green arrow indicates local y axis and blue arrow 

indicates local z axis; 
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Click the <Select by Intersection Curve> shortcut in the toolbar; 

 

Left click and hold the mouse to draw a line intersecting all the members to be 

selected; 

 

Click the View > Show Selection Only command to show the selected members only 

on the screen; 
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or click the <Show Selection Only> shortcut in the toolbar; 

 

Only the selected beam members are displayed; 

 

 

Click the Gr-Assign > Members > Member Local Axis command, 

 

 

Select the local axis to be set ‘In Degrees’ in the <Member Local Axis> window, enter 

the ‘Angle of rotation of the principal axis to the global axis’ to be 90; 
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Click Apply and OK to close the <Member Local Axis> window and view the rotation 

of local axis of the selected member; 

    

The local xy plane of each beam member is turned to parallel to global z axis; 

Click the <Extrude View> shortcut in the toolbar to view the 3D orientation of each 

member. 
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3.12 Step 12 – Add load cases 

Click the Construct > New Load Cases command,  

 

or right click <Load Cases> in the Properties window and then click <New Load 

Case>; 
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or click the <Add Load Case> shortcut in the Properties window; 

 

There are four load cases set as default in the software, just the four load cases 

required for this tutorial; 

 

Double click ‘Load Case – Self Weight’ to view and change the settings; 

 

Tick ‘Auto Self Weight’ in the <Load Case – General> window and click ‘Settings’; 
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Check the settings of auto self weight in the popped window and select ‘All Members’ 

only, set the direction of self weight to be in negative Z direction; 

Click OK to close the <Auto Self Weight> window and click OK to close the <Load 

Case> window; 

For all the other three load cases, keep the default settings.  

 

3.13 Step 13 – Add loadings 

 

Click the <Add Floor> shortcut in the toolbar; 

 

Move the mouse and click on four nodes that can form a floor to apply pressure on; 
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Select the two floors to be loaded; 

 

Click the Gr-Assign > Floor Pressure command; 

 

Apply 5kN/m
2
 dead load pressure to both floors in negative Z direction and select 

‘Convert to Member Loads first’; 
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Click Apply to continue adding 2kN/m
2
 live load pressure to both floors in negative Z 

direction; 
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Click Apply and Close to continue adding other loads; 

 

Click the Select > Multi-Select Objects command; 

 

Enter Node ‘6, 7’ of the lower layer of the frame in the <Select by Number> window 

and click Select; 
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Choose the ‘Load Case – Wind Load’ and ‘Joint Load’, enter the value of force in 

global negative Y direction; 

 

Click Apply and the wind load will be displayed as below; 
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Close the <Loading Properties> window and select the other two nodes on the upper 

layer of frame; 

 

 

Change the value of wind load to be 5.625 in global negative Y direction; 
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Click Apply and Close the <Loading Properties> window to finish this step; 

 

3.14 Step 14 – Set visibility of loadings 

Click the <Set Visibility of Loadings> shortcut in the toolbar; 

 

Select the ‘Load Case’, ‘Load Type’ and tick ‘Show Values’ in the <Show Loading> 

window; 
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Click Apply and Close to finish setting, the whole structure constructed with applied 

loading is visible as below; 

 

 

 

3.15 Step 15 – Add load combinations 

 

Click the Construct > New Combined Load Cases command; 
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or right click <Combined Load Cases> in the Properties window and then click <New 

Combined Load Cases>; 

 

 

Enter the ‘Name’ of the load case and select load cases from the ‘General Load Case’ 

menu to the ‘Combined Load Case’ menu with corresponding load factors in the 

<New Combined Load Cases> window; 

Load type of ‘Self Weight’ is the same as ‘Dead Load’, so apply the same load factor 

to ‘Self Weight’ as for ‘Dead Load’; 
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Click Apply to continue adding new combined load case following the same 

procedure; 

 

 

Click Apply to continue to add the last load case for this tutorial; 
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Click OK to finish this step. 

 

3.16 Step 16 – Set and run analysis cases 

Click the Analysis > Set Analysis Cases command; 

 

 

Add ‘Eigen-Buckling Analysis’ to determine elastic critical load factor λcr for the 

frame;  
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Give the name ‘LC1’ to the 1
st
 load combination case; 

 

 

Apply the load combination LC1; 
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Click OK to close the <EIGEN-BUCKLING> window and add another 

‘Eigen-Buckling Analysis’ to determine elastic critical load factor λcr for load 

combination 2;  

 

Give the name ‘LC2’ to the 2
nd

 load combination case; 
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Apply the load combination LC2; 
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Click OK to close the <EIGEN-BUCKLING> window and add another 

‘Eigen-Buckling Analysis’ to determine elastic critical load factor λcr for load 

combination 3;  

 

Give the name ‘LC3’ to the 3
rd

 load combination case; 
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Apply the load combination LC3; 

 

Click OK to close the <EIGEN-BUCKLING> window and go back to the <Analysis 

Cases> window; 
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To further add the second order analysis cases with the same series of load 

combinations, right click <Combined Load Cases> in the Properties window and click 

<Generate Analysis Cases>; 

 

Select ‘Nonlinear Analysis’ type , enter a ‘Prefix – 2
nd

-order’ to ‘Combined Name’ in 

the <Set Analysis Case> window; 

 

Click Next to continue; 

 

Remain the default settings of ‘Second-order Analysis + Design’ in the 

<Second-Order Analysis> window; 
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Click Finish to complete adding analysis cases; 

 

Click the Analysis > Set Analysis Cases command to view the analysis cases 

constructed; 
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Click Run Now to run all the analysis cases; 

or directly click the Analysis > Run command; 

or press F5 key; 

 

When the analysis is completed, click OK to close the <Analysis complete!> window; 
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and the post analysis toolbar will appear under the function toolbar; 

 

 

3.17 Step 17 – View result: eigen-buckling mode 

 

For more than one analysis case, the first analysis case will display automatically upon 

completion of program running. For this tutorial, the Eigen-Buckling Analysis result 

displays the 6 eigen-modes firstly; 

 

The mode could be selected through the sliding bar and the corresponding ‘Buckling 

LF’ could be viewed in the tool bar, so the elastic critical load factor for the braced 

case, which is also the first mode buckling load factor, is  

λcr = 6.6649; 

Click the Post > Export Eigen-Buckling Load Factors command, 
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or click <Export Eigen-Buckling Load Factors> short cut in the post analysis toolbar; 

 

 

Select the ‘Source File’, click Load Info in the <Export Eigen-Buckling Load Factor> 

window to import the analysis case to be exported; 

 

 

 

 

 

 

Click Select and choose the analysis case in the <Select Analysis Case> window; 
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Click OK to go back to the <Export Eigen-Buckling Load Factor> window; 

Click Export , an excel spreadsheet titled ‘***_loadfactor’ will pop up including load 

factors for all the eigen-buckling modes;  
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Click the Post > Show Deformed & Undeformed command; 

 

or click the <Show Undeformed and Deformed Shape> shortcut in the toolbar; 

 

To view the first eigen-buckling mode deformation in a larger scale, click the Post > 

Display command; 

 

or click the <Adjust Scaling Factor> shortcut in the toolbar; 

 

Enter scaling factors of ‘Delta’ and ‘Angle’ in the <Scaling> window; 

 

The first eigen-buckling mode deformation of the structure is shown as below; 
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Change the load factor in the sliding bar to view the deformed shapes of higher 

buckling modes. 

 

3.18 Step 18 – View result: View another analysis case 

 

To view another analysis result, click <Select Analysis Case> shortcut near the sliding 

bar in the post analysis toolbar; 

 

Select the ‘LC2’ case from the <Show Analysis Case> window; 

 

 

Click the Post > Show Deformed & Undeformed command; 

 

or click the <Show Undeformed and Deformed Shape> shortcut in the toolbar; 
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To view the first eigen-buckling mode deformation in a larger scale, click the Post > 

Display command; 

 

or click the <Adjust Scaling Factor> shortcut in the toolbar; 

 

Enter scaling factors of ‘Delta’ and ‘Angle’ in the <Scaling> window; 

 

 

The deformation of the frame under LC2 is show as below; 

 

With its elastic critical load factor λcr = 7.5670; 

 

 

 

The same procedure applies to the 3
rd

 load combination LC3, the deformation 

therefore obtained as below; 
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With its elastic critical load factor λcr = 7.1314. 

 

 

3.19 Step 19 – View result: check the structural adequacy by second-order analysis (i) 

Export Statistics of Analysis Results 

 

Click the Post > Export Statistics of Analysis Results command; 

 

 

or click the <Export Statistics of Analysis Results> shortcut in the toolbar; 
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‘Browse’ the ‘Source File’ direction in the <Export Statistical Results> window and 

click the ‘Load Info’ button, then the ‘Select’ of ‘Analysis Case’ option becomes 

enable; 

Click ‘Select’ for the ‘Analysis Case’ in the <Export Statistical Results> window, the 

<Select Analysis Cases> window will pop up; 
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Click OK to export the analysis cases considered and go back to the <Export Statistical 

Results> window; 

The number of items selected will be shown under ‘Analysis Case’; 

 

Choose to export ‘1 member extreme value for each selected section by section 

capacity factor’;  

Following a similar process, select the ‘Member – Sections’ by clicking the ‘Section’ 

button and choose the sections to be exported in the <Select Sections> window;  
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Click OK to go back to the <Export Statistical Results> window and click OK, an 

excel spreadsheet will be generated displaying the extreme section capacity factor for 

each section used in this tutorial; 

 

From the above spreadsheet, UB152x89x16 is observed to have a section capacity 

factor exceeding 1, which would not be acceptable for design. 

 

The member design details based on the selected design code for each critical member 

can be seen in the ***.nsd file which is located in the directory of data file when 

‘Export member design details (*.NSD file)’ option is selected.  

Part of the design details is shown as below. 

  ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ 

  [DESIGN ELEMENT]=    1; [NODE1]=    1, [NODE2]=    5; [LENGTH]=      3.0000 

  ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ 

 

  <ANALYSIS CASE> : LC2                                       <UNIT> :   kN,m  

 

    Load Stage    :   0                  Load Cycle    :   1 

    [My1]=-0.5001E+00 [Mz1]=-0.2565E+02; [My2]= 0.9307E+00 [Mz2]= 0.1229E+02 

    [Vy1]= 0.1265E+02 [Vz1]= 0.4770E+00; [Vy2]= 0.1265E+02 [Vz2]= 0.4770E+00 

    [P  ]=-0.4947E+02 (Compression);     [Mt ]= 0.1344E-03 (Torsion) 

    Design Moments:   [Myd]=-0.5001E+00  [Mzd]=-0.2565E+02 [ at]= 0.0000E+00 

    Design Shears :   [Vyd]= 0.1265E+02  [Vzd]= 0.4770E+00 [ at]= 0.0000E+00 

    Design Type   :   "Beam-Column"      Design Code   :   "HKSC[2011]" 

    Seismic Design:      0   (Not Considered) 

 

  <MATERIAL PROPERTIES> : S275 

 

    Elasticity Modulus, [E]=  0.2100E+09;  Yield Strength, [py]=  0.2750E+06 

    Design Strength:  [py1]=  0.2750E+06(Bending), [py2]=  0.2750E+06(Axial) 

 

  <SECTION PROPERTIES> : UB203X102X23 
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    Area = 0.3233E-02 Iz   = 0.2235E-04 Iy   = 0.1500E-05 J    = 0.1000E-06 

    Zz(+)= 0.2070E-03 Zy(+)= 0.3220E-04 Zz(-)= 0.2070E-03 Zy(-)= 0.3220E-04 

    Sz   = 0.2340E-03 Sy   = 0.3864E-04 rz   = 0.8460E-01 ry   = 0.2360E-01 

    Avz  = 0.1893E-02 Avy  = 0.1097E-02 

    Note: The plastic modului are limited to Sy= 1.20 Zy, Sz= 1.20 Zz. 

 

  <SECTION CLASSIFICATION> :       Rolled; I/H-Section 

 

    Mat. Coeff.[e]=    1.0000  [ =SQRT(275/py) ] 

    Web    : [d/t]=   34.1852  <= 80e/(1+r1)      =   67.7695 

    Flange : [b/T]=    5.4731  <= 9e              =    9.0000 

    Section Class =    [ 1 ]    "Plastic" 

    Strength Reduction Factor for Slender Section =    1.0000 

    NOTE: ELASTIC MODULUS IS USED IN DESIGN. 

 

… 

 

3.20 Step 20 – View result: check the structural adequacy by second-order analysis (ii) 

Export Summary of Analysis Results 

 

To further examine detailed second-order analysis results, click the Post > Export 

Summary of Analysis Results command; 

 

or click the <Export Summary of Analysis Results> shortcut in the toolbar; 

 

The <Export Analysis Results> window will pop up including the selection of analysis 

cases, items and output options; 
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Click ‘Select’, choose the analysis cases to be considered from the <Select Analysis 

Cases> window; 

 

Click OK to go back to the <Export Analysis Results> window; 
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Click Export, all the outputs will be generated by excel spreadsheets. 

 

3.21 Step 21 – View result: check the structural adequacy by second-order analysis (iii) 

Show Section Capacity Factor Statistics 

 

Click the Post > Member Results > Show Section Capacity Factor Statistics 

command; 

 

or click the <Show Section Capacity Factor Statistics> shortcut in the toolbar; 
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The <Section Capacity Statistics> window will appear; 

 

 

Click ‘Analysis Case’ in the <Section Capacity Statistics> window, the <Details> 

window will pop up; 

 

Click ‘Select All’ and then ‘Select’ items with ‘Load Factor Range 0.95 – 1.05’, then 

the ‘Load Cycle’ will be displayed after each analysis case; 
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Click OK to go back to the <Section Capacity Statistics> window and then select 

sections by clicking ‘Section’ in the <Section Capacity Statistics> window, the 

<Select Sections> window will then pop up; 

 

 

Import the sections to be considered and click OK to go back to the <Section Capacity 

Statistics> window; 

The bar charts showing the section capacity distributions could be sorted either by 

counting the number of members –‘By Count’ or by summarizing the weight of 

members –‘By Weight’ within each percentage range as shown below; 
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To have an overview of the section capacities of every member, a scatter chart could 

also be produced; 
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Move the mouse to one of the points with section capacity factor exceeding 1.0, the 

value of section capacity and member/cycle/stage/analysis case numbers will be 

displayed below the chart; 
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Both of the two members (9) and (11) with section capacity factors -1.3 belong to 

analysis case 5 – 2
nd

 order LC2; 

 

Click the <Select Analysis Case> shortcut in the post analysis toolbar; 

 

 

Select analysis case ‘5 – 2
nd

 order LC2’ from the <Show Analysis Case> window; 

 

Click OK to close the <Show Analysis Case> window, the deformed configuration is 

then displayed on the screen as below; 
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Select both of the two points described above,  

 

Click the <Show Selection Only> shortcut in the toolbar; 
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The two members that have failed the 2
nd

 order analysis are then displayed as below.  
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4. TUTORIAL 4 – Modal Response Spectrum Analysis 

 

A six-story rigid steel space frame originally studied by Orbison et al. is adopted here 

for demonstration of the modal response spectrum analysis (MRSA) by NIDA. The 

details of the space frame are given as below: 

(a) Geometrical dimensions and section sizes: shown in Figure as below; 

(b) The material properties for all members: Young’s modulus E=206850 MPa, shear 

modulus G=79293 MPa, yield strength py=250 MPa; 

(c) Applied loads: uniform floor pressure=9.6 kN/m2, wind loads simulated by point 

loads of 53.376 kN in Y-direction at every beam-column joints; 

(d) Boundary conditions: all columns are fixed to foundation. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

4.1 Step 1 – Build the structural model 

 

Input the nodal coordinates, material properties, section properties, applied loads, 

boundary conditions, etc., more details can be referred to tutorial 1 to 3. 

 

4.2 Step 2 – Define a response spectrum function 

 

Click the Construct > Response Spectrum Functions command, 

Node=21 

 

Member=13 
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Select the seismic design code ‘GB50011 (2011)’ and click Add to create a response 

spectrum function; 

According to GB50011, the design seismic intensity of Hong Kong is 7 (0.15g), and 

the seismic design group is 1. The site classification should be given by official 

department or site investigation, it is specified as 2 here for demonstration. 

 

Click OK to continue. 
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4.3 Step 3 – Define a modal analysis  

 

Click the Analysis > Set Analysis Cases… command, 

 

 

It should carefully consider the structural masses to get the natural periods and 

vibration modes. Besides structural self-weight, the other dead loads and part of live 

loads should be taken as structural masses manually, seen figure as below. Noted that 
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the structural self-weight is automatically included and therefore user need not add 

them as additional masses once more. 

 

Click OK to continue. 

 

After performing the modal analysis, the modal participating mass ratios will be 

shown in the trace window as below.  

 

Noted that the number of modes should meet the requirement of “at least 90% of the 

participating mass” in codes. 
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4.4 Step 4 – Create “single direction” MRSA cases 

 

Click the Analysis > Set Analysis Cases… command, 

 

 

Create a response spectrum analysis case in global x direction; 
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Create a response spectrum analysis case in global y direction; 

 

 

Create a response spectrum analysis case in global z direction; 

 

 

4.5 Step 5 – Create “directional combination” MRSA cases  

If the two horizontal components (vertical component may be also needed) of the 

seismic action need to be considered simultaneously, user need to conduct directional 

combination of several MRSA cases. 
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Click the Analysis > Set Analysis Cases… command, 
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4.6 Step 6 – Create “load combination” considering both earthquake action and 

other actions 

 

Click the Analysis > Set Analysis Cases… command; 

According to GB50011, the following load combinations are recommended in Hong 

Kong: 

(a) 1.2DL+0.28WL+1.3EQX 

(b) 1.2DL+0.28WL+1.3EQY 

(c) 1.2DL+0.28WL+1.3(EQX+EQY)+0.5EQZ 

 

Create a linear analysis case “1.2DL+0.28WL+1.3EQX”: 
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Create a linear analysis case “1.2DL+0.28WL+1.3EQY”: 
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Create a linear analysis case “1.2DL+0.28WL+1.3(EQX+EQY)+0.5EQZ”: 
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4.7 Step 7 – Run all analysis cases and view results 

 

Click the Analysis > Run or press F5 key to run all analysis cases; 
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The procedures for viewing and exporting analysis results can be referred to tutorial 1 

to 3. 
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5. TUTORIAL 5 – Time History Analysis 

 

A seven-story 2D steel frame is used here for demonstration of time history analysis 

by NIDA. The details of the 2D frame are given below: 

(a) Geometrical dimensions and section sizes: shown in Figure as below; 

(b) The material properties for all members: Young’s modulus E=2.034x105 MPa, 

Poisson’s ratio v=0.3, yield strength py=250 MPa; 

(c) Applied static loads: shown in Figure 10; 

(d) Boundary conditions: all columns are fixed to foundation and member connections 

are rigid; 

(e) Mass: 85 812.16 kg at each story (node 5, 8, 11, 14, 17, 20 and 23); 

(f) Earthquake wave: the N-S component of the El Centro 1940. 
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The procedure for performing time history analysis in NIDA (2010) is detailed as 

below. 

 

5.1 Step 1 – Build the structural model 

 

Input the nodal coordinates, material properties, section properties, applied loads, 

boundary conditions, etc., more details can be referred to tutorial 1 to 3. 

 

5.2 Step 2 – Define one or more than one time history functions 

 

Click the Construct > Time History Functions command, 

 

Select the type ‘User Record (Variable)’ and click Add to create a time history 

function; 
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Click OK to continue. 

 

5.3 Step 3 – Define a time history analysis case 

 

Click the Analysis > Set Analysis Cases… command, 
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Input the case name, select ‘Lumped Mass’, ‘Direct Integration’, ‘Transient’; give the 

‘Total Num. of Time Step’ as 400 and ‘Time Increment’ as 0.02 second.  

 

Click ‘Settings’ of integration method to give the parameters of Newmark method as 

below: 

 

 

Click ‘Settings’ of damping to give the parameters of ‘Rayleigh Damping’ as below: 
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Click ‘Advanced Settings’ to set the parameters for nonlinear solution as below: 

 

Noted that the Newton-Raphson method is used for the nonlinear incremental-iterative 

solution when performing a time history analysis. In some cases the structural 

behaviour may be highly nonlinear and therefore several cycles in each time step are 

needed. 

 

Click ‘Dynamic Function/Additional Mass’ tab to specify one or more than earthquake 

records as seismic input and the additional mass may need to be considered here. 

 

Select one of dynamic functions and click ‘>>’ to add it as seismic input for this 

analysis case; 

Select load case(s) and click ‘>>’ to add it as additional mass for this analysis case. 

Noted that the structural self-weight has been automatically included. 
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Double click the name of dynamic function and a dialog will pop up to set the ‘Scale 

Factor’, ‘Arrival Time’ and the seismic direction as below: 

 

Select load case(s) to consider 

additional mass such as SDL, 

LL 
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Click ‘Initial Loads’ tab to consider static loads such as dead loads before earthquake 

attack. 

 

5.4 Step 4 – Run time history analysis case(s) 

 

Click the Analysis > Run or press F5 key to run all analysis cases; 

 

 

5.5 Step 5 – View result: nodal displacements and base shear 

 

Click the Post > Nodal Results> Load Deflection Curve/Reactions … ;  

Double click the name  
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or press the button of post toolbar as below; 

 

 

Select node to observe the time history of nodal displacement(s); 
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Click ‘Base Shear’ tab to observe the time history of base shear in X, Y or Z direction; 

 

 

 

5.6 Step 6 – View result: plastic hinge rotation of all time steps 

 

Click the Post > Member Results> Member Load Deflection Curve… ;  

 



Tutorials – Step by Step 
 

NIDA – Nonlinear Integrated Analysis & Design  145 

or press the button of post toolbar as below; 

Select member to observe the time history of plastic hinge rotation; 

 

 

5.7 Step 7 – View result: plastic hinge location 

 

Plastic hinge (s) may be formed in different time step (load cycle); 

Plastic hinge (s) will be plotted on screen with dot marker as below: 
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To toggle show plastic hinge (s) on screen click the Post > Member Results> Toggle 

Show Plastic Hinge  

 

5.8 Step 8 – View and export results 

 

The procedures for viewing and exporting analysis results can be referred to tutorial 1 

to 3. 

 


