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1. DESCRIPTION 

 

1.1 Introduction 

In current most widely used practice for structural design, an analysis is carried out to 

determine forces and moments of all members in a frame under external loads. The 

resistance of the members is then determined using the formulae in design codes and 

compared with these moments and forces due to factored loads. When the resistance is 

larger than the applied forces and moments, the structure is deemed to be adequately 

safe. This process is illustrated in Figure 1.1. 

 

 

 

 

 

 

 

 

 

Figure 1.1 Conventional Design Procedure 

In this conventional process, the analysis is linear, but the actual behaviour of the 

structure is non-linear and buckling occurs before reaching the squash or yield load. 

Many realistic effects such as buckling and material yield are not considered in 

analysis. The checking of buckling strength of members by design formulae is carried 

out at a latter and independent stage using the design code formulae. These two steps 

are separated but, buckling, instability and second-order effects influence the stiffness 

and thus the force and moment distribution in the whole structural system. The linear 

analysis program is therefore incorrect in force and moment computation. Furthermore, 

error due to the effective length assumption used in design codes makes the final 

design output unreliable and inaccurate.  

For slender members and most steel or metal structures, instability or second-order 

effects will amplify the stress calculated from a linear analysis, so that the 

conventional method is either uneconomical or exceeding the adequate safety margin. 

Various design codes (e.g. Eurocode-3 [2005], AISC-LRFD [2010], and CoPHK 

[2011]) require the designer to include the P- effect or stability check in the analysis 

and design when the simplified formulae in codes cannot cover the effects. 

“Advanced analysis” is a new design method for steel structure in which the first-order 

and second-order or buckling effects are included, together with the characteristics of 

realistic structures, so that section capacity check as presented below is adequate for 

strength design.  

 

Nonlinear Analysis for Simple 
Idealized Individual Members 

Development of Design Rules 

Linear Analysis 

Output of Member 
Forces and Moments 

Individual Member Capacity 
Check 
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where 

Δ  Displacement due to sway of the frame measured at nodes 

δ  Displacement due to member curvature or bowing, measured along a member 

P  Axial force in member 

A  Cross sectional area 

py  Design strength 

Mcy  Moment capacity about principal y-axis 

Mcz  Moment capacity about principal z-axis 

My External moments about principal y-axis 

Mz External moments about principal z-axis 

  Section capacity factor. If  >1, member fails in section capacity check. 

 

The method has been stated in Eurocode-3 (2005), AISC-LRFD (2010) and CoPHK 

(2011) and well-researched (Chen and Chan 1995). Using this more rigorous approach, 

we can directly compute the applied sectional moments, forces or their resulting stress 

due to factored loads and compare against the structural resistance. In doing so, we can 

then skip the complex and unreliable process of checking individual member buckling 

strength based on simplified boundary and loading conditions. This better process is 

summarised in Figure 1.2. 

 

 

 

 

 

Figure 1.2 Nonlinear Analysis Design Procedure 

This program is aimed for this type of second-order non-linear analysis and the design 

meeting the code requirement for strength and stability design. When using the plastic 

modulus in input sectional properties, it follows the most widely used 

“first-plastic-hinge design concept” that the design load is obtained as the load causing 

the formation of the first plastic hinge. When the elastic modulus is used for input 

sectional properties, the analysis becomes an elastic analysis and design. The effect of 

effective length is automatically and accurately considered in the computer program 

and need not be assumed as the P-δ and the P-Δ moment simulating the effective length 

is automatically determined from the buckling analysis of the frame. In reality, in many 

practical situations, the effective length can hardly be determined (For example, the 

effective length of scaffolding, domes and many types of steel frames). The use of the 

linear analysis computer programs may be dangerous in actual design. 

Second-order Nonlinear Analysis 
With allowance for design code requirements 

Section Capacity Check 
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More details about nonlinear analysis can be found in the papers and book by Chan and 

Chui (2000), and Chan (2001). 

For design purpose, the present program adopts the Eurocode3 (2005) and the CoPHK 

(2011) design approaches where the initial imperfection is obtained from Table 5.1 in 

the Eurocode3 (2005) and Table 6.1 in the CoPHK (2011). For design of cold-formed 

and welded sections, the initial imperfection is amplified to simulate the effects of 

residual stress. 

This program contains conventional beam-column, shell and cable elements. 

 

1.2 Features of NIDA 

The present program, NIDA, is the ninth commercial version for non-linear analysis 

and combined design and analysis of frame, cable and shell structures. 

At the moment of preparing this manual, NIDA contains the linear analysis, geometric 

and material non-linear static and dynamic analysis, response spectrum analysis, 

eigenvalue buckling and vibration analysis of framed and shell structures.  

Special features contain second-order P-- analysis with considerations both of global 

and local initial imperfections, semi-rigid connections, load and construction sequences 

and cable structures.  

The theory of the program can be found in Chan and Zhou (1995), Chan and Chui 

(2000) and Chan (2001). For non-linear solution method, Chan (1988) should be 

referred to. The program follows the concept associated with the ultimate limit state 

design code with the “first-plastic-hinge” limit load criterion used in the AS4100 

(1990), BS5950 (1990, 2000), Eurocode-3 (2005), AISC-LRFD (2010),and CoPHK 

(2011). 

 

1.3 Important Disclaimer 

Considerable care has been taken to ensure the accuracy of the program. Nevertheless, 

responsibility for the use of the program rests with the user and the authors will not be 

responsible for any kind of damage caused by the use or misuse of the computer 

program. 

 

1.4 Program Limitations 

The program checks the lateral-torsional buckling of a beam using the code effective 

length method in which the effective length for beams can be easily assumed using 

code formulae whereas the effective length for columns is very much more 

complicated to assume. Also, the local plate buckling will be checked by the effective 

strength method. The effects of eccentric connection in unsymmetrical sections like 

angle and channel are ignored in default and need to be considered manually if these 

effects are significant. 

 

1.5 Assumptions 
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The analysis program is based on the second-order non-linear elastic and plastic, 

displacement based stiffness method of analysis. The right hand rule is assumed as the 

sign convention for the whole computer program. 

 

1.6 Copyright 

The computer program NIDA is proprietary and copyrighted products. Worldwide 

rights of ownership rest with Professor S.L. Chan. Unlicensed use of the program or 

reproduction of the documentation in any form, without prior written authorization 

from Professor S.L. Chan is explicitly prohibited. 

Several trademarks and registered trademarks have been introduced in this manual as 

follows: 

Windows, Excel, Access : Trademark of Microsoft Corporation 

AutoCAD : Registered Trademark of Autodesk, Inc. 

SAP2000, ETABS : Registered Trademark of Computer and Structure, Inc. 

STAAD : Registered Trademark of Bentley. 

 

1.7 Installation of NIDA 

The program can be used in Windows 9x, Windows 2000, Windows XP, Windows 

Vista and Windows 7 compatible. 

The package available to you will contain a manual, a USB key for protection of the 

version of your own program and a CD.  

Insert the compact disc to your computer and automatically the program, NIDA, is 

installed inside a directory you prefer. Alternatively, you can install the program by 

activating install.exe in the CD directory. During the installation process, it requires 

the directory, user name and company name. Click appropriate buttons until the whole 

installation process is completed which is indicated by a message on screen. 

After installation of NIDA, you need to install the key driver for standalone version 

and the server of network version. For network version, the client computer need a 

system variable in “Environment Variables” named as NSP_HOST with the value of 

IP address of the server. For more details, the document “NIDA Installation – Step by 

step” can be referred to. 
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2. GETTING STARTED 

 

This chapter includes different kinds of NIDA commands, providing a demonstration 

for the general process of computer model creation by NIDA.  

Start a model by clicking the File > New command to access the New Model form.  

Add structural objects from one of the built-in NIDA templates by clicking the 

File>New Model from Templates.  See New Model from Template for detailed 

information. 

Set the units and degrees of freedom of the model by clicking the Analysis>Analysis & 

Design Parameters Setting.  

Use the commands available in the Construct group to define Material, Frame Section, 

Shell Section, Load Case , Combined Load Case, Combined Member and Group and to 

create Node, Member, Spring element, Floor and Area. 

Use the Edit commands to modify the geometric properties of the model. There are two 

special commands, Mesh and Split member, providing certain operations. The Edit > 

Mesh command is used to mesh the areas, floors and shells. The Edit > Split members 

command can be used to break the member at intersections with selected members or 

selected Nodes. 

Use the Gr-Assign commands to assign relative properties to the model, i.e. the 

properties for the members (e.g. Section, End condition), nodes (e.g. Boundary 

condition, Nodal spring), shells , floors and areas, and to assign different types of 

loading (e.g. Member Loads, Nodal Loads, and Floor Pressure).  

If you want to read the input file of the model in text format, you can use the Tools > 

Show Data File command. You can directly edit and then save the data file. Please 

re-open the data file so that your change can be taken effect.  

Use the Analysis > Set Analysis Cases… to define and modify the analysis cases  

Use the Analysis > Analysis & Design Parameters Setting… to select the steel design 

Code, determinate the floor stiffness, and direction of Gravity and so on. 

The current model can be run by clicking Analysis >Run. Several individual models 

can be run simultaneously by clicking Analysis >Run a Batch Files. 

The deformed shape will be displayed automatically after the analysis is completed. 

The animation of the deformed shape or mode shape can be played by clicking the 

Play button in the Post bar. The cycle and speed of animation can be specified in the 

animation option bottom. 

To view the result, click the Post commands to display analysis results on your model. 

The Nodal Reaction, Load Deflection Curve/Reaction, Member Statistics, Bending 

Moment/Shear Diagram and Shell Result can be generated and displayed on screen by 

applying corresponding functions. 

Alternatively, use the Post>Show Result Files to show analysis results in text file. 

 

mk:@MSITStore:C:/Program%20Files/Computers%20and%20Structures/SAP2000%2012/SAP2000.chm::/Database_Tables/Choose_Tables_For_Form.htm
mk:@MSITStore:C:/Program%20Files/Computers%20and%20Structures/SAP2000%2012/SAP2000.chm::/Database_Tables/Choose_Tables_For_Form.htm
mk:@MSITStore:C:/Program%20Files/Computers%20and%20Structures/SAP2000%2012/SAP2000.chm::/Menus/Analyze/Set_Analysis_Options.htm
mk:@MSITStore:C:/Program%20Files/Computers%20and%20Structures/SAP2000%2012/SAP2000.chm::/Menus/Analyze/Set_Analysis_Options.htm
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3. GRAPHICAL USER INTERFACE 

 

3.1 Main Screen 

 

 

 

3.2 Menu Bar 

 

The Menu Bar provides the most commonly used functions in NIDA. The details of 

each operation are provided in Menus Chapter. 

 

3.3 Standard Bar 

 

The Standard Bar includes shortcuts of certain functions (e.g. New Project, Open 

Project, Save, …) available in the Menu bar for the ease of structure construction. 

 

3.4 Plot Zone 

The drawing area visualizes the overall structure to the user. It mainly shows:  

- the position of nodes,  

- how objects are connected,  

- the direction and magnitude of loadings, 

- the direction of member local axis, and 

- the presence of the boundary conditions, end releases, etc. 

 

Standard Bar 

Draw Bar 

Snap Bar 

Menu Bar 

Post Bar 

View Bar 

Status Bar 

Details window 

Properties window 

Plot Zone 

Output Zone 
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3.5 View Bar 

 

The view bar provides shortcuts to view certain properties of the model easily, 

including: 

- Fit to Screen 

- Zoom In 

- Zoon Out 

- Set 2-D or 3-D View 

- Perspective Mode 

- Extrude View 

- Show Selection Only 

- Visible/Invisible 

- Set Visibility of Loadings 

- Show Boundary Condition 

- Show Nodal Spring 

- Show Moment Release in y-direction 

- Show Moment Release in z-direction 

- Show Global Axis 

- Show Member Local Axis 

 

3.6 Draw Bar 

 

The draw bar provides shortcuts to create certain objects easily, including: 

- Add Member 

- Add Spring Element 

- Add Floor Element  

- Add Shell Element  

- Add Area Object 

 

3.7 Snap Bar  

 

The snap bar provides shortcuts to select certain objects easily, including: 

- Snap Node 

- Snap Member 

- Select by intersecting curve 
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- Select by intersecting line 

 

3.8 Post Bar 

 

 

The post bar provides shortcuts of to show certain analysis results easily, including: 

- Show Undeformed and Deformed Shape 

- Show Undeformed Shape 

- Show Deformed Shape 

- Display Scale 

- Show Section Capacity Factor Statistics 

- Show Load Deflection Curve/Reaction 

- Show Member Statistics 

- Show Nodal Displacements/Reactions 

- Show Bending Moment/Shear Diagram  

- Section Capacity Color 

- Show Nodal Displacement 

- Show Shell Nodal Stress 

- Select Analysis Case 

- Select Load Cycle 

- Play Animation 

- Stop Animation 

- Animation Options 

- To Export Summary of Analysis Results 

- To Export Statistics of Analysis Results 

- Export Eigen-buckling Load Factors 

 

3.9 Properties Window 

 

In the top of the properties window, there is also a toolbar named “Add Bar”. It helps 

to add the following objects to the NIDA project. 
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- Nodes 

- Members 

- Sections 

- Load Cases 

- Loadings 

- Boundary Conditions 

 

The Properties Window gives a systematic view of the project. It shows the main 

components of the structure in format of a tree.  

The topmost level is the project name.  

The components on the second level are :  

- Materials 

- Frame Sections 

- Shell Sections 

- Load Cases 

- Combined Load Cases 

- Groups 

- Advanced Groups 

 

3.10 Details Window 

 

The Details Window gives further details about the components of the project. When 

the user clicks on any object of the project, its own attributes will be available in this 

window immediately, providing a quick view to the user. 

 

3.11 Status Bar 
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The status bar shows the following items: 

- The number of objects selected or the status information about what the program is 

doing currently 

- The activated analysis case 

- The current units 

- The information of 3D view or 2D view 
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4. MENUS 

 

4.1 File 

 

4.1.1 New 

Click the File > New command to start a new model. Enter the project title in the 

window shown below.  

Select the force unit, length unit, and direction of gravity. 

Shortcut : Toolbar :  Keys : Ctrl+N 

 

 

4.1.2 New Model from Templates 

Click the File > New Model from Templates command to start a new model. 

The templates contain a number of common structural forms to assist the user to 

prepare a data file quickly. The list of the structural forms will be displayed on the next 

page.  

In current version, there are typical frame structural forms, several shell type structures 

as well as some extrude sections available for selection.  

Click the one preferred and input necessary parameters, the structure will then appear 

on the screen. 
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4.1.3 Add from Templates 

Click the File > Add from Templates command to add a template model to the model 

being constructed. 
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Input coordinates of insertion point, click a template preferred and input necessary 

parameters, the structure will then appear on screen. 

 

4.1.4 Open 

Click the File > Open command to open an existing NIDA data file (*.dat). Select the 

directory where the NIDA file is located. The project will be loaded and the structure 

will be shown on the screen. 

Shortcut : Toolbar :  Keys : Ctrl+O 

     

4.1.5 Close 

Click the File > Close command to close the current project. 

 

4.1.6 Save 

Click the File > Save command to save a NIDA model.  

NIDA will provide a file path and name for a new model. If the model has been saved 

before, NIDA will save the file with the same filename in the same location, and the 

previous file will be automatically overwritten.  

Once there has been a change in data file, there will be an asterisk “*” sign shown in 

the Window Title before saving.  

After saving, the asterisk “*” sign will hide until the project is changed again. 

Shortcut : Toolbar :  Keys : Ctrl+S 

 

  

Once there has been a change in After saving, the asterisk “*” 
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data file, there will be an asterisk 

“*” sign shown in the Window 

Title before saving. 

sign will hide until the project is 

changed again. 

 

Note:  The model will be saved automatically when the analysis is running. 

 

4.1.7 Save as 

Click the File > Save As command to save the current project to a new location. 

 

4.1.8 Import DXF 

Click the File > Import DXF command to import an AutoCAD generated file, with a 

“.dxf” extension usually. Only nodal coordinates and connectivity can be imported. For 

sake of convenience, sections are exported/imported as layers.  

Noted that the imported file must be further modified before NIDA can produce an 

analysis.  

 

4.1.9 Import STAAD 

Click the File > Import STAAD command to import an STAAD generated file, with a 

“.std” extension. 

Noted that the imported file must be further modified before NIDA can produce an 

analysis. 

 

4.1.10 Import ETABS (*.mdb) 

Click the File > Import ETABS (*.mdb) command to import an ETABS generated file, 

with a “.mdb” extension. 

Noted that the imported file must be further modified before NIDA can produce an 

analysis. 

 

4.1.11 Import SAP2000 (*.mdb) 

Click the File > Import SAP2000 (*.mdb) command to import a SAP2000 generated 

file, with a “.mdb” extension. 

Noted that the imported file must be further modified before NIDA can produce an 

analysis. 

 

 

4.1.12 Export DXF 

Click the File > Export DXF command to export an AutoCAD generated file with a 

“.dxf” extension usually. Only nodal coordinates and connectivity can be exported.  
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4.1.13 Export BMP 

Click the File > Export BMP command to export a Bitmap generated file with a “.dmp” 

extension usually.  

 

4.1.14 Print 

Click the File > Print to enter the printer setting page to select the printer, specify the 

range of pages to be printed, the number of copies, and set the page size, orientation 

and output format.  

Shortcut : Toolbar :  Keys : Ctrl+P 

     

4.1.15 Print Preview 

Click the File > Print Preview to show the document which would appear when 

printed. The print preview window will appear and replace the main window when you 

select this command. View one or two pages at the same time, zoom in or zoom out the 

document, and start the print job. 

 

4.1.16 Print Setup 

Click the File > Print Setup to set the color, font, size and date information, and to 

select the information which is required to be included such as the company name, 

section, and material information. 

 

4.1.17 Exit  

Click the File > Exit to quit the program NIDA.  
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4.2 Edit 

 

4.2.1 Undo 

Click the Edit >Undo command to cancel last operation in model processing. 

Shortcut : Toolbar : 
 

Keys : Ctrl+Z 

 

4.2.2 Redo 

Click the Edit > Redo command to restore last action in model processing.  

Shortcut : Toolbar : 
 

Keys : Ctrl+Y 

 

4.2.3 Cut 

Click the Edit > Cut command to cut the selected objects from the current model.  

Shortcut : Toolbar : 
 

Keys : Ctrl+X 

 

4.2.4 Copy 

Click the Edit > Copy command to copy the selected objects (nodes, members, shells, 

floors, areas …) to the current model. 

Shortcut : Toolbar : 
 

Keys : Ctrl+C 

 

4.2.5 Paste 

Click the Edit > Paste command to paste the selected objects to the current model. 

Shortcut : Toolbar : 
 

Keys : Ctrl+V 

There are 4 methods to paste new objects: Linear, Mirror, Radial, and Along Path. 

 Linear 
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Enter the number of increments, increments along X, Y and Z axes. And then, click 

OK button, the new structural objects such as nodes, members, and shells will be 

shown on the screen. 

 

 Mirror 

 

Select the X-Y, X-Z or Y-Z plane, and then input the coordinate of the corresponding 

axis. Click OK button and the new structural objects such as nodes, members, and 

shells will be shown on the screen. 

 

 Radial 

 

The increment angle is positive for clockwise. Click OK button and the new structural 

objects such as nodes, members, and shells will be shown on the screen. 

 

 Along Path 
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Pick up two nodes as a path, put into the incremental distance, click OK button and the 

new structural objects such as nodes, members, and shells will be shown on the screen. 

 

4.2.6 Paste Special 

Click the Edit > Paste special command to paste the selected nodes, members, floors, 

shells or all objects from Text/MS Excel file, other NIDA model to the current NIDA 

one. 

 

The number of objects pasted would be listed. 

 

4.2.7 Delete 

Click the Edit > Delete command to delete the selected objects from the current model. 

 For Node, Member, Shell, Floor and Area 

Select nodes, members, shells, floors and/or areas on the screen. 

Click the Edit > Delete command or press <DEL> key on the keyboard.  

 

 For Material 

Select one of the materials from the Properties Window, right click and choose delete 

or press <DEL> key on the keyboard.  

 

 For Section 

Select one of the sections from the Properties Window. Press <DEL> key on the 

keyboard then choose “Delete Members” or “Move Members to other Section”, see the 

options as below. 
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Press OK button.  

 

 For Load Case 

Select one of the load cases from the Properties Window. 

Press <DEL> key on the keyboard and then choose “Delete Loadings” or “Move 

Loadings to other Load Case”, see the options as below 

  

Press OK button. 

 

 For other objects (Group, Combined Load Case, etc.) 

Select the objects from the Properties Window or on the screen and press <DEL> key 

on the keyboard. 

 

4.2.8 Mesh Areas 

Click the Edit > Mesh Areas command to mesh the selected area objects into shell 

elements.  
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Delete Objects after Meshing option.  The selected area objects would be deleted 

after meshing if this option is selected. 

 

Mesh Method - Advanced option.  A group of high quality shell elements would be 

created by using this option. This function is very useful for meshing the complex area 

objects. 

Mesh Method - Simple option.  A group of simple shell elements would be created 

by using this option. This function is suitable for meshing the regular area objects. 

 

Shell Shape - Triangle option.  The shell elements with triangle shape would be 

created by clicking this option. 

Shell Shape - Quard option.  The shell elements with quadrilateral shape would be 

created by clicking this option. 

 

Normally, the objects to be meshed should be assigned the shell section and mesh size. 

If the user forgets to do the assignment or wants to mesh the objects with new meshing 

parameters, click Size Control button to set meshing parameters as below. 
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Shell Section option.  Choose which kind of shell section to be meshed to. 

Length of Divisions option.  Each edge of selected objects will be divided into 

several parts by the assigned division length. 

Number of Divisions of Edges option.  Each edge of selected objects will be divided 

into N parts by the assigned number N. 

 

After the appropriate options are selected, the meshing process can be started by 

clicking Mesh button. 

 

Click OK button to return to the main window of Mesh. The detailed operation can be 

checked by clicking the >> button.  

 

Click Merge button to merge duplicate nodes before meshing if needed.  

 

More details can be referred to Merge Duplicate Nodes. 

 

4.2.9 Merge Areas 

Click the Edit > Merge Areas command to merge the selected area(s) into one. 

 

To merge Areas into the big Area*, the selected Areas should be adjacent to Area*. 

You may pick up areas on screen to input Areas or Area*. 
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Sometimes not all areas input can be successfully merged into one. You may click Yes 

button of the popup dialog to get the information shown in Output Zone.  

 

In more complicated case, more trials are required if the first merging operation fails. 

 

4.2.10 Divide Areas 

Click the Edit > Divide Areas command to divide the selected area(s) into two parts by 

members of two nodes. 

When By Member(s) is active, only one selected area can be divided by selected 

members. 

 

When By Two Nodes is active, several selected areas can be divided by the line linked 

by two selected nodes. 
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4.2.11 Drop Edge Nodes of Areas 

Click the Edit > Drop Edge Nodes of Areas command to drop nodes (if any) of the 

edges of the selected areas. 

 

 

 

4.2.12 Trim/Extend Members 

 

Click the Edit > Trim/Extend Members command to modify members by trimming or 

extending them with the reference line which they are not parallel to.  

User needs to input the reference line by selecting a member on screen. Further, user 

needs to select members for trimming or extending or both. 

 

Enable Member Intersection 

To enable splitting reference member at the intersection points (if any) between the 

modified members and reference member.  

Split Reference Member 

If this option is active, the reference member will be split into two members at the 

intersection point. 

Member Distance Tolerance 

This indicates to split the reference member only if the distance of two points 

perpendicularly between the modified member and reference member is less than the 

[member distance tolerance]. 
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4.2.13 Split Members 

Click the Edit > Split Members command to split the selected members into n equal 

parts. In “Options”, you can offset the member with a given value along member local 

y or z direction to specify the member imperfection manually or to create a curved 

member by several elements.  

 

 

You can break the members at intersections with selected members or selected nodes. 

 

In Advanced setting, the variable I, CHS, Tee and RHS sections can be simulated by a 

number of members with a series of uniform sections. The parameters of the section at 

two ends will be input and the section will be changed uniformly from the large section 

to a small one. 
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4.2.14 Merge Duplicate Nodes 

Click the Edit > Merge Duplicate Nodes command to join those nodes with duplicate 

properties.  

 

The Nodes Distance Tolerance value according to the minimum size and the units of 

the structure should be input before starting this action. After that, the nodes whose 

distances are less than [Nodes Distance Tolerance] will be merged to one. 

The Node Retention Priority option will help to select the node to be remained 

automatically. 
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Click the Report button to show the details of the nodes merged already. 

 

4.2.15 Move Nodes 

Click the Edit > Move Nodes command to move the selected nodes (including the 

objects connected to the nodes) to the new position. 

Shortcut : Toolbar : None Keys : Ctrl+M 

 

 By Increment 

This option is to move the selected nodes to a new position by incremental coordinates 

in X, Y and Z axes with respective to the original one.  

   

 

 Along Path   

This option is to move the selected nodes along a path defined by 2 nodes.  
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Note: The connected objects by the nodes will be changed after this operation. 

 

4.2.16 Rotate Nodes 

Click the Edit > Rotate Nodes command to rotate the nodes (including the objects 

connected to the nodes) about X, Y or Z axis. 

 

User needs to select an axis and fill in two coordinates to determine the reference axis. 

And then fill in the angle and select the direction to rotate. After that, the selected 

objects will be re-generated by rotating the reference axis with the angle.  

The original objects will be deleted forever. 

 

4.2.17 Align Nodes 

Click the Edit > Align Nodes command to align selected nodes (including the objects 

connected to the nodes) to X, Y and/or Z coordinates or lines.  

Align to Coordinate(s) option.  The command is to align the selected nodes to the 

given coordinate(s). 
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Align to Line option. The command is to align the selected nodes to the reference line. 

 

 

4.2.18 Sort Serial Numbers 

Click the Edit > Sort Serial Numbers command to re-sort the number of node, member, 

shell, floor and spring elements according to their coordinates.  

 

 

4.2.19 Check Node for Rigid Body Rotation 

Click the Edit > Check Node for Rigid Body Rotation command to check if there are 

any nodes which have not been rigidly linked. 

If some of the nodes have not been rigidly linked, they will be shown as below. 
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If all nodes have been rigidly linked, then a message dialog will pop up as below. 

 

Important: Once some of the nodes have not been rigidly linked, the stiffness matrix 

may be singular and the structure will be unstable, and the stability problem may occur 

in the process of analysis. This checking is very important for nonlinear analysis. 

 

4.2.20 Check Overlap Members 

Click the Edit > Check Overlap Members command to check if there are any members 

overlapping each other. The overlapped members can be stored in group for further 

operation. 

 

 

4.2.21 Check Coplane of Shell & Floor 

Click the Edit > Check Coplane of Shell & Floor command to check if there are any 

four nodes of shell and/or floor elements not in the same plane. The shell and/or floor 

elements with noncoplanar nodes can be stored in group for further operation. 
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4.2.22 Find 

Click the Edit > Find command to find the node, member, shell, spring, floor and area 

objects by their unique numbers in the project quickly. 

Shortcut : Toolbar : None Keys : Ctrl+F 

 

Input the No. of a certain kind of objects (e.g. Node, Member, Shell, Spring, Floor and 

Area) and click Find button. If the number is valid, the corresponding object will be 

highlighted on the screen. 
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4.3 Select 

 When the Select function is on, left click and hold the mouse to enclose all the 

objects to be selected before releasing. There is a general rule regarding the direction to 

which the mouse moves. 

 

When the mouse moves rightwards following the paths like the arrows below, objects 

with any part enclosed by the dotted line will be selected, indicated in black. 

 

When the mouse moves leftwards following the paths like the arrows below, only 

objects with all nodes completely enclosed by the dotted line will be selected, indicated 

in black below as well. 

 

To multi-select or add objects in addition to the existing selection, press the Ctrl key 

while undergoing the Select procedure; 

Or to unselect any one of a group of objects, press the Ctrl key and click on the objects 

to be unselected. 

 

4.3.1 Select All 

Click the Select > Select All command to select all objects of the project. 

Shortcut : Toolbar : None Keys : Ctrl+A 
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4.3.2 Deselect 

Click the Select > Deselect command to deselect the objects which were selected on 

the screen.  

Shortcut : Toolbar : None Keys : Ctrl+D 

 

4.3.3 Inverse 

Click the Select > Inverse command to inverse the selection so that the unselected 

object can be selected and the selected object becomes unselected.  

Shortcut : Toolbar : None Keys : Ctrl +Shift +I 

 

4.3.4 Nodes by Boundary Condition 

Click the Select > Nodes by Boundary Condition command to select the nodes by 

typical boundary conditions such as Fixed, Pin, Roller, Fully Free.  

 

4.3.5 Members by Plastic Hinge 

Click the Select > Members by Plastic Hinge command to select the members which 

are allowed for plastic hinges or those are not allowed for plastic hinges by clicking 

“Allowed” or “Disallowed”. 

 

4.3.6 Shells by Normal Direction 

Click the Select > Shells by Normal Direction command to select the shells by normal 

direction. The direction vector can be defined by picking up members, shells or floors 

on the screen. 

 

 

4.3.7 Floors by Normal Direction 

Click the Select > Floors by Normal Direction command to select the floors by normal 

direction. The direction vector can be defined by picking up members, shells or floors 

on the screen. 
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4.3.8 Sections 

Click the Select > Sections command to select members by section name. 

 

 

4.3.9 Materials 

Click the Select > Materials command to select members by material name. 

 

 

4.3.10 Multi-select Objects 
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Click the Select > Multi-select Objects command to select the specified range of 

objects by number. 

 

Select the object type and input the number of the objects or pick up them from the 

screen. Click the Select button and the selected objects will be highlighted on screen. 
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4.4 View 

 

4.4.1 Set 3-D View 

Click the View > Set 3-D View command to adjust the 3D view.  

 

The X, Y or Z axis can be rotated with a specific angle for better view.  

The 3-D view could also be set by clicking the  button in view bar. 

Relative topic: Set 2-D View 

 

4.4.2 Set 2-D View 

Click the View > Set 2-D View command to set the 2D View.  

 

The Y-Z, X-Z or X-Y plane could be selected by choosing an appropriate X, Y or Z 

coordinate. 

The 2-D view in Y-Z, X-Z or X-Y plane could also be set by clicking the , 

 or button in view bar. 

Relative topic: Set 3-D View 

 

4.4.3 Zoom 

Click the View > Zoom command to enlarge a specific part of the model to view. 



Menus 
 

NIDA – Nonlinear Integrated Analysis & Design  36 

Shortcut : Toolbar :  Keys : None 

 

4.4.4 Zoom In and Zoom Out 

Click the View > Zoom In or View > Zoom Out command to zoom in or zoon out the 

model on the screen. 

Shortcut : Toolbar :      Keys : +,- (in Num. keyboard) 

 

4.4.5 Fit to Screen 

Click the View > Fit to Screen command to redraw and fit the entire structure on the 

screen. 

Shortcut : Toolbar :  Keys : Alt +Z 

 

4.4.6 Pan 

Click the View > Pan command to move the entire structure on the screen. The mouse 

pointer will change to “Hand” sign. 

Shortcut : Toolbar :  Keys : Arrow (up, down, left, right) 

 

4.4.7 Rotate 

Click the View > Rotate command to rotate the entire structure on the screen. 

Semi-circular arrow will be shown on the plotted area for rotating the structure by 

moving the mouse. 

Shortcut : Toolbar :  Keys : A, S, D, W 

 

4.4.8 Visible/Invisible 

Click the View > Visible/Invisible command to select the different objects to be 

displayed on the screen. 

Shortcut : Toolbar :  Keys : F4 
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Select the item by a “tick” in the box, and then press OK or Apply button. Your 

selected items will be displayed on plotted area. 

 

4.4.9 Show Selection Only 

Click the View > Show Selection Only command to view the selected objects only. 

Shortcut : Toolbar :  Keys : None 

     

 Before operation: 

 

 After operation: 
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To reshow all objects, un-press  button in the Toolbar. 

 

4.4.10 Remove Selection from View 

Click the View > Remove Selection from View command to remove the selected objects 

from the screen. To show the hide objects again click the View > Show Selection Only 

command. 

Shortcut : Toolbar : None Keys : Alt +R 

 

4.4.11 Extrude View 

Click the View >Extrude View command to access the extrude view. The section shape 

of members can be shown on the screen. Select member(s) and zoom in, then the shape 

can be viewed more clearly. This function can help to identify the member local axis. 

Shortcut : Toolbar : 
 

Keys : None 

Un-press  button, then the members will be redrawn by line only. 

 

4.4.12 Perspective Mode 

Click the View > Perspective Mode command to view the model in perspective modes. 

Shortcut : Toolbar :  Keys : None 

 

4.4.13 Toolbar 

Click the View > Toolbar command to select the toolbar items, standard, view, snap, 

output, post, properties and details window, to be shown in the main window. 

To reset the toolbars to default location click the View > Toolbar> Reset command. 

Reference: Graphical User Interface 
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4.4.14 Status Bar 

Click the View > Status Bar command to select whether or not to show the status bar at 

the bottom of the window. 
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4.5 Construct 

 

4.5.1 New Material 

Click the Construct > New Material command to define a new material.  

 

 

 

Click the Import button to import a new material according to the available design 

codes, and the material properties will be filled in the material dialog automatically. 

The material properties can also be input manually.  

After the material is defined, the new material entry will be shown in the Properties 

Window on the right side of the screen. Right click the head of material, then a pop-up 

menu will be shown as below.  

 

Delete, Duplicate or edit the properties of the selected material, and Set Color for the 

material by right clicking the Material Row of Properties window. 

Right click 
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To edit a material, double click the head of material and the Material Dialog will pop 

up. Change the values and click OK button 

To Delete a material, highlight the head of material and press <Delete> key. Noted that 

only the mateiral which has not been assigned to any objects can be deleted directly. 

 

4.5.2 New Frame Section 

Click the Construct > New Frame Section command to define a new frame section. A 

group of sections could be added by using Construct > New Frame Section>Import 

Sections command and the section type be selected from available section table. There 

are several commonly used section types available according to the five major standard 

codes such as U.K., China, Europe, U.S. and Japan codes. 

Shortcut : Toolbar :  Keys : None 

  

Select the frame section(s) and click OK button.  

Sections could also be added one-by-one using Construct > New Frame Section> New 

Sections command.  
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Sections could be imported from available section table by clicking Import button in 

the New Section Window. 

 

User can also define a section by input the dimensions directly by clicking the 

Customize button.  

 

There are 18 types of section available for customization, i.e. Rectangular, Circular, 

Box [RHS/SHS], CHS [Tube], I/H-Section, Mono I-Section, Channel, Single Angle, Tee 

Section, Double Angle, Double Channel, Double Box, I-Box Section, Two Box, 

Z-Section, Cross Plate, Trap. Hollow and Triangle Hollow.  
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Noted that only the sections with typical shape (e.g. Box [RHS/SHS], CHS [Tube], 

I/H-Section, Channel) specified in design code can perform member stability check. 

Select the section shape, and then click the Add button to input the dimensions of the 

section. After that, click the Import button to import this section, and the section 

properties of the customized section will be input in the New Section window.  

  

 

Either elastic section modulus or plastic section modulus can be selected by clicking 

Use Elastic (Z) or Use Plastic(S) button. The plastic section modulus is limited to 1.2 

times the elastic modulus by default and user can modify it if needed.  

Generally, NIDA will check the section classification by design code if the design 

function is active in analysis. If “b/T” and “D/t” ratios cannot meet the requirements of 

the code (e.g. Class 3 and Class 4 sections), the elastic section modulus will be 

automatically used even the option “Use Plastic(S)” is selected. 

 

 

Suppress Frame Eigen-imperfection option enables the ignorance or allowance of the 

members under this section group in computation of Eigen-imperfection of the frame. 

This may be required by bracing members to avoid buckling mode of the frame being 

dominated by the buckling mode of the braces. 

 

Select the section type by clicking the Rolled section, Fabricated section or 

Cold-formed section button. In some design codes (e.g. CoPHK 2011) the design 

strength py of the compression member using fabricated section should be reduced by 

20 N/mm
2
. For other cases, user may enlarge the member imperfection by code for 

fabricated and cold-formed sections. 
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By default, the member local P- imperfection will be set for different section types 

according to the design Code in use. For Eurocode-3 (2005), there are two types of 

initial imperfection to select from, i.e. “Elastic Imperfection” and “Plastic Imperfection” 

respectively.  

The member imperfection is valid for nonlinear analysis and time history analysis. For 

other analysis cases, the member imperfection will be automatically ignored. 

 

. 

Generally, the Stress Type of circular and circular hollow sections should be 

“Square-root of Stress” while other type of sections can be “Direct Sum of Stress” 

2 2

Square Root of Stress
y z

c

M MP

A M


   

Direct Sum of Stress
y z

cy cz

M MP

A M M
    

To create a group of tension members, set Stress Type as “Tension Only”. This option 

is usually for cable elements. 

To create a group of compression members, set Stress Type as “Compression Only”. 

This option is usually for soil spring element, infilled wall. 

 

User can modify the section properties by changing the dimensions. After changing the 

dimensions, user needs to click the Recalculate button to confirm and calculate the 

new values to overwrite the old ones. 

            

 

Click the Advanced button to view the advanced section design properties information. 

If the properties are zero or blank, the program will automatically calculate them by 

their dimensions if needed. Once the properties are input, the program will adopt the 

user defined values for design. For slender (Class 4) section, the effective properties 



Menus 
 

NIDA – Nonlinear Integrated Analysis & Design  45 

should be filled in if the effective width method is used, otherwise, the effective stress 

method will be used. Also, the plastic limit could be modified in this dialog. 

 

 

The new frame section entry will be shown in the Properties Window on the right side 

of the screen. Right click the head of Frame Section, a pop-up menu will be shown.  

 

Delete, duplicate and change the settings of the frame section by right clicking the 

Frame Sections Row of Properties window. 

Right click 
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4.5.3 New Shell Section 

Click the Construct > New Shell Section command to define a new shell section. 

 

Input the name of the shell, thickness of the shell for bending and membrane, also 

select the defined material and type for the shell section in the Shell Section window. If 

the “Membrane Only” or “Plate Only” is selected, more boundary conditions may be 

needed to restrain the in-plane or out-of-plane degrees of freedom.  

In most cases, the thicknesses for bending action and membrane action should be same. 

For some structural elements, the stiffness contribution of bending and membrane may 

depend on the behavior of materials used. For instant, the bending stiffness of concrete 

slab may be significantly affected by the concrete crack and in such case the bending 

thickness should be reduced accordingly.  

Noted that when the thicknesses are different the self-weight and structural masses will 

be calculated using the maximum one. 

After the shell section is defined, the new shell section entry will be shown on the 

Properties Window on the right side of the screen.  
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Right click the head of Shell Sections, and a pop-up menu is shown. Delete, duplicate 

and change the settings of the shell section by right clicking the Shell Sections Row of 

Properties Window. 

 

 

4.5.4 New Nodes 

Click the Construct > New Nodes command to define a new node.  

Shortcut : Toolbar :  Keys : None 

Fill in the nodal coordinates in the dialog, and then a new node will be created and 

shown on the screen.  

 

Offset mode could also be used to create a new node by filling in incremental 

coordinates.  

Right click 
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The node properties can also be changed by simply double clicking it on the screen and 

then a node properties dialog will pop up. 

 

4.5.5 New Members 

Click the Construct > New Members command to define a new member.  

Shortcut : Toolbar :  Keys : None 

 

Select the section and end condition of the new member and select the starting and 

ending node for the new member. 

 

4.5.6 New Spring Elements 

Click the Construct > New Spring Elements command to define a new spring element. 

Shortcut : Toolbar :  Keys : None 

 

User can input or select two nodes on the screen to define a spring element. Each node 

has six degrees of freedom. The definition of the local axis of the spring element is 

same as general beam-column element. The local axis is important as the element 
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stiffness is formed in this coordinate system first and then transferred to global 

coordinate system. 

 

The element stiffness matrix is formed by six independent springs, i.e., axial spring, 

shear springs along y/z-axis, torsional spring, bending springs about y/z-axis. If the 

contribution of the spring is ignorable the corresponding spring can be left blank.  

Noted that the spring model can be defined in “Semi-Rigid/Spring Models”. If the 

nonlinear spring model(s) is used, the spring element may behave nonlinearly. 

 

The new spring element would appear on the screen when the OK button is clicked.  

 

4.5.7 New Areas 

Click the Construct > New Areas command to define a new area. 

Shortcut : Toolbar :  Keys : None 

 

In the New Area window, input or pick up the nodes on the screen which are used to 

form an area. Click the Apply button and a new area will be created. 

A new area could also be created by clicking the shortcut and picking up the nodes on 

the screen. 
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To obtain more information about the construction of an area, click the information 

button . 

Warning: Areas are not structural objects and therefore all their properties such as 

section assignment and loading assignment are invalid in the analysis before they are 

converted to floor or shell elements. The area properties will be converted to the 

corresponding floor/shell properties after they are converted to floor/shell elements. 

The function of AREA is to help to create complex structures with floor/shell 

elements. 

 

4.5.8 New Load Cases 

Click the Construct > New Load Cases command to define a new load case.  

Shortcut : Toolbar :  Keys : None 

 

A load case is a container to save loadings, such as dead loads, live loads, wind loads 

and so on. 

Fill in the load case name and factor in the New Load Case window. Click Show 

Loadings on Structure and Show Values buttons to show all of the loadings as well as 

the values belong to them on the screen.  

If the self-weight are to be added to all members, shells or floors in the load case, click 

the Auto Self Weight button. Click Settings button and a dialog will pop up as below. 

 

After the load case is defined, the new load case entry will be shown on the Properties 

Window on the right side of the screen.  
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Right click the head of Load Cases, a pop-up menu will be shown. Delete, duplicate 

and change the load factor and properties of the load case by right clicking the Load 

Cases of Properties window. 

 

4.5.9 New Combined Load Cases 

Click the Construct > New Combined Load Cases command to define a new combined 

load case.  

 

A combined load case is a group of load cases with load factors for ULS (ultimate limit 

state) check, SLS (serviceability limit state) check or other purposes. A combined load 

case can be used in a linear, nonlinear, eigenvalue buckling or time history analysis. 

Fill in name and factor for the new combined load case in the Combined Load Case 

Window.  

To add load cases into the combined load case, one or more existed load cases should 

be selected from the left side, provide a load factor for the load cases, and press  

button to add to the new combined load case. All of the load cases could be added 

together into the combined load cases by pressing  button.  

To remove load cases from the combined load case, you have to select one or more 

existing load cases from right side and press  button to remove from the new 

combined load case. All of the load cases can also be removed from the combined load 

cases simultaneously by pressing  button.  
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After the combined load case is defined, the new combined load case entry will be 

shown in the Properties Window on the right side of screen. Right click the head of 

Combined Load Cases, and a pop-up menu will be shown. Delete, duplicate and 

change the load factor and properties of the load case by right clicking the Combined 

Load Cases of Properties window.  

Analysis cases could also be generated directly with the selected combined load cases. 

  

 

4.5.10 New Combined Members 

Click the Construct > New Combined Members command to combine a group of 

selected elements into a combined member for easy checking of deflection or consider 

the imperfection as a single member. For the latter use, the combined members will be 

like super elements.  

All elements in a combined member should be continuous and parallel to each other. 

When considering member imperfection, all elements in a combined member should be 

assigned with same section and the local axes of all elements should be same direction. 

Shortcut : Toolbar : None Keys : F7 

If several members are successfully combined, a message will show as follows: 

 

 

To edit, delete the combined members, double click the head of “Combined Members” 

in Properties Window on the right side of the screen as below. 
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A dialog will pop up as below. This dialog shows the number of elements, total length 

and setting of imperfection of each combined member.  

To add a combined member, please select a group of elements on screen and then click 

“Add” button. 

To modify the imperfection, select a number of combined members and choose the 

direction such as “Both Axes”, “y-axis” and “z-axis” in “Options” and then click 

“Modify” button.  

“Both Axes” means that the imperfections of both major and minor axes will be treated 

as a single member which follows a sinusoidal curve. “Y-axis” means that the 

imperfection of the combined member in y axis will be treated as a single member 

while the imperfection in z axis will follow the individual elements of it.  

       

 

e0 

(4) 

(3) 

(2) 

(1) 

Imperfection in one 

direction of a 

combined member 
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Imperfection of a combined member in “z-axis” 

 

Generally “one element per member” is adequate to capture the structural behavior in 

NIDA. The imperfection of combined member is usually for a member divided into 

several elements or a physical member spanning across multiple members and its 

buckling lengths in two directions are different. 

 

4.5.11 Diaphragms 

Click the Construct > Diaphragms command to define a new diaphragm. A diaphragm 

is a group of nodes in the same plane connected to a C.G. Node with internal spring 

elements with infinite stiffness “-1”. Generally, the nodes at the same story can be 

assigned to a diaphragm. 

Click Add New to define a diaphragm. The default stiffness of internal spring elements 

is set as “-1” which means infinite stiffness. User can change the stiffness if needed. 

When the stiffness is zero, the diaphragm will be ignored in the analysis. The default 

C.G. Node is zero which means the C.G. Node should be further determined by user. 

Select a number of nodes on the screen and choose Add Sel. Nodes, and then click OK 

button to add nodes to the selected diaphragm. 

Select a number of nodes on the screen and choose Remove Sel. Nodes, and then click 

OK button to remove nodes from the selected diaphragm. 

User can edit the CG Node and Stiffness manually or click Cal. CG Node to determine 

it automatically. 

 

Imperfection of all 

elements along z-axis 

as a single member 

Imperfection of each 

element along y-axis 
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After the diaphragm is defined, the new diaphragm entry will be shown on the 

Advanced Groups of Properties window on the right side of screen.  

 

4.5.12 Response Spectrum Functions 

Click the Construct > Response Spectrum Functions command to define a new 

response spectrum function. 

Three seismic design codes, i.e. GB50011-2010 (China), Eurocode8 (2004) and IS 

1893:2002 (India), and User Defined are available for defining a new response 

spectrum. After selecting the design code, click the Add button to define a new 

response spectrum function.  
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 GB50011 (2010) 

 

Seismic Intensity (SI) level: Six levels are available for selection.  

Max Influence Factor (Amax): Two values are available for selection. 

Characteristic ground period (TG): This value can be determined by. 

(1)Site Classification and Seismic Design Group 

Site Classification: Four site types are available for selection. 

Seismic Design Group: Three groups are available for selection. 

(2)User Defined 

Customize: Define the characteristic ground period TG manually. 

Function Damping Ratio: Enter the function damping ratio. 

Period Reduction Factor: Range from 0 to 1.0. This value is to consider the influence 

of non-structural elements such as infill walls to the periods. 

 

 Eurocode8 (2004) 
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 IS1893 (2002) 

 

Seismic Zone Factor (Z): Enter the value of seismic zone factor 

Important Factor (I): Enter the value of importance factor 

Response Reduction Factor (R’): Enter the response reduction factor 

Soil Type: Select the soil type 

 

4.5.13 Time History Functions 

Click the Construct > Define Time History Functions command to define a new time 

history function. 
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Seven types of functions, i.e. User Record (Constant), User Record (Variable), Sine 

Function, Cosine Function, Ramp Function, Sawtooth Function and Triangular 

Function are available for defining a new time history. 

 

 User Record (Constant) 

 

To scale an earthquake or artificial wave, user can select “By” or “To” mode. For “By” 

option, the wave will be scaled by multiplying the factor. For “To” option, the scale 

factor is equal to [given value] / [peak value]. 

 

 

To create elastic response spectrum, click Response Spectrum button. The obtained 

spectrum can be plotted against those defined in Response Spectrum Functions. 
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 User Record (Variable)  

 

 

 Sine Function 
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 Cosine Function 

 

 

 Ramp Function 
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 Sawtooth Function  

 

 

 Triangular Function 
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4.5.14 Semi-Rigid/Spring Models 

Click the Construct > Semi-Rigid/Spring Models command to define a semi-rigid 

model for beam-column element or a spring model for spring element and support 

spring. 

 

 

Type: Two kinds of relationships, i.e. Moment -Rotation and Force-Displacement are 

available. 

 Moment-Rotation 

(1) Linear Model 
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(2) Bi-linear Model 

 
 

(3) Three-parameter power model 
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(4) Four-parameter power model 

 
 

(5) Multi-linear model 
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 Force-Displacement 

(1) Linear Model 

 
 

(2) Bi-linear Model 
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(3) Multi-linear Model 

 

 

4.5.15 Node Local Axis 

Click the Construct > Node Local Axis command to define the local axis for specific 

nodes. 

There are two methods to create a node local axis, i.e. By 3 Nodes and By 3 Angles. 
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4.5.16 Groups 

Click the Construct > Groups command to define a new group.  

 

A group can contain a group of nodes, members, shells, floors, areas and their 

combination. 

You can add, rename and delete the group. After a group is defined, a new group entry 

will be shown under the Groups of Properties window on the right side of screen.  
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4.6 Gr-Assign 

 

4.6.1 Nodes 

4.6.1.1 Boundary Conditions 

Click the Gr-Assign >Nodes>Boundary Conditions command to set the boundary 

condition of an individual node or a group of nodes.  

Shortcut : Toolbar :  Keys : None 

 

The boundary condition of the node could also be changed by double clicking the node 

and changing it in Boundary tab window. 

 

4.6.1.2 Node Support Springs 

Click the Gr-Assign >Nodes>Node Support Springs… command to set the node 

support spring of the selected nodes.  

 

The spring model(s) used should be defined in “Semi-Rigid/Spring Models” first. The 

support spring could also be changed by double clicking the node in “Spring” tab of 

node properties window. 

 

4.6.1.3 Node Local Axis 
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Click the Gr-Assign >Nodes>Node Local Axis command to set the node local axes of 

the selected nodes. The node local axis is used to consider inclined support and the 

joint loads in local axis. 

 

 

4.6.2 Members 

4.6.2.1 Section 

Click the Gr-Assign > Members>Section command to assign a defined section to an 

individual member or a group of members.  

 

 

The member section could also be changed by double clicking the member and 

changing it in member properties window. 

The frame section can be defined in New Frame Section. 

 

4.6.2.2 End Conditions 

Click the Gr-Assign > Members>End Conditions command to assign the end condition 

to both ends of an individual member or a group of members.  



Menus 
 

NIDA – Nonlinear Integrated Analysis & Design  70 

 

You can also change the connection stiffness of both ends by double clicking the 

member and change it in “End Conditions” tab of member property window. 

Fast function enables a quick select of the end condition. The Pin button means the pin 

ends for both nodes. The Rigid button means the rigid ends for both nodes. The P1R2 

button means pin end for the first node and rigid end for the second node. The P2R1 

button means pin end for the second node and rigid end for the first node. Also Define 

Semi-Rigid button can be used to define semi-rigid connections. 

 

4.6.2.3 Effective Length 

Click the Gr-Assign > Members>Effective Length command to assign the effective 

length or effective length factor to an individual member or a group of members (Beam 

and Column), and to select the loading condition (Normal or Destabilizing) for beam 

design.  

 

You can also assign the effective length of the member by double clicking the member 

and assign in Design tab of member properties window. 
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Click the Tip button to view the definition of effective length. 

Note: The recommended beam and column effective length factors refer to CoPHK 

(2011) or BS5950 (2000). The column effective length factors are invalid in nonlinear 

analysis. 

 

4.6.2.4 Eccentricity 

Click the Gr-Assign > Members>Eccentricity command to assign eccentricity to an 

individual member or a group of members. 

 

 

 

 

 

 

 

 

 

4.6.2.5 Member Local Axis 

Click the Gr-Assign > Members>Member Local Axis command to define the member 

local axis system by K-Node, degrees or K-Node coordinates.  

(1) When “K-Node” is chosen, a node should be picked up on screen or input directly. 

Note: the k-node should be defined before clicking Apply and local xy-plane will tilt to 

contain k-node. 

y 

z ey 

ez 

End Section Eccentricity 

i/j-Node 

(at centroid) 

ei ej 

End Length Offset 

i-Node j-Node 
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(2) When “In Degree” is chosen, an angle is required to be specified. 

 

 

(3) When “K-Node Coordinates” is chosen, 3 coordinates should be input in global 

coordinate system to define a k-node. Note: k-node needs not be defined before using 

it. 

 

 

4.6.2.6 Plastic Hinge 

Click the Gr-Assign > Members>Plastic Hinge command to choose whether or not to 

allow for plastic hinge. 
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4.6.2.7 More Design Parameters 

Click the Gr-Assign > Members>More Design Parameters… command to set the 

member design type such as column, beam and brace and the seismic performance 

according to GB 50011 of the selected members. 

 

 

4.6.2.8 Reverse Connectivity 

Click the Gr-Assign > Members>Reverse Connectivity command to reverse the 

connectivity of the selected members. 

 

4.6.3 Springs 

4.6.3.1 Stiffness of Spring 

Click the Gr-Assign >Springs> Stiffness command to assign one or more than one 

defined spring models to an individual spring element or a group of spring elements.  
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You can also select and double click a spring element and then change its stiffness in 

spring properties window. 

 

4.6.3.2 Spring Local Axis 

Click the Gr-Assign > Springs> Local Axis… command to define the spring local axis 

system by K-Node, degrees or K-Node coordinates.  

 

 

4.6.3.3 Reverse Connectivity 

Click the Gr-Assign > Springs>Reverse Connectivity command to reverse the 

connectivity of the selected spring elements. 

 

4.6.4 Shells 

4.6.4.1 Section 

Click the Gr-Assign >Shells> Section command to assign a section to an individual 

shell or a group of shells.  
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You can also select and double click a shell and then change its section in shell 

properties window. 

 

4.6.4.2 One-Way/Two-Way 

Click the Gr-Assign >Shells>One-Way/Two-Way command to assign the load 

distribution mode to an individual shell or a group of shells. 

 

 

4.6.4.3 Reverse Normal Direction 

Click the Gr-Assign >Shells>Reverse Normal Direction command to reverse the 

normal direction of the selected shells. 

 

4.6.4.4 Convert to 2 Triangular Shells 

Click the Gr-Assign >Shells>Convert to 2 Triangular Shells command to convert the 

selected shells to 2 triangular shells. 

 

4.6.4.5 Convert to 4 Triangular Shells 

Click the Gr-Assign >Shells>Convert to 4 Triangular Shells command to convert the 

selected shells to 4 triangular shells. 
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4.6.4.6 Convert to Floor 

Click the Gr-Assign >Shells>Convert to Floor command to convert the selected shells 

to floors. 

 

4.6.4.7 Convert to Area 

Click the Gr-Assign >Shells>Convert to Area command to convert the selected shells 

to areas. 

 

4.6.5 Floors 

4.6.5.1 Section 

Click the Gr-Assign >Floors> Section command to assign a section to an individual 

floor or a group of floors.  

 

You can also change the section by clicking the floor and changing it in floor 

properties window. 

Noted that the section assigned to floor elements for calculation of self-weight and 

structural mass and also for conversion of shell elements but not the stiffness. The 

stiffness of all floor elements are defined in Analysis>Analysis & Design Parameters 

Setting as below.  
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4.6.5.2 One-Way/Two-Way 

Click the Gr-Assign >Floors>One-Way/Two-Way command to assign the load 

distribution mode to an individual floor or a group of floors. 

 

 

4.6.5.3 Reverse Normal Direction 

Click the Gr-Assign >Floors>Reverse Normal Direction command to reverse the 

normal direction of the selected floors. 

 

4.6.5.4 Convert to 2 Triangular Shell Elements 

Click the Gr-Assign >Floors>Convert to 2 Triangular Shell Elements command to 

convert the selected floors to 2 triangular shell elements. 

 

4.6.5.5 Convert to 4 Triangular Shell Elements 

Click the Gr-Assign >Floors>Convert to 4 Triangular Shell Elements command to 

convert the selected floors to 2 triangular shell elements  

 

4.6.5.6 Convert to Quard Shells 
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Click the Gr-Assign >Floors>Convert to Quard Shells command to convert the 

selected floors to shell in a rectangular shape.  

 

4.6.5.7 Convert to Area 

Click the Gr-Assign >Floors>Convert to Area command to convert the selected floors 

to areas. 

 

4.6.6 Areas 

4.6.6.1 Set Meshing Parameters 

Click the Gr-Assign >Areas>Set Meshing Parameters command to set up the 

parameters for meshing operation. 

 

Select the shell section and input the mesh size or the number of the parts for all edges 

for meshing.  

 

4.6.6.2 Reverse Normal Direction 

Click the Gr-Assign >Areas>Reverse Normal Direction command to reverse the 

normal direction of the selected areas. 

 

4.6.6.3 Convert to Floor Elements 

Click the Gr-Assign >Area>Convert to Floor Elements command to convert the 

selected areas to floor element. 

 

4.6.6.4 Drop Edge Nodes of Areas 

Click the Gr-Assign >Drop Edge Nodes of Areas command to drop nodes (if any) at 

the edges of the selected areas.  

 

4.6.7 Node Loads 

4.6.7.1 Joint Loads 
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Click the Gr-Assign >Nodal Loads>Joint Loads command to assign joint load to 

selected nodes.  

 

Fill in the value of forces and moments in X, Y and Z directions.  

 

4.6.7.2 Settlements 

Click the Gr-Assign >Nodal Loads>Settlements command to assign support settlement 

to the selected nodes with boundary conditions.  
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Fill in the value of settlement and select the axis and direction. 

 

4.6.8 Member Loads 

4.6.8.1 Point Loads 

Click the Gr-Assign >Member Loads>Point Loads command to assign the point load 

to selected members.  

 

Fill in the magnitude, distance from left (i.e. distance from the node with smaller 

number to one with larger number), load distance type, and axis and direction.  

 

4.6.8.2 Trapezoidal Loads 

Click the Gr-Assign >Member Loads>Trapezoidal Loads command to assign the 

trapezoidal load to selected members.  
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Four types of trapezoidal loads are available, i.e. UDL, Trapezoid, Triangle and 

Quadrangle. 

For Uniformly Distributed Load (UDL), you have to fill in magnitude q of the load, 

element axis and direction.  

 

 

 

For Trapezoid load, you have to fill in magnitude at near and far end (count from the 

node with smaller node number), distance from left (i.e. distance from the node with 

smaller number to one with larger number), load distance type, length of the distributed 

load, element axis and direction. If the “Whole Length” is selected, that means the load 

is applied to the whole member and the distance and length will be disabled.  

 

 

 

 

 

 

For Triangle load, you have to fill in magnitude of the load at top, distance from left 

(i.e. distance from the node with smaller number to one with larger number), load 

distance type, length of the distributed load, element axis and direction. 

 

 

 

q 

q1 

q2 

d c 
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For Quadrangle load, you have to fill in magnitude of load in 1 and 2, distance from 

left (i.e. distance from the node with smaller number to one with larger number), and 

distance from 1 to 2, load distance type, element axis and direction. 

 

 

 

 

 

 

Click Apply button and a new trapezoidal load entry will be shown on the load case 

properties and it can be activated by double-clicking the load in the right properties 

window.  

 

4.6.8.3 Member Pressure 

Click the Gr-Assign >Member Loads>Member Pressure command to assign pressure 

to selected members. 

 

Fill in the magnitude of member pressure. 

 

q 

a b 

q1 
q2 

a b 
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4.6.8.4 Cable Forces 

Click the Gr-Assign >Member Loads>Cable Forces command to assign the cable load 

to selected members. 

 

Fill in the magnitude of pre-stressing force. 

 

4.6.8.5 Self Weight 

Click the Gr-Assign >Member Loads>Self Weights command to assign the self-weight 

to selected members.  
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Fill in the amplification factor, select the sign and direction for selected beam-column 

elements only. The other structural objects do not allow for self-weight individually. 

 

4.6.8.6 Temperature 

Click the Gr-Assign >Member Loads>Temperature command to assign the 

temperature load to selected members.  

 

Fill in the magnitude of temperature for selected beam-column elements.  

  

4.6.9 Floor Pressure 

Click the Gr-Assign >Floor Pressures command to assign pressure to selected floors.  
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Fill in the magnitude and select the direction of the pressure. The pressure can be 

converted to either member loads or nodal forces directly. 

 Convert to Member Loads First option.  This command is to convert the floor 

pressures to member loads first by one-way or two-way mode if there are some 

beam-column elements under the floor elements. 
 Convert to Nodal Forces Directly option.  This command is to convert the floor 

pressures to joint loads directly. 

 

4.6.10 Shell Pressure 

Click the Gr-Assign >Shell Pressure command to assign pressure to selected shells.  
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Fill in the magnitude and select the direction of the pressure. The pressure can be 

converted to either member loads or nodal forces directly. 

 Convert to Member Loads First option.  This command is to convert the shell 

pressures to member loads first by one-way or two-way mode if there are some 

beam-column elements under the shell elements. 
 Convert to Nodal Forces Directly option.  This command is to convert the shell 

pressures to joint loads directly. 

 

4.6.11 Area Pressure 

Click the Gr-Assign >Area Pressure command to assign pressure to selected areas.  
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Fill in the magnitude and select the direction of the pressure. The pressure can be 

converted to either member loads or nodal forces directly. 

 Convert to Member Loads First option.  This command is to convert the area 

pressures to member loads first by one-way or two-way mode if there are some 

beam-column elements under the areas. 
 Convert to Nodal Forces Directly option.  This command is to convert the area 

pressures to joint loads directly. 

Warning: Area pressures are invalid in the analysis before the area(s) are converted to 

floor/shell elements.  

 

4.6.12 Copy Area Pressures 

Click the Gr-Assign >Copy Area Pressures command to copy the area pressure from 

one specified area to several areas.  

 

Input the area No. in “Source”. You can also pick up an area on the screen. 

Input several areas in “Target”. You can also select the areas from the screen directly. 

Click Apply button and all pressures in different load cases of the “Source” area can be 

copied to the “Target” areas. 

Click Close button to quit this window. 
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After this operation, all “Target” areas will be assigned with the same pressures in 

many load cases of the “Source” area. 

 

4.6.13 Remove Loads 

Click the Gr-Assign >Remove Loads command to delete the loadings within the 

selected load cases in the selected objects. 

 

Select the load cases inside the load case and different load type to remove the loading 

of selected objects.  

 

4.6.14 Assign to Group 

Click the Gr-Assign >Assign to Group command to add the selected objects to the 

specific group.  

 

Choosing a group, the selected objects can be added, replaced or deleted from the 

group. The group can be defined by clicking the  button on the left side of Groups. 
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Note: Node, member, shell, floor and area objects can be assigned to one group. 
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4.7 Analysis 

 

4.7.1 Run 

Click the Analysis>Run command to run a number of analysis cases which are set up 

in Set Analysis Case step. 

Shortcut : Toolbar : None Keys : F5 

 

4.7.2 Run a Batch of Files 

Click the Analysis>Run a Batch of Files command to run a batch of NIDA data files. 

 

 

Click the Add file(s) button to add the NIDA files to run.  

Click the Clear button to remove the selected NIDA data files.  

Click the Run button to run the files in sequence. 
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During the analysis process, the message from analysis can be viewed by clicking the 

Trace button. 

 

4.7.3 Set Analysis Case 

Click the Analysis>Set Analysis Case command to define analysis cases. 
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Click Add button to add analysis cases. Six types of analysis (Linear Analysis, 

Nonlinear Analysis, Modal Analysis, Eigen-buckling Analysis, Response Spectrum 

Analysis and Time History Analysis) can be selected. 

 

Click Modify button to modify the analysis case. 

Click Rename button to change the name of analysis case 

Click Delete button to delete the analysis case. 

Click Run/Do Not Run button to toggle the selection status of analysis. 

Click All Not Run button to set all analysis cases in un-active status.  

Click All Run button to set all analysis cases in active status. 

Click Run Now Button to start running the active analysis cases. 

 

4.7.3.1 Linear Analysis 

Click Linear Analysis to define a linear type analysis case. Give a case name and 

select the linear analysis type.  

 

Noted that when selecting ‘Linear Analysis + Design’ NIDA will check the member 

adequacy by selected design code, for example, design strength reduced by plate 

thickness, section classification, lateral-tortional bucking, column buckling. Otherwise, 

the checking by code will be skipped. 

 

The linear moment can be amplified by filling in the parameters in ‘Moment 

Amplification Factor’ such as elastic critical load factor and/or the equation from 

CoPHK (2011) when using CoPHK for steel design.  
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Click the Applied Loads tab to select the type of general load cases (Load case, 

Combined and Spectrum Analysis Case) to be added to analysis case. Different factors 

can be assigned to the analysis case. 

 

 

 

Reference: Definition of Linear Analysis 
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4.7.3.2 Nonlinear Analysis 

Click Nonlinear Analysis to define a second-order elastic or plastic analysis case. 

Give a case name and select the nonlinear analysis type.  

 

Noted that when selecting ‘Second-order Analysis + Design’ NIDA will check the 

member adequacy by selected design code, for example, design strength reduced by 

plate thickness, section classification, lateral-tortional bucking, column buckling. 

Otherwise, the checking by code will be skipped. 

 

Either PEP Element (Chan and Zhou 1994) or Curved Stability Function (Chan and Gu 

2005) can be used to simulate the beam-column elements with initial member 

imperfection.  

Click the Enable Plastic Advanced Analysis to allow for the material yielding in 

beam-column elements. Either Plastic Element or Plastic Hinge can be used for plastic 

analysis method.  

 

The nonlinear solution in NIDA is essentially based on the incremental-iterative 

procedure. There are three numerical methods for Load Incremental Scheme and 

Interactive Scheme, i.e. Newton-Raphson (Constant Load) Method, Single 

Displacement Control (Constant Displacement) Method, and Arc Length Method + 

Minimum Residual Displacement Method.  

In Single Displacement Control method and Arc Length Method + Minimum Residual 

Displacement Method, user can set the parameters for load incremental scheme and 

interactive scheme.  
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It is also required to specify the total load cycles, target load factor, maximum 

iterations for each load cycle, number of iterations for tangent stiffness. The definition 

of each parameter is explained in General Nonlinear Parameters for Analysis.  
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Total Load Cycles 

It describes the maximum number of total load cycles for the nonlinear analysis. The 

analysis process will be terminated once the maximum cycle reaches. The analysis 

process may be also terminated when input errors or divergence found, or when the 

target load factor reaches if Target Load Factor function is enable.  

 

Target Load Factor 

It describes the expected load factor for the nonlinear analysis. The analysis process 

will be terminated once the load factor reaches the target one even though the load 

cycles may be less than the total load cycles. The load factor may be not able to reach 

the target one due to structural problem or limitation of total load cycles. For the 

former user need to redesign the structure while for the latter user may increase the 

total load cycles. 

 

Maximum Iterations for each Load Cycle 

It describes the maximum number of iteration for each load cycle in the analysis. If the 

equilibrium condition is satisfied before this number is reached or the iteration number 

is equal to this assigned iteration number, another load step will be imposed until the 

permitted number of load steps is reached. The tolerance for equilibrium check is 0.1 % 

by default. That is, when the Euclidean norms of the unbalanced displacements and the 

unbalanced forces are less than respectively 0.1 % of the total applied forces and the 

total accumulated displacements, the equilibrium condition is assumed to have been 

satisfied. 

 

Number of Iterations for Tangent Stiffness Matrix 

It describes the number of iterations for the tangent stiffness matrix to reform during 

the iterative process. When this number is specified to be very large or simply equal to 

the “maximum number of iterations for each load cycle” above, the iterative scheme 

will then become the modified Newton Raphson method. If the number here is 

specified as "1”, it becomes the Newton Raphson method. If the number is between 

these two extremes, the method is a mixed Newton-Raphson method. When compared 

to modified Newton Raphson method, the Newton Raphson method generally requires 

less number of iterations for convergence, but longer time for each iteration. It is 

recommended to use the Newton Raphson method 

 

Incremental Load Factor 

This factor will be used as the first load factor used for the analysis and the load factor 

increment in subsequent analysis. It is different from the design load factor behind 

“header load” which is multiplied to the input load to obtain the design load vector and 

will not appear in the plotting of equilibrium or load-deflection curve with its value 

generally taken as, for example, 1.6 for wind, 1.4 for self-weight etc. The load factor 

described here is used as the ratio of the current applied load to the input design load. 

For example, if a structure yields at a load factor of 2.6, it means when the applied load 

is 2.6 of the design load, the structure yields. 



Menus 
 

NIDA – Nonlinear Integrated Analysis & Design  97 

 

Parameters for Numerical Methods 

1. Newton-Raphson (Constant Load) Method 

a. Incremental load factor – constant load increment ratio  

2. Single Displacement Control (Constant Displacement) Method 

a. Incremental displacement – constant displacement increment  

b. Control node – monitored node  

c. DOF - degree of freedom of control node  

3. Arc Length Method + Minimum Residual Displacement Method 

a. Initial incremental load factor – load increment ratio for first load cycle 

b. Expected iterations for next load cycle – iterations to control the load increment 

c. Maximum arc distance – limit of arc distance increment     

 

Minimum Member Imperfection 

The minimum magnitude of initial imperfection is taken as 1 (Input value) /1000 of the 

member length if the initial imperfections are allowed. 

 

Imperfection Method & Direction 

It describes the direction of initial imperfection. It can be no initial imperfection, initial 

imperfection in one principal plane causing less severe effect than initial imperfection 

in both the principal planes.  

The frame global and member imperfections should be defined in analysis. There are 

three types of imperfections including ‘displacement (DIMP)’, ‘eigen-buckling mode 

(EIMP)’, and ‘notional force (NIMP)’. The imperfection could be added in one or both 

principal axes of a beam-column element. If no initial imperfection is required, select 

the ‘No Imposition of Initial Imperfection’. Click the Setting… button to set the 

required parameters for imperfection analysis. 
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Magnitude of Imperfection for Global Eigenvalue Mode 

This value is the magnitude of imperfection when eigenvalue buckling mode is adopted. 

After the eigenvalue analysis, the eigen-mode is determined and a set of initial 

imperfection is determined for the structure with this mode shape. This number is for 

the magnitude (maximum) of the initial deflection for the eigen-mode which is then 

added to the initial geometry of the structure. 

 

 

Click the Advanced Setting button to select the recovery force method. 

Click the Applied Loads tab to add loading for analysis. Appropriate load factor can be 

input for load combination purpose in the analysis case. 
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Click the Construction Sequence tab to add different construction stage. 

 

 

References:  

Definition of Nonlinear Analysis 

Numerical Method 
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Load Incremental Scheme 

Interactive Scheme 

Imperfection 

 

4.7.3.3 Modal Analysis 

Click the Modal Analysis to define a modal analysis case. Give a case name, select the 

mass type (Lumped or Consistent) and determine whether the output results have to be 

printed in *.out file or not. The number of required modes should be input. 

 

 

Click the Advanced button to activate the function for determining the mode numbers 

automatically by specifying the effective modal masses ratios.  
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Click the Mass from Load Cases tab to define additional masses from load cases. The 

self-weight of structural objects will be automatically included in the modal analysis. 

However, if additional masses due to other dead and live loads have to be considered, 

you may consider them by adding load cases which include mass components. Noted 

that only the loadings in gravity direction will be added to the mass matrix. 

 

 

Click the Initial Loads tab to consider stiffness change in structural system due to loads 

like temperature and pretension forces. The effect of initial load is not necessary for all 

kinds of structures. 
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Reference:  

Definition of Modal Analysis 

 

4.7.3.4 Eigen-buckling Analysis 

Click the Eigen-buckling Analysis to define an eigen-buckling analysis case. Give a 

case name and determine whether the output results have to be printed in *.out file or 

not. The number of modes required for observation should be given. 
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Click the Applied Loads tab to add the loads for analysis. The default load factor for 

each load case is 1.0 and it can be changed if needed.  

 

Reference:  

Definition of Eigen-buckling Analysis 

 

4.7.3.5 Response Spectrum Analysis  

Click the Response Spectrum Analysis and select One Direction Only or Directional 

Combination to define a response spectrum analysis case.  
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 Response Spectrum Analysis - One Direction Only 

Define a response spectrum analysis in one direction. 

 

For one direction only, input the name of analysis case and select the Use Modes from 

Modal Analysis Case.  

Select the Response Spectrum Function from the dropdown list if any or click the 

Define button  to create a new spectrum function for selection. 

Select the Modal Combination , there are three methods available, i.e. CQC (Complete 

Quadratic Combination), SRSS (Square Root of the Sum of the Squares) and ABS 

(Absolute Sum). 

 

CQC (Complete Quadratic Combination) Method 

The CQC method takes into account the statistical coupling between closely-spaced 

modes caused by modal damping. You may specify a CQC damping ratio (damp) 

measured as a fraction of critical damping: 0 <= damp<1. This should reflect the 

damping that is present in the structure being modeled. Note that the modal damping 

ratio is different from the function damping ratio defined in the Response Spectrum 

Function. The latter is developed independently for an assumed value of structural 

damping. Normally these two damping values should be the same. If the damping is 

zero, this method degenerates to the SRSS method. 

 

SRSS (Square Root of the Sum of the Squares) Method 
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The SRSS method is to combine the modal results by taking the square root of the sum 

of their squares. This method does not take into account any coupling of Modes as in 

the CQC method. 

 

ABS (Absolute Sum) Method 

The ABS is to combine the modal results by taking the sum of their absolute values. 

This method is usually over- conservative. 

 

Modal Damping Ratio: For CQC method only. This ratio is to consider the coupling 

between closely-spaced modes. 

Seismic Direction and Excitation Angle: To define the seismic direction. When the 

seismic direction is “Horizontal”, the “Excitation Angle” should be further defined to 

indicate the seismic direction. The vertical direction is the same as the gravity 

direction. 

 

 Response Spectrum Analysis - Directional Combination 

Combine the results of two or three “one direction response spectrum analysis”. 

 

To select the method of Directional Combination, there are three available – SRSS, 

ABS and Modified SRSS (Chinese). 

 

SRSS 
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Combine the directional results by taking the square root of the sum of their squares. 

This method is in variant with coordinate system, i.e., the results do not depend upon 

the choice of coordinate system when the given response-spectrum curves are the same. 

This is recommended for directional combination. 

 

ABS 

Combine the directional results by taking the sum of their absolute values. This method 

is usually over- conservative. 

 

Modified SRSS (Chinese) 

Combine the directional results by a modified SRSS method complied with Chinese 

Seismic Design Code GB50011-2001 

Select the Response Spectrum Analysis cases for combination in EQX, EQY and EQZ 

directions. 

 

4.7.3.6 Time History Analysis 

Click the Time History Analysis to define a time history analysis case. Give a case 

name and select the mass type, time history type and time history motion type.  

 

 

Select an integration method and fill in the parameters as required. 
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Define the damping as below. 

 

Fill in the total no. of time steps and time increment. 

 

For more advanced settings for nonlinear solution, click Advanced Setting button and a 

dialog will pop up as below. 
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Click Dynamic Function / Additional Mass tab to select one or more than one dynamic 

functions as earthquake input. Also, the additional masses from load cases such as dead 

load and live load can be input in this tab. 

 

 

Click Initial Loads tab to consider static loads such as dead load and live load. 
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4.7.4 Analysis & Design Parameters Setting  

Click the Analysis>Analysis & Design Parameters Setting command to change the 

general settings of the model. 

 

The first tab window is the general information and global control parameters of the 

project. You can change the project title, define the floor stiffness, set the direction of 

gravity, select the steel and concrete design code, and change the force unit as well as 

the length unit.  
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Click the Advanced button to select the Skyline Profile Minimization Indicator for 

memory optimization and modify the tolerances for convergence of analysis.  

 

 

The second tab window is used to set the activation of degrees of freedom in 6 

directions (Ux, Uy, Uz, Rx, Ry and Rz). You can use the ‘Fast DOFs’ function by 

clicking the Active All, X-Y Plant or Truss button to set up the degrees of freedom in a 

fast way. 
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4.8 Post 

 

4.8.1 Show Deformed Shape 

Click the Post>Show Deformed Shape command to view the deformed shape of the 

model after finishing the analysis. 

Shortcut : Toolbar :  Keys : None 

 

4.8.2 Show Undeformed Shape 

Click the Post>Show Undeformed Shape command to view the undeformed shape of 

the model. 

Shortcut : Toolbar :  Keys : None 

 

4.8.3 Show Deformed & Undeformed Shape 

Click the Post>Show Deformed & Undeformed Shape command to view the deformed 

and undeformed shape of the model together at the same window. 

Shortcut : Toolbar :  Keys : None 

 

4.8.4 Display Scale 

Click the Post>Display Scale command to magnify displacement of nodes and rotation 

of the members of deformed structure. 

Shortcut : Toolbar :  Keys : None 

 

 

To magnify the deflected shape, change the value of “Delta” or “Angle” or both of 

them. The displacement or rotation of the nodes will be multiplied by this factor. Click 

“Reset” button, all values will be reset to 1.  

 

4.8.5 Show Analysis Case 

Click the Post>Show Analysis Case command to show the results of the selected 

analysis case on the screen, such as internal forces and moments, nodal displacements 

and reactions, shell stresses and so on. 

Shortcut : Toolbar :  Keys : None 
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4.8.6 Show Result Files 

Click the Post>Show Result Files command to open the results in text file. There are 

four types of result file associated with different information. 

 

 *.out  

It is a text file which includes the detailed input data, analysis results such as nodal 

displacements, member internal forces and moments, shell stresses and nodal reactions. 

Each analysis case contains a *.out file with analysis case number. 



Menus 
 

NIDA – Nonlinear Integrated Analysis & Design  113 

 *.log  

It is a text file which stores important messages during analysis procedure, such as load 

increment, divergence and singular information. Some information of error, warning 

and note may be important for correct solutions.  

Each analysis case contains a *.log file with analysis case number. 

 *.mon  

It is a text file which stores some messages during data reading procedure. The 

information may help correct the errors due to modelling.  

 

4.8.7 Nodal Results 

4.8.7.1 Reactions/Displacements 

Click the Post>Nodal Results >Reactions/Displacements command to show the nodal 

reaction forces and displacements when you click the node of deformed structure. 

 

4.8.7.2 Load Deflection Curve/Reactions 

Click the Post>Nodal Results>Load Deflection Curve/Reactions command to show the 

load-deflection curve, displacement statistics and reaction forces and moments. 

Shortcut : Toolbar :  Keys : None 

 

 Load-Deflection Curves 

When loading is applied to a structure, it will deform according to the load factor.  

The deflection versus load plot and other information about nodes can be viewed in this 

Load-Deflection Curve window: 
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The first tab represents the deflection of selected node against load factor. The two 

axes represent the change of load factor and deformation of a node. The number of 

cycle can be set in Cycle box.  

Six different curves against load factor can be plotted, i.e. deflections in X, Y, Z, and 

rotations about X, Y, Z with appropriate selection. Tick the check boxes at right hand 

side of diagram to show/hide the curves and draw the curve with line or symbol.  

To save the results in text file, just click the button  at top right of this window. 

 

 Displacement Statistics 
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The second tab shows detailed displacements and rotations in specified load cycle and 

load stage. When cycle number is changed, the results will be changed accordingly. 

|Ux|,|Uy| and |Uz| are the displacements in X, Y and Z-axes respectively, Displacement 

is the total translation between original and new positions, and |Rx|, |Ry| and |Rz| are 

the rotation about X, Y and Z-axes respectively. 

Click the column header (e.g. |Ux|, |Ry|, etc.) to sort that column in ascending or 

descending order for finding the maximum and minimum values. 

To save the results in text file, click the button  at top right of this window. 

 

 Reactions  
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This tab lists the reaction forces and moments of each load cycle.  

To save the results in text file, click the button  at top right of this window. 

 

 Pushover Curve 

 

This diagram shows change of base shear against nodal deflection for pushover 

analysis. 

To save the results in text file, click the button  at top right of this window. 
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4.8.7.3 Toggle Displacements/Reactions Dialog 

Click the Post>Nodal Results>Toggle Displacements/Reactions Dialog command to 

choose whether reactions or displacements to be shown on the popup dialog when 

double-clicking a node. 

  

 

4.8.8 Member Results 

4.8.8.1 Member Statistics/Moment-Rotation 

Click the Post>Member Results>Member Statistics/Moment-Rotation command to 

show the member information such as the section capacity factor, end moment, shear 

stress, axial force and torsional moment and the Moment-Rotation curve in each load 

cycle. 

Shortcut : Toolbar :  Keys : None 

 Member Statistics 
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When different loading is applied on the structure, the internal forces on the members 

are changed accordingly. Some useful information about the force on each member: 

stress, axial force and torsional moment can be found here. 

To find the minimum/maximum section capacity factor, axial force or torsional 

moment among the members in the structure at a certain load factor, select the cycle 

number and click on column header to sort it in ascending/descending order. 

To save the results in text file, click the button  at top right of this window. 

 

 Moment-Rotation 
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This diagram shows change of moment against rotation for second-order plastic 

analysis and time history analysis. 

 

4.8.8.2 Show Section Capacity Factor Statistics 

Click the Post>Member Results>Show Section Capacity Factor Statistics command to 

show section capacity factor statistics. 

Shortcut : Toolbar : 
 

Keys : None 

This function is useful to check the utilization of each section group. User can reduce 

or increase member size according to charts. 
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Click the Analysis Case button to select the analysis case to be included.  

Click the Section button to select the section to be included. 

The color of background, axis, front, grid line and point color can be selected. The 

chart can be exported to a BMP file. 

 

The color of each member in deformed structure depends on the section capacity factor 

at each load cycle.  

Shortcut : Toolbar :  Keys : None 

 

 

           

It is divided into 12 different colors by different ranges of section capacity factor. The 

first one represents the member with stress value larger than or equal to 1.0 (i.e. 

exceeding the tensile yield stress), whereas the last one represents the stress value is 

less than -1.0 (i.e. exceeding the compressive yield stress). 

Change these colors by simply clicking the color boxes and select the new one from 

color palette.  

 

4.8.8.3 Show Bending Moment/Shear Force Diagram 

Click the Post>Member Results>Show Bending Moment/Shear Force Diagram 

command to show the bending moment and shear force diagram of all the members on 

the screen in undeformed configuration. 

 

Shortcut : Toolbar :  Keys : None 



Menus 
 

NIDA – Nonlinear Integrated Analysis & Design  121 

 

To show bending moment and/or shear force on undeformed structure in main window, 

select one or more than one items to be shown on the screen. 

 Bending moment about y-axis 

 Bending moment about z-axis 

 Shear force along local y-axis (xz plane) 

 Shear force along local z-axis (xy plane) 

 Axial force 

 Value of bending moment, shear force and axial force 

 

Afterwards, tick the members you want to draw curves and press Apply. 

 

Please be reminded that too many curves will reduce the quality of the diagram. It is 

recommended that only diagrams of selected members would be shown simultaneously 

on the screen.  

The result could also be viewed in a separate window by clicking the specific member, 

and then a dialog will pop up to show the bending moments and shear forces as below. 
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The first diagram shows bending moment about y-axis and shear force along y-axis (i.e. 

xz plane) of the selected member. The second diagram shows bending moment and 

shear force about z-axis and along z-axis (i.e. xy plane) respectively. 

Note: all these diagrams are drawn in member local axis. 

 

4.8.8.4 Show Plastic Hinge 

Click the Post>Member Results>Show Plastic Hinge command to show the plastic 

hinge if it is a plastic analysis allowing for plastic hinges formation. 

The plastic hinge may occur at one or both ends of the member with blue or red 

circular mark. The blue mark means partially yield plastic hinge while the red one 

means full yield plastic hinge. 

 

4.8.9 Shell Results 

4.8.9.1 List Nodal Stress 

Click the Post>Shell Results>List Nodal Stress command to list the nodal stresses. 

Double click the dialog to open it by external 

editor tool such as “Notepad.exe”. 
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You may obtain 6 types of information of each node in different load cycles. When 

cycle number is changed, the load factor will also be varied. 

 

Sx The nodal stress in x-direction (Global coordinate system) 

Sy  The nodal stress in y-direction (Global coordinate system) 

Txy Shear Stress (Global coordinate system) 

von.Mises von Mises Stress 

S1  The First Principle Stress 

S2  The Second Principle Stress 

    

Note: Principle stresses and von Mises stress are calculated as below. 

2

2

1
2 2

X Y X Y
XY

S S S S
S T

  
   

   

2

2

2
2 2

X Y X Y
XY

S S S S
S T

  
   

   

2 2 23VMS X Y X Y XYS S S S S T   
 

Click the column header (e.g. Sx, Von Mises, S1, etc.) to sort that column in ascending 

or descending order in order to obtain the maximum and minimum values. 

To save the results in text file, click the button  at top right of this window. 
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4.8.9.2 List Shell Stress 

Click the Post>Shell Results>List Shell Stress command to list the shell element 

stresses. 

 

You may obtain 6 types of information of each shell element in different load cycles. 

When cycle number is changed, the load factor will be changed accordingly. 

 

Sx The element stress in x-direction (Local coordinate system) 

Sy  The element stress in y-direction (Local coordinate system) 

Txy Shear Stress (Local coordinate system) 

von.Mises von Mises Stress 

S1  The First Principle Stress 

S2  The Second Principle Stress 

 

Click the column header (e.g. Sx, Von Mises, S1, etc.) to sort that column in ascending 

or descending order in order to obtain the maximum and minimum values. 

To save the results in text file, click the button  at top right of this window. 

 

4.8.9.3 Show Displacements 

Click the Post>Shell Results>Show Displacements command to show the displacement 

contour. 

Shortcut : Toolbar :  Keys : None 



Menus 
 

NIDA – Nonlinear Integrated Analysis & Design  125 

 

You may obtain 7 types of displacement of each shell in different load cycles. When 

cycle number is changed, the load factor will be changed accordingly. 

 

Ux Displacement in X-axis 

Uy Displacement in Y-axis 

Uz Displacement in Z-axis 

Disp Total displacement, 
2 2 2

X Y ZDisp U U U    

Rx Rotation about X-axis 

Ry Rotation about Y-axis 

Rz Rotation about Z-axis 

 

The different colors in the shell element indicate the different levels of deformation.  

     

4.8.9.4 Show Nodal Stress (Surface) 

Click the Post>Shell Results>Show Nodal Stress (Surface) command to show the 

nodal surface stress contour. 

Shortcut : Toolbar :  Keys : None 
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You may obtain 6 types of stress of each node in different load cycles. When cycle 

number is changed, the load factor will be changed accordingly. 

Sx The nodal stress in x-direction (Global coordinate system) 

Sy The nodal stress in y-direction (Global coordinate system) 

Txy Shear Stress (Global coordinate system) 

Von.Mises von Mises Stress 

S1 The First Principle Stress 

S2 The Second Principle Stress 

  

The different colors in the shell element mean the different level of stress.  

 

4.8.9.5 Show Shell Element Stresses (Surface) 

Click the Post>Shell Results>Show Shell Elem Stress (Surface) command to show the 

shell element surface stress contour. 
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You may obtain 6 types of stress of each node in different load cycles. When cycle 

number is changed, the load factor will be changed accordingly. 

Sx The element stress in x-direction (Local coordinate system) 

Sy The element stress in y-direction (Local coordinate system) 

Txy Shear Stress (Local coordinate system) 

Von.Mises von Mises Stress 

S1 The First Principle Stress 

S2 The Second Principle Stress 

 

The different colors in the shell element indicate the different levels of stress.  

 

4.8.10 Export Summary of Analysis Results  

Click the Post>Export Summary of Analysis Results command to export the analysis 

results to MS Excel file or Text file. 

Shortcut : Toolbar :  Keys : None 
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Step 1: Click Select … button to select analysis case, load cycle and/or load stages.  

Analysis case(s) with load stages: 
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Analysis case(s) without load stages: 

 

 

Step 2: Click the Browse button to select the output path to save results. 

Step 3: Choose the item(s) to be included in output. Items(result type) can be specified 

(Max Section Forces & Moments, Nodal Displacements, Nodal Reactions, Internal 

Forces & Moments, Deflection of Members and Deflection of Combined Members); 

and options are provided for each item. Star (*) in option means further setting is 

provided. 
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Click Export button and an MS Excel file or Text File will be shown as below. 

 

 MS Excel File 
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 Text File 

  

 

4.8.11 Export Statistics of Analysis Results 

Click the Post> Export Statistics of Analysis Results command to export the statistical 

results in an MS Excel file. 

Shortcut : Toolbar :  Keys : None 
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Analysis Cases Selection:  refer to Step (1) of 4.18.10 Export Summary of Analysis 

Results. 

 

Node result output:  Most top (max) N result items sorted by Option will be exported 

if the checkbox enables. The item Count ‘N’ can be specified and 

Option(Resultant/Ux/Uy/Uz/Rx/Ry/Rz) is provided for displacement while 

Option(Resultant/Fx/Fy/Fz/Mx/My/Mz) is provided for reaction. 

 

Member result output:  

“For” Option: items are categorized by Each selected section/Each member or not 

categorized, i.e. All. 

“By” Option: items are sorted by |Section capacity factor| (Absolute value) /Axial 

force/Bending moment/Shear force/Torsional moment; 

Section filter: 
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An exported MS Excel file will be shown as below. 

 

 

“Export Member Design Details (*.NSD file)” option can output the details of design 

procedure of critical members for calculation report. 
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4.8.12 Export Eigen-buckling Load Factor(s) 

Click the Post>Export Eigen-buckling Load Factor(s) command to export the 

eigen-buckling load factor to an MS Excel file. 

Shortcut : Toolbar :  Keys : None 

 

 

Analysis Cases Selection:  refer to Step (1) of 4.18.10 Export Summary of Analysis 

Results.  

 

4.8.13 Export Animation AVI 

Click the Post>Export Animation AVI command to export an animation file with AVI 

format. 
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Multi-Cycles option provides a video which plays the deformation of the structure 

under loading from one load cycle to another. 

Specified Cycle option provides a video which plays vibration between the 

undeformed and deformed shape of the specified load cycle. 

 

4.9 Tools 

4.9.1 Show Data File 

Click the Tools>Show Data File command to open the data file in text format, which 

contains all information of the model. User can modify the model by editing the file 

directly and reload it to confirm the change. 

 

4.9.2 Export Tables 

Click the Tools>Export Tables command to export the definition of the model such as 

node coordinates, beam and shell connectivity, materials, sections, load cases and load 

combinations.  

 

 

4.9.3 Check Nodal Distance 
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Click the Tools>Check Nodal Distance command to calculate the distance between 

two selected nodes. 

 

 

4.9.4 Statistics 

Click the Tools>Statistics command to show the information of the model. 

 

 

The General tab lists the number of member, nodes, materials, sections, shells, floors, 

the total weight of the model, and the maximum length in X, Y and Z axes. 

The Selection tab shows the number of member, node, shell, floor and the total weight 

of the selected objects. 

The Frame Section tab shows the number of the members and the total weight of the 

members in the frame sections. 

The Shell Section tab shows the number of the shells and the total weight of the shells 

in the shell sections. 

The Load Case tab shows the name, load factor and number of loadings in the 

corresponding load case. 
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4.9.5 Options 

Click the Tools>Options command to set the color of each object as well as the display 

options.  

 

Select an object on the list . The button beside the object will show the current color of 

that object. Click it to change the color scheme.  

 

 

Change the thickness of line, choose the tool for opening the data file and so on. 
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4.10 Window 

 

4.10.1 New Window 

Click the Window>New Window command to open a new window. 

 

4.10.2 Tile Vertically 

Click the Window>Tile Vertically command to show the windows vertically.  

 

4.10.3 Tile Horizontally 

Click the Window>Tile Horizontally command to show the windows horizontally. 
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4.11 Help 

 

4.11.1 Tutorials 

Click the Help>Tutorials command to view the step-by-step tutorials. 

 

4.11.2 User Manual 

Click the Help>User Manual command to view the manual document. 

 

4.11.3 About Nida 

Click the Help>About Nida command to show the name and version of the program, 

and the license information. 
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5. ANALYSIS THEORY 

 

5.1 General Concept for Ultimate Behaviour of Structures 

 

The strut under compression in Figure 5.1 represents the typical behaviour of a member 

under compression. 

 

Figure 5.1  Typical Behaviour of An Imperfect Strut 

Note: (1)λ is a load factor multiplied to the factored design load P. 

   (2)λ should not be less than 1 to ensure resistance is not less than design load. 

 

5.1.1 Elastic Critical Load Factor cr 

Elastic Critical Load Factor (cr) is an indicator for buckling sensitivity of a structure. 

The larger the value is, the less sensitive to sway buckling effect the structure is. It can 

also be used to compute the amplification moment (M) from the moment obtained by a 

linear analysis ( M ) as, 

 MM  
1

 
cr

cr






 (5.1.1) 

By definition, cr is a factor multiplied to the design load to cause the structure to 

buckle elastically and drastically, such that the structure does not exhibit pre-buckling 

deflection. This condition is impossible to attain in practice since structures deform in 

all directions, no matter how small, once external loads are applied. As the large 

deflection and material yielding effects are not considered here, the factor is an upper 

bound solution that cannot be used directly in design. However, cr is useful in 

assessing the stability condition. 

The following requirements are imposed in the CoPHK (2011). 

P  where P = design load

First-order  linear

Deflection

Load factor 

UP

yP

 crP

Design resistance or collapse load by 
Second-order Plastic Analysis

Analysis

Elastic Buckling Load = EI/L = crP





Second-order elastic analysis

Plastic collapse load = py A = pP

Design resistance by "First-plastic-hinge" 

P P

2       2
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(1) When cr < 5, a structure must be designed by a second-order analysis discussed 

below (i.e. the P-Δ moment must be considered by a second-order analysis and the 

first-order linear analysis with or without moment amplification cannot be used) 

(2) When 5≤ cr < 10, the structure is sway-sensitive and moment must be amplified for 

the sway effect (i.e. the P-Δ moment must be considered and the first-order linear 

analysis with moment amplification method can be used) and 

(3) When cr ≥10, the frame is sway insensitive that the sway effect can be ignored (i.e. 

the P-Δ moment can be ignored) 

cr can be determined either by the deflection method in the CoPHK (2011) or in 

computer. In all cases, the P-δ moment must be considered in using imperfect member 

in analysis or the buckling curves in design code. 

Second-order analysis can be used in all cases above. 

 

Figure 5.2  The P-Δ and P-δ Moments 

 

5.1.2 P-Δ-Only Analysis 

P-Δ-only analysis is the simplest method in the family of non-linear analyses. In this 

method, the only considered non-linear effect is the change of structural geometry due 

to nodal displacements. The process is to simply add displacements to coordinates of 

all nodes in a structure during an analysis. As the member curvature or the P-δ effect 

indicated in Figure 5.2 is ignored and the member is assumed to remain perfectly 

straight in an analysis, design formulae in a design code must be applied in this method 

for checking the buckling resistance of a member with its length either of an effective 

member length or multiplied by a rationally determined effective length factor (Le/L).  

 

5.1.3 P-Δ-δ Elastic Analysis 

P-Δ-δ elastic analysis allows for the non-linear effects due to nodal displacement and 

member bow. The consideration of these two effects is equivalent to reducing the 

member resistance by the corrected value effective length (unfortunately this is 

P P





P- for nodal displacement / sway

P- for member curvature / bowing
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unknown for most except the simplest structures). The resistance of a member in a 

frame is adequate when the following equation for section capacity check is satisfied. 

 
( ) ( )

1
y y y z z z

y cy cz

M P P M P PP

p A M M

 


     
     (5.1.2) 

where 

Δ  Displacement due to sway of the frame measured at nodes 

δ  Displacement due to member curvature or bowing, measured along a member 

P  Axial force in member 

A  Cross sectional area 

py  Design strength 

Mcy  Moment capacity about principal y-axis 

Mcz  Moment capacity about principal z-axis 

My External moments about principal y-axis 

Mz External moments about principal z-axis 

  Section capacity factor. If  >1, member fails in section capacity check. 

 

The term “elastic” here indicates that the method disallows stress or moment 

re-distribution.  However, a small degree of material yield for compact or plastic 

section based on the “first-plastic–hinge” concept can be used in Equation (5.2) by 

replacing the elastic moduli (ZY and ZZ) with the plastic moduli (SY and SZ). Even with 

this use of plastic modulus and plastic moment as moment capacity in this 

“First-plastic-hinge” design approach, stress or moment re-distribution is not allowed. 

 

5.1.4 P-Δ-δ Plastic Analysis or Advanced Analysis 

The P-Δ-δ plastic analysis is not the same as the conventional rigid-plastic design 

based on equalization of external work done and internal strain energy, which ignores 

the effect of buckling or large deflection. P-Δ-δ plastic analysis allows for buckling and 

material yielding and it extends the method of elastic analysis to plastic range utilizing 

the mechanism of moment or stress re-distribution after the first plastic hinge formation. 

This is in line with the ultimate limit state design which requires the structural 

resistance allowing for the effects of buckling and plastic yielding larger than the 

factored ultimate load. In the computer analysis, a plastic hinge is inserted to the end of 

a member when a section along the member reaches the limit of section capacity in 

Equation (5.1.2). The process is continued until a plastic collapse mechanism allowing 

for P-Δ-δ buckling effects is formed at which the load is taken as the collapse load of 

the frame. 

 

5.1.5 Initial Imperfections 

All structures contain imperfections due to member out-of-straightness and frame 

out-of-plumbness and therefore they MUST be included either in analysis or in design. 

As the presence of imperfections reduces the load resistance of a practical structure, 
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their ignorance is on the unsafe side in design. The geometrical member 

out-of-straightness is normally not greater than 0.1% of its length but a larger value is 

commonly used in order to include the effect of residual stress by an enlarged 

equivalent geometrical member imperfection. The CoPHK (2011) and the Eurocode 3 

(2005) are possibly the only two codes giving explicit imperfections for members of 

different cross sectional shapes while nearly all design codes allow the use of 

second-order analysis without giving explicit guides. To include the effect, the 

imperfections are assumed to have initial values before load applications. Thus, 

 0  P     and 0 P     (5.1.3) 

in which  , 
0  and p  are member total, initial and load-induced member bowing 

displacements and Δ , Δ 0 and Δ P are frame total, initial and load-induced 

out-of-plumbness displacements. 

 

5.1.5.1 Frame Imperfection 

Frames can hardly be built perfectly vertical and out-of-plumbness should be allowed. 

In the steel design codes, an inclination of 1/500 or 0.2% is commonly adopted 

whereas temporary or other structures require a larger value of out-of-plumbness. 

Although the effect of applying a notional force of 0.5% of the total vertical loads is 

not exactly the same as the use of slightly inclined structural geometry in an analysis, 

the codes allow the interchanged use of the two approaches. However, for irregular 

frames like domes, both methods are difficult to apply, because of the irregularity of 

the structural geometry. The CoPHK (2011) allows the use of the buckling mode as the 

imperfection mode. The magnitude of imperfection should be taken to be not less than 

the construction tolerance in analysis. 

 

Figure 5.3  Transformation of out-of-plumbness to  

Horizontal Notional Force 

 

5.1.5.2 Member Imperfection 

Similar to frames which cannot be perfectly vertical, members can hardly be perfectly 

straight. The initial imperfection or crookedness is not totally due to geometrical defect, 

it also allows for residual stress in different sections. The procedure of curve-fitting to 

obtain a lower-bounded match of imperfection against the buckling curve in the code 

was discussed by Cho and Chan (2005) whose proposed imperfections are the basis of 

the subsequently drafted the CoPHK (2011) and it is similar to the Eurocode 3 (2005). 
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5.1.6 Elastic vs. Plastic Analysis 

Elastic or first-plastic-hinge design has been used for century and plastic analysis is 

mainly limited to portal frame design. While steel accepted for use in building 

structures is reasonably ductile and has a minimum elongation at fracture of 15%, the 

ignorance of favorable effect in redundant structures by using elastic analysis is 

unjustifiable and un-sustainable for several reasons as follows. 

 The elastic analysis discourages engineers to design robust and redundant 

structure against local failure since the design stops at the first plastic hinge. The 

approach does not allow engineers to consider in an analysis the strength reserve 

after first yield of structures while redundant and robust structures do not fail at 

the first plastic hinge. 

 Engineers quite often like to make use of ductility of steel in their design and, for 

extreme loads during rare events, elastic design is uneconomical and puts a 

consultant using the elastic design into a non-competitive position. 

 From past record, one can hardly find frame failure initiated by formation of 

plastic hinges in beams. Inspection of steel structures after earthquake showed that 

member buckling and cracking at connections were more common but plastic 

hinge in beams was unusual. This indicates buckling and connection are two 

important aspects in structural steel design against collapse and design allowing 

for plastic behaviour and stress re-distribution is both a safe and a sensible 

direction for design. 

 For design of structures under static loads, the authors suggest the use of P-Δ-δ 

plastic analysis in ultimate load design and P-Δ-δ elastic analysis for design under 

working loads, with both analyses allowing for mandatory frame and member 

imperfections. This ensures that the structure will not collapse under ultimate 

loads or yield to store energy under working load condition. 

 

5.1.7 Design Hierarchy 

With the introduction of the new design method, it will be useful to summarize the 

relationship between various design methods for appreciation by engineers in choosing 

a suitable design method for certain structure. The flow-chart below indicates their 

relationship. 
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Checking of elastic critical load factor 

Modeling of the structure

If  

First-order linear analysis 

If  

Second-orderP- elastic analysis 
with parameters to code requirements

Use plastic strength reserve ? 

Second-orderP- plastic analysis

or "Advanced analysis"

Second-orderP-only elastic analysis

with effective length factor (Le/L)=1

Design to charts and tables in code

Amplify moment

Y N

Y

N

Design output

Design output

Y

N

Second-order analysis

 

Figure 5.4  Flow-chart of Structural Design under  

the Contemporary Codes 
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5.2 Analysis Types 

 

5.2.1 Introduction 

Second-order analysis is considered in many design codes as a more reliable and 

accurate design and analysis tool for slender frames. For example, CoPHK (2011) 

disallows the use of the first-order linear analysis when the elastic critical load factor 

(cr) is less than 5 while similar requirement also applies for other codes like AS4100 

(1998), BS5950 (2000) and the Eurocode 3 (2005). However, unlike the first-order 

linear analysis which has only one version of assuming the external force proportional 

to displacement and stress, there are several versions of second-order nonlinear 

analysis since many aspects of structural behaviour can be considered as non-linear or 

assumed as linear. Being a powerful tool with saving in material weight, improvement 

in safety margin and reduction in design effort and time, the second-order nonlinear 

analysis can be dangerous if not used properly. 

 

5.2.2 Background 

In structural analysis and design, a suitable model to represent and simulate the true 

behaviour of a structure is necessary for obtaining an accurate output. The first-order 

linear analysis is based on the assumption of elastic material behaviour and 

undeformed structural geometry for equilibrium check. The elastic analysis does not 

fully comply with the requirements of the limit state design (LSD) philosophy and 

additional member check is needed to ensure nonlinear effects due to buckling and 

plastic failure do not occur under the design loads. Also, the use of plastic moment 

capacity in design and the adoption of an elastic analysis are inconsistent. More 

critically, buckling is system behaviour while the design check is member-based and 

they are not compatible with great uncertainty in effective length factor (Le/L). 

A complete non-linear analysis traces the structural response until the limit state is 

reached with allowance for non-linear geometrical and material behaviour and 

imperfections. As such, the limit load from the analysis can be directly compared with 

the factored design load and individual member design becomes unnecessary. Because 

of this characteristic, the method is sometimes called the “Direct analysis” in the U.S.A. 

However, in order to simplify the complexity of an analysis, different versions of 

non-linear analysis are available. The engineer must therefore fully realize the 

limitation of any one of these versions otherwise disaster due to over-estimation of load 

resistance may occur. The P-Δ-only version of second-order analysis requires 

additional checks using the tables in the code and the software is not fully “automatic”. 

All software for second-order non-linear analysis, like the first-order linear analysis, 

requires careful input of data file and interpretation of data output. This section 

introduces the design concept for a second-order elastic and plastic analysis of steel 

frames used in many real projects. Below is a summary of these methods which are 

essential in understanding the new design theory. 
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5.2.3 First-order Linear Analysis 

As other structural analysis software, NIDA plots the bending moment and shear force 

diagrams under the assumption that change in geometry under load does not affect the 

structural stiffness. 

 

5.2.4 Second-order Analysis 

In this second-order analysis, NIDA performs the following functions. 

 Calculate the displacements and rotations at all the nodes or junctions of elements 

or members, allowing for the change of structural geometry (P- and P- effects) 

upon loading. 

 Calculate the bending moments about the element cross sectional axes, torsional 

moment about the longitudinal axis and axial force in the member, allowing for 

the second-order non-linear effects due to axial force. Shear will also be 

determined in the computer output. 

 Design a structure by section capacity check that effective length is not required to 

be assumed. 

 Check the instability of members as well as global structure. 

 Design the structure by a system approach, in contrast to the traditional 

“member-based” design method. 

 

5.2.4.1 Second-order Elastic Analysis 

In the design of steel structures by second-order non-linear analysis, the program 

increments the load in a step-by-step and incremental-iterative manner. Thus, a small 

increment of, say, from 5 to 25%, of expected design load is applied to the structure 

and the displacements are then computed and used to calculate the resistance. Iteration 

for equilibrium is carried out if they do not balance and convergence is assumed when 

the error of the norm of the unbalanced forces is smaller than 0.1% of the applied force. 

After convergence, the section capacity is checked for each member using Equation 

(5.1.2). When any one of the members fails to meet the section capacity check, it is 

considered to have failed and it is then indicated in red and shown in post-viewer. After 

this step, a new load increment is applied and the same iterative procedure is exercised. 

This incremental-iterative procedure is activated until the specified number of load 

increments has been applied and the analysis is completed or when divergence occurs. 

In the whole design and analysis process, no assumption of effective length is needed 

since the P- and P- effects have been considered in Equation (5.1.2). 

 

5.2.4.2 Second-order Plastic Analysis or Advanced Analysis 

This type of second-order plastic or advanced analysis is similar to the above elastic 

analysis except it needs not stop at the first plastic hinge as its design resistant load. 

When a member fails, a hinge is inserted to the member end close to the hinge position 

and analysis continues until the collapse load is reached. The collapse load is taken as 

the load level which does not allow further load increase indicated as a curve reaches 
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plateau, descends or stagnates in the load vs. deflection plot. In design, this collapse 

load should be greater than or equal to the factored design load in all load cases. 

In Plastic Advanced “plastic element” analysis, when a member reaches its design 

resistance, the axial force and moments of the member are kept constant and not 

allowed to change with the increasing load. This implies additional loads will be 

re-distributed to other members. 

In plastic advanced “plastic hinge” analysis, when a member reaches its design 

resistance, a plastic hinge will be inserted to the node close to the location of plastic 

moment. 

Note that, in second-order elastic-plastic analysis, the load increment should be smaller 

and generally should be less than 1% of the expected design load. Also, the arc length 

plus minimum residual displacement method should be used with control parameters 

sufficiently smaller, normally between 2 to 3. 

 

5.2.5 Vibration and Buckling Analysis 

NIDA determines the natural frequency by lump mass or consistent mass assumptions 

and the eigen-value buckling load factor as follows.  

 For natural frequency analysis 

 2 0LK M   and period 2 /T    (5.2.1) 

 For eigenvalue buckling analysis 

 0L GK K   (5.2.2) 
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5.3 General Nonlinear Parameters for Analysis 

 

5.3.1 Total Load Cycles 

It describes the number of total load cycles for the nonlinear analysis. The number is 

equal to the total number of load cycles required in the Analysis.  

 

5.3.2 Maximum Iterations for each Load Cycle 

It describes the maximum number of iteration for each load cycle in the analysis. If the 

equilibrium condition is satisfied before this number is reached or the iteration number 

is equal to this assigned iteration number, another load step will be imposed until the 

permitted number of load steps is reached. The tolerance for equilibrium check is 0.1 % 

by default. That is, when the Euclidean norms of the unbalanced displacements and the 

unbalanced forces are less than respectively 0.1 % of the total applied forces and the 

total accumulated displacements, the equilibrium condition is assumed to have been 

satisfied. 

 

5.3.3 Number of Iterations for Tangent Stiffness Matrix 

It describes the number of iterations for the tangent stiffness matrix to reform during 

the iterative process. When this number is specified to be very large or simply equal to 

the “maximum number of iterations for each load cycle” above, the iterative scheme 

will then become the modified Newton Raphson method. If the number here is 

specified as "1”, it becomes the Newton Raphson method. If the number is between 

these two extremes, the method is a mixed Newton-Raphson method. When compared 

to modified Newton Raphson method, the Newton Raphson method generally requires 

less number of iterations for convergence, but longer time for each iteration. It is 

recommended to use the Newton Raphson method 

 

5.3.4 Incremental Load Factor 

This factor will be used as the first load factor used for the analysis and the load factor 

increment in subsequent analysis. It is different from the design load factor behind 

“header load” which is multiplied to the input load to obtain the design load vector and 

will not appear in the plotting of equilibrium or load-deflection curve with its value 

generally taken as, for example, 1.6 for wind, 1.4 for self-weight etc. The load factor 

described here is used as the ratio of the current applied load to the input design load. 

For example, if a structure yields at a load factor of 2.6, it means when the applied load 

is 2.6 of the design load, the structure yields. 

 

5.3.5 Imperfection Method & Direction 

It describes the direction of initial imperfection with different methods. It can be no 

initial imperfection, initial imperfection in one principal plane causing less severe 

effect than initial imperfection in both the principal planes. The minimum magnitude of 

initial imperfection is taken as 1/1000 of the member length if the initial imperfections 
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are allowed. For some sections such as cold-formed sections, this value may not be 

adequate. For global imperfections of a structure, the notional force can be used in 

place of member imperfections.  

 

5.3.6 Magnitude of Imperfection for Global Eigenvalue Mode 

This value is the magnitude of imperfection when eigenvalue buckling mode is adopted. 

After the eigenvalue analysis, the eigen-mode is determined and a set of initial 

imperfection is determined for the structure with this mode shape. This number is for 

the magnitude (maximum) of the initial deflection for the eigen-mode which is then 

added to the initial geometry of the structure. 
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5.4 Numerical Methods for Nonlinear Analysis 

 

5.4.1 Load Incremental Schemes 

It describes the solution method for control of load increment size. There are five 

methods to be selected. 

Newton-Raphson (Constant Load) Method 

Single Displacement Control Method  

Minimum Residual Displacement Method 

Arc Length Method 

Constant Work Method 

 

5.4.2 Iterative Schemes 

It describes the solution method for control of iterative scheme. Same as above are five 

methods to be selected. 

Newton-Raphson (Constant Load) Method 

Single Displacement Control Method  

Minimum Residual Displacement Method 

Arc Length Method 

Constant Work Method 

 

5.4.3 Incremental-Iterative Schemes 

Generally the numerical methods for incremental-iterative procedure can be any 

methods mentioned above. For easy use, three common combinations are provided. 

 

Newton-Raphson (Constant Load) Method 

For constant load increment method, the Newton-Raphson method will be used for 

load incremental scheme and iterative scheme. 

 

Single Displacement Control (Constant Displacement) Method 

For constant displacement increment method, single displacement control method will 

be used for load incremental scheme and iterative scheme. 

 

Arc Length Method + Minimum Residual Displacement Method 

Arclength method will be used for load incremental scheme and minimum residual 

displacement method will be used for iterative scheme. 
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5.4.4 Solution Methods 

5.4.4.1 Newton-Raphson (Constant Load) Method 

This is the only method providing the response of a structure at the input load in terms of 

buckling strength and therefore it should be used check the adequacy of a structure under 

a set of factored design loads. In the Newton-Raphson method, iteration is activated to 

obtain the equilibrium condition between the applied forces and the internal structural 

resistance within a load step. Unlike the pure incremental method in which no 

equilibrium check is performed, the unbalanced force is dissipated via the iterative 

procedure and can therefore be eliminated by this method. Being free from the drift-off 

error, the solution is more accurate and the computational time is reduced when 

compared to the pure incremental method. The general procedure can be summarized by 

the following recurrent equations. The quantities in the following can be referred to 

Figure 5.5 and Figure 5.6. The load increment at the k-th cycle and the i-th iteration,

}F{ k
i , can be obtained from the external load vector }F̂{  as,  

 }F̂{  = }F{ kk
i   (5.4.1) 

in which 
k  is an incremental load factor at the k-th load cycle. 

 

 

Figure 5.5  Conventional Newton-Raphson Method 
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Figure 5.6  Modified Newton-Raphson Method 

For the i-th iteration within this load step, the displacement increment }r{ k
i  can be 

determined as, 

 }F { ]K[ = }r { k
i

-1

T

k
i

k
i   (5.4.2) 

in which ]K[ T

k
i is the instantaneous tangent stiffness matrix; the superscript i is for the 

i-th iteration.  Thus, the updated total displacement }r{ k
1i+ can be added by the last 

displacement }r{ k
i to this displacement increment as, 

 }r { + }r{ = }r{ k
i

k
i

k
1i+   (5.4.3) 

The resistance of the structure }R{ k
1i+ and the unbalanced force }F{ k

1i+ can be calculated 

as, 

 

kk ke
i+1 i+1i+1

k k-1 k

kk k
i+1 i+1

{ } = [ ] { }KR r 

        =  +  

ˆ{  } =  {F} - { }F R

  

  



 






 (5.4.4) 

in which ]K [
k

1i+
e is the element stiffness at local coordinate and }r{ k

1i+ is the element 

nodal displacement extracted from the global displacement vector and transformed to the 

element local axis. The procedure from Equations (5.4.2) to (5.4.4) is repeated until 

convergence is reached. 

For the conventional Newton-Raphson method, the tangent stiffness matrix of the 

structure ]K[ T

k
i will be updated at every iteration while for the modified 

Newton-Raphson method, it is reformed only in the first iteration and is kept unchanged 

within the load cycle. 
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The conventional and the modified Newton-Raphson methods usually provide a rapid rate 

of convergence in the stable equilibrium range.  However, when approaching the limit 

point of the load-deflection curve, a large number of iterations will be required even for a 

small load increment.  In the Newton-Raphson method, the solution point at the 

specified applied load level is sought and therefore any unloading path cannot be traced. 

Consequently, the solution scheme diverges near the critical point due to the 

ill-conditioning of the tangent stiffness matrix or simply due to the size of the load 

increment being greater than the limit load as shown in the Figure 5.5 and Figure 5.6. 

 

5.4.4.2 Single Displacement Control Method  

Unlike the load control methods previously described, a constraint equation for 

displacement is imposed in this approach. The displacement control method was 

originally proposed by Argyris (1965). In his study, however, the symmetrical nature of 

the tangent stiffness matrix is destroyed by adding the displacement constraint equation.  

In order to retain the symmetrical property of the tangent stiffness matrix, Batoz and Dhatt 

(1979) imposed the constraint for displacement via iteration. According to their procedure, 

a single displacement degree of freedom is chosen to be constrained.  The accumulated 

value of this displacement within a load cycle is given by, 

 ) r    + r̂    ( + r   = r  
k
i

jjk
i

k
1i-

jk
i

j   (5.4.5) 

in which r  
k
i

j  is the accumulated displacement for the j-th degree of freedom, at k-th 

load cycle and in the i-th iteration; 
k
i  is the incremental load factor; and r̂  

j and 

r  
k
i

j are respectively the displacements for the unbalanced force and for the reference 

load vector at the j-th degree of freedom. 

In the first iteration, we have 0 = r   = r  
k
1

jk
0

j  and hence Equation (5.4.5) can be 

simplified as, 

 
r̂  

r~  
  - =  

j

j
k
1  (5.4.6) 

in which r~  
j  is the specified displacement increment at the j-th degree of freedom.  

After the first load increment, the control displacement is kept constant so that, 

 r   = r  
k
1i-

jk
i

j  (5.4.7) 

Substituting Equation (5.4.7) into (5.4.5), the adjustment on the load factor at i-th 

iteration, 
k
i  , can be obtained as, 

 
r̂  

r   
  - =  

j

k
i

j
k
i


   (5.4.8) 

The diagrammatic presentation of the above procedures is depicted in Figure 5.7. 

The constant displacement method does not exhibit any difficulty in passing the 

snap-through limit point but fails to converge in snap-back problems.  Thus, it is usually 

used in conjunction with other solution schemes in order to solve general nonlinear 

problems.  For example, Sabir and Lock (1972) used the constant load Newton-Raphson 
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method, which can handle the snap-back but not the snap-through problem, together with 

the constant displacement method in their nonlinear analysis of shell structures exhibiting 

snap-through and snap-back behaviour. 

 

 

Figure 5.7  Displacement Control Method 

 

5.4.4.3 Constant Work Method 

Similar to the constant displacement method, the basic idea of the constant work method 

is to impose a constraint equation to guide the incremental load.  In this case, the work 

done by the external loading is kept constant within a load increment. The use of this 

concept on nonlinear analysis has been reported by many researchers including Honecher 

(1980), Powell and Simons (1981), Karamanlidis et al. (1981), Bathe and Dvorkin (1983) 

and Yang (1984). 

Before introducing the constant work constraint, Equation (5.4.5) is first rewritten in 

terms of the complete displacement vector instead of a single degree of freedom as, 

   }r { + }r̂{    + }{r = }{r
k

i

k
i

k

1i-

k

i
  (5.4.9) 

Assume Wo  to be the specified work increment in a load step. For the first iteration, 

}{r
k

1i-
 and }r{

k

i
  are zeros.  Hence, we have, 

 }r̂{ }F̂{ ) ( = }{r }{F = W 
T2k

1

k

1

k

1o    (5.4.10) 

and, 
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
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




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




}r̂{ }F̂{

W 
 =  

T

ok
1


  (5.4.11) 

in which Wo  can be calculated according to the work done by the specified load in the 

first cycle; and }r̂{  is the displacement increment due to the reference external load as,  

 }F̂{  ]K[ = }r̂{
1-    

T

k
i  (5.4.12) 

For the second and subsequent iterations, the external work done is kept constant and thus 

there should be no work done due to the change in displacement. This condition can be 

expressed as, 

   0 =  }r { + }r̂{   }F̂{ 
k

i

k
i

Tk
i   (5.4.13) 

and the load factor, 
k
i , can be expressed as, 

 
}r̂{ }F̂{

}r { }F̂{
 - =  

T

k

i

T

k
i


   (5.4.14) 

Graphical illustration of the procedure for the constant work method is shown in Figure 

5.8. It can be seen from the figure that the load increment is directed towards the 

load-deformation curve so that there would not be any difficulty in handling both general 

snap-through and snap-back problems. Exception of this will be the case when the loaded 

degrees of freedoms exhibit snap-back behaviour. This characteristic has been discussed 

by Chan and Ho (1990). However, Bathe and Dvorkin (1983) showed that its rate of 

convergence is slow when compared to the arc-length method which is discussed in the 

following sub-section. 

 

Figure 5.8  Constant Work Method 
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5.4.4.4 Arc Length Method 

Different forms of the arc-length method have been proposed by Wempner (1971), Riks 

(1979) and Ramm (1980; 1981) for nonlinear analysis. In NIDA, the spherical constant 

arc-length method suggested by Crisfield (1981) is adopted as it shows to be more reliable 

than others. 

The basic concept of the spherical arc-length method is to constrain the load increment so 

that the dot product of displacement along the iteration path remains constantly in the 

2-dimensional plane of load versus deformation. This means that the constraint condition 

is given by,  

     Ŝ =  }r { + }r̂{   + }{r      }r { + }r̂{   + }{r
2k

i

k
i

kk

i

k
i

k

1i-

T
   (5.4. 15) 

in which  is the specified constant arc-length. 

For the first iteration, 0 = }r { = }{r
kk

0
 . Thus, the first incremental load factor is given 

by, 

 

   
1

Ŝ

ˆ ˆr r

k

T
 


 (5.4. 16) 

It is noted that the sign for the load increment will be the same as that for the determinant 

of the updated tangent stiffness matrix. In other words, a positive determinant will lead to 

an increase in loading while a negative determinant will result in a decreasing load. This 

concept of choosing the sign was first suggested by Bergan and Soreide (1978) in their 

studies using the method of current stiffness parameter. 

The load increment for the second and subsequent iterations can be calculated by 

expanding Equation (5.4.15), which yields a quadratic equation in 
j
i   as, 

 0 = b + ) (  b + ) (  b 0
k
i1

2k
i2    (5.4. 17) 

where, 
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 

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

 (5.4. 18) 

In general, two different roots for 
k
i   can be obtained from Equation (5.4.17).  The 

proper solution to be used would be the one which satisfies the following condition as, 

 0   >   }{r   }F̂{    
k

i

k
i  (5.4. 19) 

In case when both roots satisfy Equation (5.4.19), the one close to the linear solution 

given below should be chosen as, 

 
b

b
 -  =  

1

0k
i  (5.4. 20) 

If the solution point is approaching the limit point, a smaller arc-length should be used to 

prevent divergence. The specified arc distance at a particular i-th iteration is given by, 

S

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d
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1k-k
 (5.4. 21) 

in which Ŝk
 and Ŝ 1k-

 are the arc-lengths for the k-th and (k-1)-th load cycle; Id  is the 

desired number of iterations; and I 1k-  is the number of iterations used in the last or 

(k-1)-th cycle. 

The procedure of the spherical arc-length method is illustrated in Figure 5.9. Owing to its 

accuracy, reliability and satisfactory rate of convergence, it is probably the most popular 

method for nonlinear analysis and it was noted to be robust and stable for pre- and 

post-buckling analysis. 

 

Figure 5.9  Arc-length Method 

 

5.4.4.5 Minimum Residual Displacement Method 

The basic idea of this method originally proposed by Chan (1988) is to minimize the norm 

of residual displacement in each iteration. The constraint equation can be written as, 

      0 =   }r̂{   + }r {   }r̂{   + }r {   
 d

d k
i

k

i
k
i

k

i

T

k
i




  (5.4. 22) 

Re-arrange the above equation, there obtained, 

 
}r̂{  }r̂{

}r {  }r̂{
 - =  

T

k

i

T

k
i




   (5.4. 23) 

in which 
k
i  is the load increment factor to be determined for all iterations except the 

first one. For the first iteration, the load increment factor is chosen to be, 
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in which   is a parameter defined by the analyst for the control of load size and the sign 

of the load factor is taken to be the same as that of the determinant of the updated tangent 

stiffness matrix. The choice of 
k
1   is indeed arbitrary. It is later found that the 

procedure of spherical arc-length method in determining the load factor for the first 

iteration is more appropriate. 

The graphical representation of the procedure is demonstrated in Figure 5.10. From the 

figure, it can be seen that this constraint condition enforces the iteration path to follow a 

path normal to the load-deformation curve. It adopts the shortest path to arrive at the 

solution path by error minimization and thus is considered to be an optimum solution. In 

addition, the procedure from Equations (5.4.22) to (5.4.24) is much simpler to use than the 

arc-length method. Generally speaking, owing to its efficiency and effectiveness in tracing 

the equilibrium path, the minimum residual displacement method is usually chosen to 

perform the iterative procedure and combined with the part for load size determination in 

the first iteration by the arc-length method. Unless otherwise specified, the combination 

for the nonlinear solution strategy is used in NIDA for static analysis. 

 

Figure 5.10  Minimum Residual Displacement Method 
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5.5 Beam-Column Element 

 

5.5.1 Coordinate Systems 

All structural analyses require a set of consistent coordinate systems to define the 

vector quantities. A properly defined coordinate system is essential for the 

development of reliable, convenient and user-friendly analysis computer program. In 

some cases the loads are referred to in a global coordinate system such as the structural 

dead weight and the gravitational loads. In other cases, the loads are referenced by the 

local coordinate system which belongs to the element itself. This loading type includes 

the pressure load perpendicular to the element axis. Wind load can act on the projected 

area about either the global or the local axes, depending on the load case being 

considered. 

About the output of NIDA, nodal displacements are always defined in global 

coordinates. However, internal forces and moments are output in local coordinate 

systems. 

In NIDA, two coordinate systems are adopted to describe analytical model, i.e., global 

coordinate system describing the structural model and local coordinate system 

describing the finite element model. To illustrate the relationship between global 

system and local system, a coordinate system of reference, named reference coordinate 

system, i.e., default local coordinate system, is introduced to help transform arbitrary 

local system to global system. 

All coordinate systems are right-handed, 3D Cartesian systems. 

 

5.5.1.1 Global Coordinate System 

The global coordinate system OXYZ is a set of coordinate axes for the complete 

structure. The stiffness and applied forces for all the elements must be transformed to 

this coordinate system for global superposition. 

The location and orientation of global coordinate system is arbitrary. In default the Y

-axis is upward, but could be altered according to required conditions. 

 

5.5.1.2 Reference Coordinate System 

For sake of convenience, global coordinate system OXYZ and local coordinate system 

oxyz  can be linked by reference coordinate system zyxo , which could be defined as 

below: 

1. z -axis always parallels to global XZ plane; 

2. Angle   between local yx   plane and global X-Y plane should satisfy 

900  ; 

3. When element or member is perpendicular to global XZ plane, i.e., 90 , z -axis 

and global Z-axis are in the same direction. 
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Figure 5.11 Coordinate Systems of Beam-Column Element 

Reference coordinate system is the default local coordinate system in NIDA. 

 

5.5.1.3 Local Coordinate System 

In default, local coordinate system oxyz  is the same as reference coordinate system 

zyxo .  

However, the default local coordinate system may be oriented differently from the 

considered member section. Generally, an angle, named   (see Figure 5.12), lies 

between the real local coordinate system and reference coordinate system. 

Once the orientation of local coordinate system is different from that of reference 

coordinate system, i.e. 0 , the angle   should be specified in NIDA or edited in 

the input file manually. Alternatively, K-node (see Figure 5.13) could be specified to 

determinate the local xy  plane expediently. 

 

 

Figure 5.12  Orientation Angle   

 

z 
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Figure 5.13  K-node for Local Axis 

 

5.5.2 PEP Element 

5.5.2.1 Introduction 

Pointwise Equilibrating Polynomial (PEP) element based on a fifth-order polynomial 

shape function was developed to enable the second-order analysis by using one single 

element per member. With the inclusion of initial imperfection, the improved PEP 

element shows good performance in predicting the buckling behaviour of slender 

structure. The behaviour of high slenderness ratio steel member can be precisely 

captured by using PEP element. On the contrary, the conventional cubic Hermite 

element can only reflect the behaviour of the low slenderness ratio member. With the 

invention of PEP element, practical and reliable second-order analysis and design 

become possible. 

 

5.5.2.2 Assumptions 

The PEP element was based on the following assumptions. 

 The theory is based on the underlying assumption of the beam-column theory by 

Timoshenko and Gere. 

 The element is prismatic and elastic. 

 The applied loads are conservative and nodal. 

 Small strain but arbitrarily large deflection is considered. 

 Warping is ignored. 

 The member but not the frame is assumed to be prevented against any 

out-of-plane deformation due to instability caused by moments. 

 Rotations between the tangent at member ends and the chord joining the two ends 

are small. 

 

5.5.2.3 Formulations 

The shape function of the lateral displacement along one principal plane of the PEP 

element as shown in Figure 5.14 is assumed to be a fifth-order polynomial which is 

given by 
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Figure 5.14  Basic Forces vs. Displacements Relations in PEP Element  

(with Initial Imperfection) 
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The initial curvature as shown in Figure 5.14 is assumed to be a quadratic function 

which is given by 
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In order to solve the six unknown coefficients of Equation (5.5.1), six boundary 

conditions are required. The differential equilibrium equation which takes the effect of 

axial force into consideration can be written as follows: 
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Differentiating both sides, obtained 
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For equilibrium state, the boundary conditions are given by 

At 0x ,         

  1 2
0
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EIv P v

M M
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L



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 (5.5. 5) 

The four boundary conditions for geometrical compatibility are:  

At 
2

L
x  , 0v  and 1v         (5.5. 6) 

At 
2

L
x  , 0v  and 2v   

Applying boundary conditions from Equations (5.5.5) to (5.5.6), the coefficients of 

Equations (5.5.1).can be solved. Unlike the stability function, the shape function 

derived of a PEP element is valid for positive, zero and negative values of P.  

For axial deformation and torsion, their respective shape functions can be assumed to 

be linear as:  

  0 1u b b x                         (5.5. 7)
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With the above boundary conditions, the shape functions of axial deformation and twist 

can be obtained: 
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 (5.5. 8) 

The total potential energy function, , is given by: 

 VU   (5.5. 9) 

in which U is the strain energy and V is the external work done. The strain energy, U, 

can be written as: 

 dxvvvPdxvEIdxuEAU
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22 2
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1

2

1

2

1
 (5.5. 10) 

The secant stiffness matrix can be found from the first variation of the strain energy 

function. 

The tangent stiffness matrix can be found from the second variation of the total 

potential energy function. 

 

5.5.2.4 Transformation Matrices 

Before carrying a second-order analysis, the element stiffness matrix must be 

transformed from the local system to the global system. The stiffness matrices above 

are derived basically for an element has 6 degrees of freedom, namely, 

                            . These 6 independent forces and moments are required to be 

expressed in terms of 12 degrees of freedom as: 

     PTF   (5.5. 11) 

in which      is the 12×1 local element force vector 

                                                                 
 ,     is the 6×1 

elemental force vector                                    
  and    is the 

transformation matrix as 
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With the transformation matrix    , 6×6 the element stiffness matrix       in the 

local coordinate system having the dimension of 12×12 can be obtained as 

      TeTe TkTk   (5.5. 12) 

 

Rotational transformation matrix for principal axes 

For asymmetric members such as angles, the principle axes are not parallel to the 

global axes. In order to relate the sectional properties of the member in the principal 

axes to those parallel to the global axes, a rotational transformation matrix is required 

as shown as follows. 
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And 
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Local to global transformation matrix 

In order to transform the stiffness matrix for the elements from the local coordinate 

system to the global coordinate system, the following transformation matrix is 

required. 
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And 

  

 
 

 
 




















'

'

'

'

1

1

1

1

1

L

L

L

L

L
 (5.5. 16) 

 

in which   ,    and    are the direction cosines of x, y and z axes. 

However, when the member is vertical, i.e. |  |   ,        , the following 

matrix for     
  should be used. 
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L  (5.5. 17) 

The overall transformation matrix     is the product of the rotational and the local to 

global transformation matrices. i.e. 

     21 LLL   (5.5. 18) 

 

The global tangent stiffness matrix of an element is given by 

       LkLk Te

T

T   (5.5. 19) 

 

5.5.3 Curved Stability Function 

Real structural members contain imperfection and so design codes require implicit (via 

use of different buckling curves) or explicit (via element formulation) consideration of 

initial imperfection in element geometry. The conventional stability function with high 

accuracy in beam-column analysis is improved to consider member initial bowing.  

Imperfections are first assumed to be in a half sine curve with an assigned amplitude at 

mid-span as follows (see also Figure 5.15). 
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Figure 5.15  Stability Function Element with Initial Crookedness 

 
0 mov v sin

x

L


  (5.5. 20) 

in which v0 is the lateral deflection, vmo is the magnitude of imperfection at the 

mid-span, x is the distance along the element longitudinal axis and L is the element 

length (Figure 5.15). 

The equilibrium equation along the element length can be expressed as, 

 
2

1 1 2
0 1 12

d v M M
EI P(v v ) M

d L
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x


      (5.5. 21) 

in which EI is the flexural rigidity, M1 and M2 are the nodal moments and v1 is the 

lateral displacement induced by loads. 

Making use of the boundary conditions that when x=0 and x=L, v1=0, we have, 

 1 2
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 (5.5. 22) 

Superimposing the deflection to the initial imperfection, we have the final offset of the 

element centroidal axis from the axis joining the two ends of the element as, 
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 (5.5. 23) 

in which,  

 
P P

, L,q
EI Pcr

k k    (5.5. 24) 

And     is the buckling axial force parameter given by     
    

  . 

Differentiating Equation (5.5.22) with respect to x, and expressing the rotations at two 

ends in terms of the nodal rotations as,
   

  
        

   

  
        , we have, 
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 (5.5. 25) 
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in which   ,    and    are stability functions given in appendix. Axial strain can be 

expressed in terms of the nodal shortening, the bowing due to initial imperfection and 

deflection as, 

 0

L L L

c u 
     (5.5. 27) 

in which u is the nodal shortening, 0  and c  are the shortening due to bowing of 

initial imperfection and deflection given by, 

 

 

(5.5. 28) 

Substituting Equations (1) and (4) into Equations (10) and (11), we have, 

  (5.5. 29) 

in which   ,   ,     and     are curvature functions and A is the cross sectional 

area. These functions need to be repeatedly derived for the cases of positive, zero and 

negative values of axial force parameter, q . Expressions for    and    are given in 

appendix for completeness and these coefficients are originally given by Oran who, 

however, considered only a straight element and bvs and bvv are listed in appendix.  

Defining [F] and [u] as the basic nodal variables at two ends of an element as, 

  (5.5. 30) 

  (5.5. 31) 

the tangent stiffness equation for the incremental forces and displacements can then be 

written as, 

 
 

(5.5. 32) 

in which [L] is the global to local transformation matrix, [T] is the transformation 

matrix relating the 6 local forces and moments to the 12 nodal forces and moments in 

local element coordinate system, [N] is the geometric matrix accounting for nodal 

translations and  ek  is the element tangent stiffness matrix in the local co-ordinate 

system given by, 

  (5.5. 33) 
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5.6 Shell Element 

 

5.6.1 Triangular Shell 

In NIDA, the triangular shell element is a flat type element which superimposes plate 

bending and membrane element stiffness, in conjunction with the Kirchhoff thin shell 

theory. 

 

Membrane Stiffness 

In NIDA, the constant strain triangular (CST) with drilling degree of freedom 

developed by Allman (1984) is used. The strain vector can be expressed in terms of 

the displacement in the element and then to the nodal displacements as,  

  (5.6. 1) 

in which                                             
 is the nine element nodal 

displacements and rotations (see Figure 5.16) and  mB is the strain vs. displacement 

matrix given by, 

× 

  (5.6. 2) 

in which     and    are the coordinates of vertex i in local coordinate with x-axis 

passing through node 1 and 2. 

The membrane element stiffness can then be obtained by a standard procedure as, 

  (5.6. 3) 

in which      is the elasticity matrix,   is the element thickness and   is the 

element area. The elasticity matrix is defined as follows, 

  (5.6. 4) 

where   is the Poisson’s ratio and   is the Young’s modulus of elasticity. 
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Bending Stiffness 

Discrete Kirchhoff triangular (DKT) element proposed by Batoz et al. (1980) is used 

in NIDA. In the element, the Kirchhoff hypothesis is imposed on the element at its 

corners and mid-side nodes only. The bending stiffness of the element is based on the 

assumption of zero shear strain energy. The curvature     of the plate can be derived 

in terms of the nodal displacement      as, 

  (5.6. 5) 

in which                                                 is the nodal displacement 

degrees of freedom, as shown in Figure 5.16,    and     are the rotations of the 

normal to the undeformed middle surface in the x-z and y-z planes and      is the 

strain vs. displacement matrix given by, 

  (5.6. 6) 

where    and   are the area coordinates; [    ] and [    ] are the derivatives of 

the interpolation function [       ]  with respect to   and   while [    ]  and 

[    ] are the derivatives of the interpolation function [       ] with respect to    

and   . 

Using the principle of total potential energy, the bending stiffness of the element can 

be derived as, 

  (5.6. 7) 

in which      is elasticity matrix for plate bending and it can be expressed as follows. 

  (5.6. 8) 

 

Geometric Stiffness Matrix 

The geometric stiffness matrix is formed by the product of the initial stress and the 

quadratic strain tensor energy due to the motion of an element. The initial stresses are 

taken as the average of their respective element stresses calculated from the membrane 

stiffness. Mathematically the geometric stiffness matrix can be written as Zienkiewicz 

and Taylor (1989) 
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  (5.6. 9) 

in which    ,    and     are the product of the average membrane stresses and the 

plate thickness. 

The matrix     is the derivative of the shape functions given by 

  (5.6. 10) 

 

Element Stiffness Matrix 

The flat shell element is superposed by CST and DKT and the complete element 

stiffness can be obtained from Eqns (5.6.3) and (5.6.7) as, 

  (5.6. 11) 

in which [KL] is the shell element composed of membrane and bending stiffness. The 

incremental tangent matrix can be written as below. 

      e L GK K K      (5.6. 12) 

 

 

 

 

 

 

 

 

 

 

 

                       (a) Membrane stiffness         (b) Bending stiffness 

Figure 5.16  Shell Element (CST + DKT) 
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5.7 Response Spectrum Analysis 

 

5.7.1 Response Spectra of SDOF Systems 

Although a real structure may be very complicated and possess many degrees of 

freedom, the design spectra are essentially obtained from a single-degree-of-freedom 

(SDOF) system as shown in Figure 5.17. For this typical SDOF system, the equation of 

motion can be formulated by expressing the equilibrium of all forces acting on the 

system. 

  (5.7. 1) 

in which,      is time-varying force,       is inertial force,       is damping force,  

      is elastic restoring force. The governing equation of motion can be rewritten as 

   ̈      ̇             ̈     (5.7. 2) 

where   is mass of the SDOF system produced inertial force,   is damping constant 

presented energy dissipation mechanism,   is linear stiffness of the spring provided 

elastic resistance. 

 

 

 

 

 

 

 

 

 

 

 

Figure 5.17  SDOF System under Horizontal Force 

 

By defining the natural frequency and damping ratio as 
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The governing equation of a SDOF system subjected to ground acceleration  ̈      

becomes 

  (5.7. 5) 

The Eq. (5) clearly shows that for a given  ̈     the displacement response      of 

the system depends only on its natural frequency   (or period  ) and damping ratio 

 . That is, the same response      will be produced for any two systems having the 

same values   and  under a specified earthquake. Thus, the response spectrum 
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determined from a SDOF system can be applied to any structures though their stiffness 

and mass may be very different. 

The evaluation of the dynamic response such as displacement, velocity, acceleration, 

internal force and stress at every time instant during an earthquake is usually conducted 

by numerical integration (e.g. Newmark’s method, central difference method). For 

engineering application purpose, only the maximum absolute values of displacement, 

velocity and acceleration responses experienced by a structure are of interest as below: 

  (5.7. 6) 

in which    is spectral displacement,    is spectral velocity,   is spectral 

acceleration. 

In engineering practice, the following approximations are generally employed: 

  (5.7. 7) 

Where     is pseudo-spectral velocity,     is pseudo-spectral acceleration. The 

prefix ‘pseudo’ indicates that such values do not correspond to the actual peak spectral 

velocity and acceleration. The above spectral relationships significantly expedite the 

construction of earthquake response spectra because only the spectral displacement    

needs to be determined by numerical integration. 

A plot of the peak value of a spectral ordinate (i.e.   ,    or    ,    or    ) against 

the natural period   is called the response spectrum for that spectral ordinate. Each 

such plot is for SDOF systems having a fixed damping ratio   and therefore a family 

of plots will be produced to cover the range of damping values encountered in real 

structures. 

 

5.7.2 Design Spectra 

The response spectrum mentioned above is obtained from a specified past earthquake 

record. The shape of the response spectrum is normally very irregular for a given 

earthquake. However, certain similarities exist among the earthquake ground motions 

recorded under similar conditions. Thus, the design spectra can be derived from 

statistical analyses based on the response spectra obtained from earthquakes with 

common characteristics. The design spectra in seismic codes are usually presented as 

smooth curves and/or straight lines. 

Acceleration response spectra are commonly implemented in seismic design codes 

such as GB50011, Eurocode 8 and UBC97 because they are related directly to the base 

shear used in the seismic design. For long period structures, the displacement response 

spectra become more and more important for seismic design. 

It is convenient that the pseudo-spectral acceleration     is normalized by gravity 

acceleration    (GB50011, UBC97) or design acceleration    (Eurocode 8) to a 

dimensionless quantity. In GB50011, this dimensionless quantity is called seismic 

influence coefficient defined as 
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  (5.7. 8) 

 

5.7.3 Modal Response Spectrum Analysis 

Modal response spectrum analysis (MRSA) is used to find the maximum responses 

rather than the full responses during a likely earthquake. This method is performed 

using mode superposition. 

For a multi-degree-of-freedom structure, the governing equation of motion of the 

structure undergone an earthquake is given as 

  (5.7. 9) 

where     is mass matrix,     is damping matrix,     is stiffness matrix, and  

{ ̈    } is ground acceleration vector. 

 

Making use of the modal decomposition method, 

  (5.7. 10) 

the following modal equation can be obtained  

  (5.7. 11) 

in which    is natural frequency, j  is damping ratio, and 

  (5.7. 12) 

in which { }  is the modal shape for jth mode which can be determined by modal 

analysis, and    is the earthquake participation factor for jth mode. 

The modal response       for jth mode can be obtained by the Duhamel integral 

expression 

  (5.7. 13) 

where 

  (5.7. 14) 
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/paS g 

[ ]{ ( )} [ ]{ ( )} [ ]{ ( )} [ ]{ ( )}gM u t C u t K u t M u t   

1

{ ( )} [ ]{ } { } ( )
n

j j

j

u t q q t


  

2( ) 2 ( ) ( ) ( )j j j j j j j gq t q t q t u t      

1

2

1

{ } [ ]{1} { } [ ]{1}

{ } [ ]{ }

n

T T i ji
j j i

j nT

j j j
i ji

i

m
m m

M m
m


 


 







  




( )

0
( ) ( )sin ( ) ( )j j

t tj

j g j j j

j

q t e u t d t
  

    


 
    

( )

0

1
( ) ( )sin ( )j j

t t

j g j

j

t e u t d
  

   


 
   



Analysis Theory 
 

NIDA – Nonlinear Integrated Analysis & Design  175 

  (5.7. 15) 

The inertia force on ith DOF is expressed as 

  (5.7. 16) 

Using the relationship 
1

1
n

j ji

j

 


 , we have 

  (5.7. 17) 

Substituting Eqs. (5.7.15) and (5.7.17) into Eq. (5.7.16), the inertia force on ith DOF 

for jth mode can be written as 

  (5.7. 18) 

For engineering applications, we only need to know the maximum inertia force. 

  (5.7. 19) 

where 

  (5.7. 20) 

  (5.7. 21) 

The displacement response of ith DOF for jth mode can be calculated as 

  (5.7. 22) 

Thus, the other responses such as internal force and stress can be further determined 

from displacement response. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Figure 5.18  Seismic Influence Coefficient (GB50011) 
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Although there are many seismic design codes in the world, the difference between 

them when using MRSA mainly lies in the difference of determination of the 

coefficient   . Eq. (5.7.8) shows the definition of the coefficient   . Figure 5.18 

shows the curve for determination of    specified in GB50011. 

 

5.7.4 Participating Mass Ratio 

From above, it can be seen that the response spectrum analysis is based on the modal 

analysis which is used to find the natural frequencies and the vibration modes of the 

structures. When performing a modal analysis for a structure with large degrees of 

freedom, it only need to consider a relatively small number of modes  in the 

response calculations, such that   <<   (  is the number of all modes). Otherwise, it 

needs huge computer time to calculate all vibration modes. Thus, the displacement 

response in Eq. (5.7.15) can be approximated as 

  (5.7. 23) 

in which  ̂     represents the truncated response for   <  . 

However, the number   cannot be too small though small value of p means time 

saving. Otherwise, some important higher-mode effects will be ignored and, 

consequently the output may be not accurate enough. For this, the effective mass 

concept is widely used to determine the number of modes p to be input in the modal 

analysis. The effective mass for jth mode,    , is defined as 

  (5.7. 24) 

The sum of the effective masses for all modes is equal to the total mass   of the 

structure, i.e. 

  (5.7. 25) 

This leads to a means for determining the number of truncated modes necessary to 

accurately represent the structure response. If the structural response is calculated from 

the truncated modes, the ratio calculated by the sum of the effective masses from these 

modes over the total mass   should be not less than a predefined percentage. This 

ratio is called participating mass ratio which is given by 

  (5.7. 26) 

Many seismic design codes specify that at least 90% of the participating mass of the 

structure must be included in the response spectrum analysis. 
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5.7.5 Combination of Modal Responses 

Noted that the maximum responses for different modes do not occur simultaneously 

and therefore the maximum structural response cannot be obtained by taking the sum 

of the maximum modal responses. Two methods have been widely used for modal 

combination, i.e. the square-root-of-the-sum-of-the-squares (SRSS) method, and the 

complete-quadratic-combination (CQC) method. 

 

(1) SRSS method 

The SRSS method is usually applied for calculating the maximum response for 

two-dimensional systems exhibiting well-separated modes. In this method, 

  (5.7. 27) 

in which,     is the structural response such as internal force and displacement 

considering all selected modes, and    is the structural response for jth mode. 

 

(2) CQC method 

The CQC method is usually applied for calculating the maximum response for 

three-dimensional systems and/or systems with closely spaced modes. In this method, 

  (5.7. 28) 

 

in which,     is the correlation coefficient for jth mode and kth mode. When using 

constant damping ratio  , this coefficient is calculated as 

  (5.7. 29) 

where   
  

  
⁄  and must be not greater than 1.0.  

 

5.7.6 Combination of the Effects of the Components of the Seismic Action 

In real world, an earthquake may come from any directions such that a designed 

structure should be capable of resisting earthquake shaking from all possible directions. 

Generally, two horizontal components and one vertical component of seismic action 

should be considered to act simultaneously on a spatial structure. There are denoted 

here as     and     for the structural responses of the two horizontal components 

and     for the vertical. Since the peak value of the seismic action effects do not 

occur simultaneously, a combination rule is required to produce reasonable results. 

Two approaches have been widely used for directional combination, i.e. the 

square-root-of-the-sum-of-the-squares (SRSS) method, and the absolute-sum (ABS) 

method.  
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(1) SRSS method 

The SRSS method for directional combination assumes the components are 

independent of each other. In this method, 

  (5.7. 30) 

 

(2) ABS method 

The ABS method assumes that when the maximum response from one component 

occurs, the responses from the other two components are taken part of their maximum. 

In this method, 

  (5.7. 31) 

where 

  (5.7. 32) 

The value   in Eq. (5.7.32) is usually taken as 0.3 in seismic design codes. 
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5.8 Time History Analysis 

 

5.8.1 Direct Integration for Equation of Motion 

The incremental form of the equation of motion Eq. (5.7.8) can be written as.  

  (5.8. 1) 

in which {  } is equal to     {  ̈ }. For simplicity, the “(t)” in acceleration  ̈ t , 

velocity  ̇ t  and displacement   t  will be omitted hereafter. 

 

Noted that the damping matrix     is usually employed the Rayleigh damping model 

which is given as 

  (5.8. 2) 

in which   is mass proportional coefficient, and   is stiffness proportional 

coefficient. The two coefficients can be calculated by 

  (5.8. 3) 

in which    and    are the first and second natural periods of the structure 

respectively, and 1  and 2  are the damping ratios corresponding to   and    

respectively. 

MRSA solves the dynamic equilibrium equation by mode superposition approach while 

THA widely adopts numerical integration method. In NIDA [1], the Newmark method 

is utilized for step-by-step solution of Eq. (5.8.2). 

Newmark truncated the Taylor’s series for displacement { }and velocity { ̇} and 

finally expressed them as, 

  (5.8. 4) 

  (5.8. 5) 

where  tu ,  tu  and  tu  are the total displacement, velocity and acceleration 

vectors at time t , and t  is time increment. The parameters   and   define the 

variation of acceleration over a time step and determine the stability and accuracy 

characteristics of the method. Typically, 0.5   and 1/ 6 1/ 4   can provide 

stable results. 

By using Eqs. (5.8.4) and (5.8.5), the equation of motion Eq. (5.8.1) can be finally 

written as, 
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in which 

  (5.8. 7) 

  (5.8. 8) 

with 

  (5.8. 9) 

After obtaining  t u  from Eq. (5.8.6), the incremental velocity  t u  and 

acceleration  t u  can be calculated by 

  (5.8. 10) 

  (5.8. 11) 

Further, the total vectors for next time step are updated as 

  (5.8. 12) 

For nonlinear dynamic analysis, iterations for solving Eq. (5.8.6) are needed for 

correction of equilibrium error. To check the equilibrium, both the displacement and 

force norms are recommended, i.e. 

  (5.8. 13) 

  (5.8. 14) 

in which the subscript “ i ” is the number of iterations within a time step, and  *t F  

is the unbalanced residual force increment vector determined by 

  (5.8. 15) 

where  t tR  is the resisting force of the complete structure. 

Once the conditions given in Eqs. (5.8.13) and (5.8.14) are satisfied, the procedure 

presented in Eqs. (5.8.6-5.8.14) is repeated for next time step until the target time steps 

reach or the structure is collapsed.  
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selected for a time history analysis may significantly affect the outcome. Therefore, 
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seismic design codes explicitly or implicitly specify some requirements for selecting 

earthquake waves when performing a nonlinear dynamic analysis.  

The theoretical background for selection of earthquake wave is generally based on the 

three characteristics of ground motion, i.e. peak ground motion, time duration and 

frequency content. Peak ground motion, primarily peak ground acceleration (PGA), 

influences the vibration amplitude and has been commonly employed to scale 

earthquake design spectra and acceleration time histories. Time duration of ground 

motion affects the severity of ground shaking. For example, an earthquake with a high 

PGA poses a high hazard potential, but if it is sustained for only a short period of time 

it is unlikely to inflict significant damage to many types of structures. On the contrary, 

an earthquake with a moderate PGA and a long duration can build up damaging 

motions in certain types of structures. When the frequency content of the ground 

motion is close to the natural frequencies of the structure, the resonant phenomenon, in 

which the vibration amplitude of the structure grows indefinitely in theory, will occur. 

From above, the general rules for selection of earthquake waves in GB50011 are listed 

as below. 

 

(1) Minimum Time Duration 

The duration of the input wave should be long enough, which is generally taken as not 

less than 5 to 10 times of the fundamental period of the structure. 

 

(2) Minimum Number of Waves 

GB50011 specifies that at least 2 sets of recorded strong earthquake waves and 1 set of 

artificial wave, based on the seismic intensity, design seismic group and site 

classification, should be employed. 

 

(3) Minimum Base Shear 

The seismic action represented by the input waves should conform, on average, to the 5% 

damping elastic response spectrum so that the waves used may have the statistical 

meaning to some extent. GB50011 states that when performing an elastic time history 

analysis, the base shear obtained from each wave shall not be less than 65% of that 

from the response spectrum method, and the average value from all waves shall not be 

less than 80% of that from the response spectrum method. 
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5.9 Semi-Rigid Connection 

 

A semi-rigid connection must have the required strength, stiffness and ductility. Some 

typical moment versus rotation (M-θ) curves and various analytical and mathematical 

models representing the M-θ relationships can be found in previous chapters. 

Conveniently, a joint can be considered in an analysis as dimensionless with location at 

the intersection of the element centre lines. Further, a rotational spring element 

satisfying the M-θ relationship is inserted into each end of beam element to model the 

connection behaviour. The joint equilibrium condition can be expressed as, 

 
0e iM M 

 (5.9. 1) 

in which eM  and iM  are the moments at the two ends of a connection (see Figure 

5.19a). The corresponding external node is connected to the global node and the 

internal node is joined to the beam element. 

 

 

 

 

 

 

Figure 5.19  Modeling of Semi-Rigid Jointed Member 

 

The stiffness of the connection, S , can be related to relative rotations at the two ends 

of the connection spring as, 
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where e  and i  are the conjugate rotations for the moments eM  and iM  (see 

Figure 5.19b). Rewriting Equation (2) in matrix form, the stiffness matrix of a 

connection spring can be written as, 
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A typical beam element bending stiffness matrix can be expressed as, 

 

1 111 12

2 221 22

i i

i i

Mk k

Mk k





    
    

       (5.9. 4) 

in which ijk  is the stiffness coefficients of a prismatic beam. Here, the imperfect PEP 

element proposed by Chan and Zhou (1995) is adopted and more details can be referred 

to the original reference. Therefore, a hybrid element can be obtained by directly 
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adding the two ends connection stiffness to the PEP element bending stiffness matrix 

as, 
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in which the first subscript refers to node 1 or node 2. The internal degrees of freedom 

of the stiffness expression can be eliminated by a standard static condensation 

procedure. The stiffness expression of a beam element with both ends connected to a 

pair of springs can be finally written as, 
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and   is given by, 
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 (5.9. 9) 

where 1S and 2S  are the connection stiffness at nodes 1 and 2, respectively. When the 

spring stiffness iS  is zero, it means that the corresponding end is pinned end; when 

the spring stiffness iS is infinite, it means that the corresponding end is rigid end. For 

semi-rigid case, the spring stiffness iS  can be determined by the given M-θ function. 
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5.10 Plastic Hinge Method 

 

In the process of time history analysis by NIDA, a simple, accurate and efficient 

method for determining the plastic hinge(s) is used to capture the progressive strength 

and stiffness degradation of the structure under an earthquake attack. 

The basis of the plastic hinge method is cross-section plastification. Material yielding 

is accounted for by zero-length plastic hinges at one or both ends of each element.  

Plasticity is assumed to be lumped only at the ends of an element, while the portion 

within the element is assumed to remain elastic throughout the analysis.  

In NIDA, two predefined section springs (see Figure 5.20), which are used to simulate 

plastic hinge, will be set at the two ends of each beam-column element.  The end 

section springs will be finally formulated into the element stiffness matrix of the 

curved stability function beam-column element (Chan and Gu 2000) which has been 

widely used for second-order P-- analysis. More details about the plastic hinge 

method can be referred to Chan and Chui (2000).  

 

 

 

 

 

 

 

 

 

 

Figure 5.20  Internal Forces of the Curved Element with End Springs 

 

The hysteresis model for steel material used in NIDA is shown in Figure 5.21. As 

illustrated in Figure 5.21, initial yielding occurs at point A when the first yield moment 

capacity Mei is attained. On the curve AB, the gradual yielding occurs and the plastic 

moment capacity Mp is reached point B. When unloading takes place at point B, 

gradual yielding characteristics disappears and the path follows the line BDC in which 

the moment at point C is less than the initial yield moment Mei at point D. On 

reloading, the path moves along the line CD under the perfectly elastic state and then 

follows the curve DE under the partial yielding state. Similarly, under unloading 

conditions at point E, the path moves along EFG’H. 
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Figure 5.21  Elastic-Perfectly Plastic & Refined-Plastic Models 
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5.11 Load and Construction Sequences 

 

Sequential loads and segmental structural components are considered by assigning 

design load cases and structural elements to different load stages and they are applied 

by the load stage number sequentially, see Figure 5.22. Applying a set of loads in the 

first load stage and keeping them constant in the second load stage with a set of 

additional loads allow us to simulate load sequence.  

The strength, stability and deflection checks in the conventional design are essentially 

based on the complete structure without consideration of construction process. In fact, 

the behaviour of the components or units in the erection process may be different from 

the ideal case because instability and excessive deflection may occur in the 

construction stage with limited propping. Furthermore, shortening and undesirable 

deformations of the incomplete structure under self-weight and construction loads are 

inevitable. Generally speaking, the structural self-weight, external loads, boundary 

conditions and materials are depended on stages during the construction process and 

their variations are easily overlooked in conventional design.  

 

Figure 5.22  Construction Sequence Analysis 

 

The deformation and stress level during construction are key considerations by 

structural engineers. 

Unlike previous work using the first-order linear analysis which treats the limit states 

design and the construction analysis as two separate procedures with analysis by 

computers and design by charts, the proposed method integrates analysis to design and 

therefore the design and analysis models are consistent. Moreover, the P- and P- 

effects, initial imperfections, pre-deformation and material yielding are all taken into 

account. The flow chart of the proposed procedure is shown in Figure 5.23. 

The steps in the flowchart in Figure 5.23 are explained as follows. 
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(1) Define Construction Sequence 

Engineers group structural elements in the design model into a number of construction 

units according to the construction scheme and assign each of them a unique 

“Construction ID”. Only the elements in the active groups are considered in analysis at 

a particular loading stage with other non-active structural elements ignored. New 

elements are added to the structure at initial stage. 

(2) Apply Dead Loads (DL) and Construction Loads (CL) 

Dead loads are mainly from the structural self-weight and a load factor of 1.2 is 

suggested. Construction loads include the live loads, self-weight of equipments and 

others.  

(3) Pre-set Deformation 

Excessive deflections can be reduced by pre-cambering through pre-set displacements.  

(4) Construction Analysis 

Stiffness matrix of the members in active groups is solved with the nonlinear 

incremental-iterative procedure adopted to improve convergence.  

(5) Strength and Instability Check 

With the consideration of initial imperfections and P- and P- effects, a fast and 

accurate instability and strength checks can be conducted by the section capacity check 

in Eq. (9). Modification is needed when some members fail. 

(6) Deflection Check 

As checking for serviceability limit state, this step ensures deflection limit is not 

violated otherwise member re-sizing or pre-cambering is activated. 

(7) Permanent Load Design Check  

The conventional ultimate and serviceability limit state design load checks are carried 

out as the final safety and serviceability checks. The consideration of load sequence 

may affect the final force and moment distribution as some construction loads are 

present earlier than some members which do not share these construction loads.  
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Figure 5.23  Flow Chart of the Integrated Design and Construction Procedure 
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6. EXPLANATION OF INPUT FILE 

 

6.1 Comment and General Rules 

 Using "!" for comment which will be ignored when reading the file. 

 All names such as material, section, load case should be put into "< >". 

 

6.2 Project Title and Information 

To record the project title and other project information and will be output in *.out file. 

 

*TITLE 

...  

Noted that more than one lines is allowed, but should not include the KEYWORDs. 

 

6.3 Version 

To verify whether the data file is supported by the current version of NIDA or not. 

 

*VERSION [Number] 

 

6.4 Active Degree of Freedom 

To active some of the degrees of freedom for analysis. User can set 2D problem such 

as XY plan here 

 

*ACTIVEDOF [Number] 

 

[Number] 

(1) 0 or 1 only; 

(2) 0 = inactive; 1= active 

(3) Combine with maximum 6 digitals, for example, 111111 

 

6.5 Unit System 

To define the units used in the project.  

 

*UNIT [Force Unit] [Length Unit] 

Item Unit 

Force N, kN, kgf, tonf 
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Length mm, cm, m 

Rotation DEGREE, RAD 

Temperature 
o
C 

Time s (second) 

 

6.6 Numbering Optimization 

Active or inactive the nodal numbering optimization for reducing memory used in 

analysis. 

 

*KMIN [Number] 

 

[Number] 

= 0 Inactive nodal numbering optimization for reducing memory used; 

= 1 Auto active this function (default); 

= 2 Always active this function. 

 

6.7 Tolerance 

Set the tolerances to change the accuracy of analysis results.  

 

*TOLERANCE [Number1] [Number2] 

[Number1] : For nonlinear iteration, Default Value = 1e-3 

[Number2] : For subspace iteration, Default Value = 1e-7 

 

6.8 Design Code Used 

To define the design codes for design purpose. 

 

*DESIGN [Steel Code] {[Concrete Code] [Composite Code]}  

 

[Steel Code] : Steel design code used 

Number Design Code 

1~10 HKSC (2011) 

11~20 BS5950 (2000) 

21~30 Eurocode3 (2005) 

31~40 GB50017 (2003) 

41~50 AISC-LRFD (2010) 

> 50 Undefined 

 

[Concrete Code] : Concrete design code used 

Number Design Code 
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1~10 HKCC (2004, 2nd) 

11~20 BS8110 (1997) 

21~30 Eurocode2 (2004) 

31~40 GB 50010 (2002) 

> 40 Undefined 

 

[Composite Code] : Composite design code used 

Number Design Code 

1~10 HKSC (2005) 

11~20 BS5950 (2000) 

21~30 Eurocode4 (2004) 

31~40 GBJ138 (2001) 

> 40 Undefined 

 

6.9 Gravity Direction 

To define the direction of gravity. It is important to define the gravity direction as 

many parameters are related to it. For modal analysis or time history analysis, user may 

need to add additional mass from load cases (in the gravity direction) into the structural 

system.  

 

*GRAVITY [Number]  

 

[Number] : Direction of gravity 

= +/-1, Global axis +/-X; 

= +/-2, Global axis +/-Y; 

= +/-3, Global axis +/-Z; 

 

6.10 Analysis Case 

To define analysis case and analysis parameters. 

 

*ANTY 

SOLU [NO.][TYPE][IF DESIGN /dummy] [IF RUN:1=RUN,0=NOT RUN] <NAME> 

 

[TYPE] 

Number Analysis Case Type 

1~10 Linear Analysis 

11~20 Nonlinear analysis 

21~30 Modal analysis 

31~40 Eigen-buckling analysis 

41~50 Response spectrum analysis 

51~60 Time history analysis 

>60 Undefined 
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6.10.1 Linear Analysis 

SOLU [NO.][TYPE=1~5][IF DESIGN][IF RUN:1=RUN,0=NOT RUN] <NAME> 

LINP [Method_AmpMoment=0][Elastic Buckling Factor = 0] 

USE [1=LOADCASE] [NO.] [FACTOR] 

USE [2=COMBLOAD] [NO.] [FACTOR] 

 

Note: Method_AmpMoment : Method for Moment Amplification (Linear Design only) 

(1) HKSC (2005/2011) 

     = 0 , No moment amplification; 

     = 1 , cr

cr

λ

λ -1
; 

     = 2 ,
2

c E

2

1

F L
1-
π EI

;  (Default) 

     = 3 , Larger of 1 and 2; 

(2) GB50017 (2003) 

     = 0 , No moment amplification; 

     = 1 , N.A.; 

     = 2 ,
' 2 2

'

1
 , where N / (1.1 )

N
1-0.8

N

E

E

EA  ;  (Default) 

     = 3 , N.A.; 

 

6.10.2 Nonlinear Analysis 

SOLU [NO.][TYPE=11~20,11/13=PEP,12/14=STABILITY FUNCTION, 13~14 BEAM BUCKING] 

[IF DESIGN] [IF RUN:1=RUN,0=NOT RUN] <NAME> 

 

NONP [ … ] 

Note: All data should be in one line.  

No. Parameter Description 

1 MYIELD 0=Elastic; 1=Plastic Element; 2=Plastic Hinge 

2 Force Recovery Scheme 1= Total Secant Stiffness Method; 2= Incremental Tangent 

Stiffness Method 

3 CYCLES Total Load Cycles, 1 

4 ITERATIONS Number of Iterations for Each Load Cycle, 1 

5 INC LOADFACTOR Incremental Load Factor, 1.0 

6 NUMERICAL METHOD Numerical Method: 11=NR, 22=Single Disp., 

43=ArcLen+MRD 



Explanation of Input File 
 

NIDA – Nonlinear Integrated Analysis & Design  193 

7 ITER-PARAMETER Parameter for Numerical Method, 4 

8 INC-PARAMETER Parameter for Numerical Method, 5 

9 TANGENTS Number of Iterations for Tangent Stiffness Matrix, 1 

10 IMPERFECTION 

DIRECTION 

+/-1, DIMP; +/-2, EIMP; +/-3, NIMP 

0, No Imperfection 

11 MIN. MEMBER 

IMPERFECTION 

Minimum Member Imperfection, 1/1000.  

12 Stiffness Reduction Factor 0.8~1.0 (AISC-LRFD 2010)  

13 Target Load Factor Target Load Factor, 1.0 

(-1=Disable this function) 

 

IMPERFECTION DIRECTION: To determine GLOBAL and LOCAL imperfection 

(a) IMPERFECTION DIRECTION=+/-1: “Displacement”, using deformed shape of applied forces as 

global imperfection; 

DIMP [MAGNITUDE OF GLOBAL IMPERFECTION, L] 

(b) IMPERFECTION DIRECTION=+/-2: “Eigen-buckling mode”, using specified buckling mode as 

global imperfection, need the following parameters: 

EIMP [MAGNITUDE OF GLOBAL IMPERFECTION, L][>0, Directly Calc. MODES,5] [iTH MODE 

USED,1] 

(c) IMPERFECTION DIRECTION=+/-3: “Notional Forces”, using notional horizontal forces as global 

imperfection, need the following parameters: 

NIMP [Angle about vertical axis (HORIZONTAL Direction), 0, DEGREE][% of Gravity Load] 

Note: For all methods, “+ ve” considers member imperfections in both principal axis while “-ve” 

considers only one principal axis which is adequate for most structures. 

 

NUMERICAL METHOD (3 given schemes) 

[NUMERICAL METHOD] 

No. Description 

1 NEWTON-RAPHSON 

2 DISPLACEMENT CONTROL 

3 MINIMUM RESIDUAL DISPLACEMENT 

4 ARC-LENGTH 

5 CONSTANT WORK 

 

(a) Constant Load Increment [11] 

Iterative Parameter : None 

Incremental Parameter : None 

(b) Constant Displacement Increment [22] 

Iterative Parameter : Control Node + DOF  (NODE.DOF) 

Incremental Parameter : Incremental Displacement (L) 

(3) Advanced Technique [43] 

Iterative Parameter : Load Size of First Step 

Incremental Parameter : Maximum Arc Distance 
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AGRP [Construction Stage ID] [Active Group ID] 

USE [1=LOADCASE] [NO.] [FACTOR] [Load/Construction stage] 

USE [2=COMBLOAD] [NO.] [FACTOR] [Load/Construction stage] 

 

 [LOAD/Construction STAGE] 

 = -2 : For construction stage 

 = -1 : For initial imperfections 

 = 0: Reserved, for traditional NO load stage 

 > 0: Defined by User 

Note: If no “Load/Construction Stage” defined by user, this value should be left as BLANK. 

 

6.10.3 Modal Analysis 

SOLU [NO.][TYPE=21~30,21=LUMPED MASS,22=CONSISTENT MASS][dummy][IF 

RUN:1=RUN,0=NOT RUN] <NAME> 

FREQ [EIGENVALUES,6] [IF PRINT: 1=PRINT, 0=NOT PRINT] [IF ACTIVE AUTO FUNCTION: 

1=ACTIVE, 0=INACTIVE] [Modal Participating Mass Ratios,90%] [INC modes,10]  

 

USE [-1=LOADCASE] [NO.] [FACTOR]   !for additional mass 

USE [1=LOADCASE] [NO.] [FACTOR]   !for determination of initial stiffness 

USE [2=COMBLOAD] [NO.] [FACTOR] 

 

6.10.4 Eigen-Buckling Analysis 

SOLU [NO.][TYPE=31~40][dummy][IF RUN:1=RUN,0=NOT RUN] <NAME> 

BUCK [EIGENVALUES, 6] [IF PRINT] 

USE [1=LOADCASE] [NO.] [FACTOR] 

USE [2=COMBLOAD] [NO.] [FACTOR] 

 

6.10.5 Response Spectrum Analysis 

RESPONSE SPECTRUM ANALYSIS 

SOLU [NO.][TYPE=41~45][ dummy][IF RUN:1=RUN,0=NOT RUN] <NAME> 

SPEC [MODAL ANALYSIS CASE NO.] 

[MODAL COMBINATION:1=CQC,2=SRSS,3=ABS] 

[SEISMIC DIRECTION: 0: HORIZONTAL, 1: VERTICAL] [EXCITATION ANGLE, 0]  

[Modal Damping Ratio, 0.05] 

USE [4=SEISMIC SPECTRUM FUNCTION] [NO.] [dummy]    !Response spectrum function 
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RESPONSE SPECTRUM ANALYSIS(DIRECTIONAL COMBINATION) 

SOLU [NO.][TYPE=46~50][dummy][IF RUN:1=RUN,0=NOT RUN] <NAME> 

DCMB [DIRECTIONAL COMBINATION:1=SRSS,2=ABS,3=Modified SRSS(Chinese)] 

[Horizontal Spectrum Ana.: EQ1] [Horizontal Spectrum Ana.: EQ2] [Vertical Spectrum Ana.: EQ3] 

{Scale factor for ABS, 0.3} 

 

6.10.6 Time History Analysis 

SOLU [NO.][TYPE=51~60][IF DESIGN][IF RUN:1=RUN,0=NOT RUN] <NAME> 

 

[TYPE] 

Number Analysis Case Type Mass Type 

52 Nonlinear analysis (PEP) Lumped 

53 Nonlinear analysis (STABILITY FUNCTION) Lumped 

55 Nonlinear analysis (PEP) Consistent 

56 Nonlinear analysis (STABILITY FUNCTION) Consistent 

 

TIHI [ … ] 

No. Parameter Description 

1 TIME HISTORY TYPE 1= Direct integration; 2= Mode superposition 

2 TIME HISTORY 

MOTION TYPE 

1= Transient; 2= Periodic 

3 TOTAL NO. OF TIME 

STEP 

<=0 depend on the time history function defined; > 0 

stop when the total time reached 

4 TIME INCREMENT 0.02 second 

5 MODAL ANALYSIS 

CASE No. 

MODAL ANALYSIS CASE USED for mode 

superposition (ignorable) 

 

NONP [ … ] 

Note: All data should be in one line.  

No. Parameter Description 

1 MYIELD 0=Elastic; 1=Plastic Element; 2=Plastic Hinge 

2 Force Recovery Scheme 1= Total Secant Stiffness Method; 2= Incremental 

Tangent Stiffness Method 

3 CYCLES Total Load Cycles, 1 

4 ITERATIONS Number of Iterations for Each Load Cycle, 1 

5 INC LOADFACTOR Incremental Load Factor, 1.0 

6 NUMERICAL METHOD Numerical Method: 11=NR, 22=Single Disp., 

43=ArcLen+MRD 

7 ITER-PARAMETER Parameter for Numerical Method, 4 

8 INC-PARAMETER Parameter for Numerical Method, 5 

9 TANGENTS Number of Iterations for Tangent Stiffness Matrix, 1 

10 IMPERFECTION 

DIRECTION 

+/-1, DIMP; +/-2, EIMP; +/-3, NIMP 

0, No Imperfection 

11 MIN. MEMBER 

IMPERFECTION 

Minimum Member Imperfection, 1/1000.  
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12 Stiffness Reduction Factor 0.8~1.0 (AISC-LRFD 2010)  

13 Target Load Factor Target Load Factor, 1.0 

(-1=Disable this function) 

 

IMPERFECTION DIRECTION: To determine GLOBAL and LOCAL imperfection 

(a) IMPERFECTION DIRECTION=+/-1: “Displacement”, using deformed shape of applied forces as 

global imperfection; 

DIMP [MAGNITUDE OF GLOBAL IMPERFECTION, L] 

(b) IMPERFECTION DIRECTION=+/-2: “Eigen-buckling mode”, using specified buckling mode as 

global imperfection, need the following parameters: 

EIMP [MAGNITUDE OF GLOBAL IMPERFECTION, L][ >0, Directly Calc. MODES,5] [iTH 

MODE USED,1] 

(c) IMPERFECTION DIRECTION=+/-3: “Notional Forces”, using notional horizontal forces as global 

imperfection, need the following parameters: 

NIMP [Angle about vertical axis (HORIZONTAL Direction), 0, DEGREE][% of Gravity Load] 

Note: For all methods, “+ ve” considers member imperfections in both principal axis while “-ve” 

considers only one principal axis which is adequate for most structures. 

 

DINT [NUMERICAL METHOD FOR DIRECT INTEGRATION, 1=Newmark] [Parameters …] 

(1) Newmark: [Gamma, 0.5] [Beta, 0.25] 

 

DAMP [TYPE] [PARAMETERS …] – Rayleigh Damping 

(1) [Type=1, Direct input, {C}=a*{M}+b*{K} ] [Alpha, Mass Proportional coefficient] [Beta, Stiffness 

Proportional coefficient] 

(2) [Type=2, Calculate by Period] [T1, 1
st
 period] [T2, 2

nd
 period] [Damping Ratio1 1 ] [Damping 

Ratio2 2 ]  

(3) [Type=3, Calculate by Frequency] [f1, 1
st
 frequency] [f2, 2

nd
 frequency] [Damping Ratio1 1 ] 

[Damping Ratio2 2 ] 

Note:  

1 1 2 2

2 2

1 2

1 2 2 1 1 2

2 2

1 2

4 ( )

( )

( )

( )

T T

T T

TT T T

T T

  


 














 

(
2 2i i i    , 

1
f

T
 ) 

 

USE [-1=LOADCASE] [NO.] [FACTOR]          !for additional mass 

USE [ 1=LOADCASE] [NO.] [FACTOR]          !for static loads 

USE [ 2=COMBLOAD] [NO.] [FACTOR]         !for static loads 
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USE [ 5=DYNAMIC FUNCTION] [NO.] [FACTOR] [Arrival Time, 0, s] 

[SEISMIC DIRECTION: 0: HORIZONTAL, 1: VERTICAL]  

[EXCITATION ANGLE, 0, DEGREE]        !for time history function (Earthquake) 

 

6.11 Material 

To define material properties. 

 

*MATP 

MAT [NO.][TYPE] <NAME> COLOR 

 

Number Material Type 

0 OTHER 

1 STEEL 

2 CONCRETE 

3 ALUMINIUM 

4 GLASS 

5 REBAR 

 

[E (short term for concrete), F/L
2
] [-1~0 =Poisson’s ratio; >0 = G] [Density, F/L

3
] 

[Thermal coefficient][Yield strength, F/L
2
] {[Yield tensile strength, F/L

2
] [Long term 

for concrete: E, F/L
2
]}   

 

6.12 Frame Section 

To define frame section properties. 

 

*SECT 

Note: The section ID for all sections should be unique. 

 

 

 

 

 

 

 

6.12.1 General and Steel Section 

SSTL [NO.][TYPE][SHEAR FACTOR] [SHAPE] <NAME>  COLOR 

LINE1: [MAT] [IMP-Y] [IMP-Z] [Limit SY, 1.2] [Limit SZ, 1.2]  

[B (B1)][D][Tf (Tf1)][tw]{[B2][Tf2][ds]} 

z 

y 

y 

z 

Section axis 
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LINE2: [AREA, L
2
] [IY, L

4
] [IZ] [J,L

4
] [ZY(+), L

3
] [ZZ(+)] [SY, L

3
] [SZ]  

       {[Iw, L
6
] [ZY(-)] [ZZ(-)]}  

LINE3: {[Avy, L
2
] [Avz] [ry, L] [rz] [u] [x]}  

LINE4: {[Aeff] [Zy,eff(+)] [Zz,eff(+)] [Sy,eff] [Sz,eff] [Zy,eff(-)] [Zz,eff(-)]}  

Note: (1) Line 2&3 can be ignored when the dimensions are defined. 

     (2) Line 2&3 cannot be ignored when LINE4 exists. 

 

[SHAPE] – 5 DIGITAL AS BELOW: {N1}N2N3N4N5 

N1 – Indicator of considering eigen-imperfection or not (0,1) 

N2 – Indicator of using elastic or plastic modulus 

     1~2: Effective stress method (1=Elastic, 2=Plastic) 

N3 – Formed type of section (1= rolled, 2=fabricated, 3= cold-formed) 

N4 – Section Axis (0 = yz axis; 1 = uv axis) 

N5 – Stress Type for Stress Computation (1=Direct sum of stress, 2=Square-root of stress, 3= Tension 

Only, 4=Compression Only) 

 

Type Name Dimensions Figure 

0 Other N.A. N.A. 

1 Rectangular B,D 

 

2 Circular D 

 
3 Box

 
B,D,Tf,tw 

 
4 Pipe D,Tf 

 

5 I/H section(double 

symmetric) 

B,D,Tf,tw 
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6 Monosymmetric 

I-section 

B (B1),D,Tf1,tw,B2,Tf2 

 

7 Channel B,D,Tf,tw 

 
8 Single angle 

 

B,D,Tf,tw 

 

9 Tee section B,D,Tf,tw 

 
10 Double angle B,D,Tf,tw,ds 

 
11 Double channel B,D,Tf,tw,ds 

 

12 Double box B,D,Tf,tw,ds 
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13 I-Box section B (B1),,D,Tf,tw,B2 

 

14 Two boxes 

 

B,D,Tf,tw 

 

15 Z-section B,D,Tf,tw 

 
16 Cross plate B,D,Tf,tw 

 

17 Trap-hollow 

section 

B,D,Tf,tw,B2,Tf2 

 
18 Triangular-hollow 

section 

B,D,Tf,tw 
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6.13 Area Section 

To define area type section properties. 

 

*ASECT 

Note: The section ID for all sections should be unique. 

 

6.13.1 Shell Section 

SSHL [NO.] <NAME> COLOR 

[MAT] [Type] [THICKNESS-BENDING] [THICKNESS-MEMBRANE] {[IsThickPlate]} 

 

[TYPE] 

 = 1 : Shell (Membrane+ Plate) 

 = 2 : Membrane only 

 = 3 : Plate only 

 

[IsThickPlate] 

 = 0 : Thin Plate (Default) 

 = 1 : Thick Plate 

 

6.14 Node 

 

*NODE 

[NO.] [X, L] [Y, L] [Z, L] 

 

 

6.15 Semi-rigid Connection and Spring Models 

 

*SEMIRIGID 

SRModel [NO.>0] [Relationship] [TYPE] [Initial Stiffness] [Ultimate Rot./Disp.] [SIGN] <NAME> 

Note: [Ultimate Rot./Disp.] =0 means no limitation. 
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[Relationship=1]: Moment -Rotation 

 

[TYPE=1] : Linear Model 

SRModel [NO.] [1] [1] [Re Initial stiffness, F*L/RAD] [p Ultimate Rotation, RAD] [SIGN] <NAME> 

 

eM R  

 

 

 

[TYPE=2] : Bi-linear Model 

SRModel [NO.] [1] [2] [Re0/0 or dummy] [p Ultimate Rotation, RAD] [SIGN] <NAME> 

[0 Yield moment, F*L], [0 Yield Rotation, RAD] , [p Ultimate moment, F*L]  

0 0

0

0

0 0 0

0

,    /
( )

( ) ( )

0 ( )

e e

p

p

p

p

R R M

M M
MM

 
 

    
 

 




     



 

 

 

[TYPE=3] : Three-parameter power model (Kishi and Chen 1987) 

SRModel [NO.] [1] [3] [Re Initial stiffness, F*L/RAD] [p Ultimate Rotation, RAD] [SIGN] <NAME> 

[0 Reference moment, F*L], [n Shape parameter, NO UNIT] 

 

1/

0

0 0( 1) /

0

1/

0

[1 ( / ) ]

    where /
[1 ( / ) ]

[1 ( / ) ]

e

n n

e
en n n

n n

e

R
M

RdM
R M R

d

M

R M M



 


  











  







 

 

[TYPE=4] : Four-parameter power model (Richard and Abbott 1975) 

SRModel [NO.] [1] [4] [Re Initial stiffness, F*L/RAD] [p Ultimate Rotation, RAD] [SIGN] <NAME> 

[0 Reference moment, F*L], [Rp Strain-hardening/softening stiffness, F*L/RAD],  

[n Shape parameter, NO UNIT] 

 

 

M 

 

0 

p 

0 p 

M 

 
p 

M 

 
p 
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1/

0

( 1) /

0

( )

{1 [( ) / ] }

{1 [( ) / ] }

e p

pn n

e p

e p

pn n n

e p

R R
M R

R R M

R RdM
R R

d R R M






  


 

 


   
  

 

/(1 ) 1/

0

0

[ 1 (1 / ) ]
  ( 0)

n n n

e p

e p

M R R dM
R

R R d




  
  


 

 

[TYPE=5] : Multi-linear Model 

SRModel [NO.] [1] [5] [Re Initial stiffness, F*L/RAD] [p Ultimate Rotation, RAD] [SIGN] <NAME> 

[M1, F*L], [1, RAD] 

[M2], [2] 

… 

[Mn], [n] 

 

i m j    j=i+1, < <

j i

j i

t

m i t m

M M M

M
R

M M R

  

  





  

  
 



 

 

 

[Relationship=2]: Force-Displacement 

 

[TYPE=1] : Linear Model 

SRModel [NO.] [2] [1] [ke Initial stiffness, F/L] [dp Ultimate Displacement, L] [SIGN] <NAME> 

 

eF k d  

 

 

 

 

[TYPE=2] : Bi-linear Model 

SRModel [NO.] [2] [2] [ke=F0/d0 or dummy] [dp Ultimate Displacement, L] [SIGN] <NAME> 

[F0 Yield force, F], [d0 Yield Displacement, L] , [Fp Ultimate force, F] 

 

M 

 
p 

F 

d 
dp 

p i m j 

M 

 
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0 0

0

0

0 0 0

0

,    /
( )

( ) ( )

0 ( )

e e

p

p

p

p

k d k F d
d d

F F
F d d d d dF

d d

d d




     



 

 

 

[TYPE=3] : Multi-linear Model 

SRModel [NO.] [2] [3] [ke Initial stiffness, F/L] [dp Ultimate Displacement, L] [SIGN] <NAME> 

[F1, F], [d1, L] 

[F2], [d2] 

… 

[Fn], [dn] 

 

i m j    j=i+1, < <

j i

j i

t

m i t m

d d d

F F F

d d dF
k

d

F F k d

  

  
 




 

 

 

6.16 Beam-Column Element 

To define beam-column elements. 

 

*BEAM 

[Mem NO.][SECT] [JOT1][JOT2] [Design Type:0=By Program (beam-column), 1= column, 2= beam, 

3=brace][If Igored plastic hinge,-1=ignore,0=Default hinge model, >0 Plastic hinge model][Seismic 

Design=0 No Seismic (Default),4,3,2,1] 

 

6.17 End Conditions 

To define the end connection of beam-column element. 

 

*RELEASE 

[Mem NO.] [SPRING 1~6: IIY, IIZ, JJY, JJZ, IJT, IJX] 

 

IIY: connection stiffness at i-node and about y-y axis [-1=Rigid, 0=Pin, >0 Semirigid Model] 

IIZ: connection stiffness at i-node and about z-z axis [-1=Rigid, 0=Pin, >0 Semirigid Model] 

JJY: connection stiffness at j-node and about y-y axis [-1=Rigid, 0=Pin, >0 Semirigid Model] 

F 

d 

F0 

Fp 

d0 dp 

dp di dm dj 

F 

d 
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JJZ: connection stiffness at j-node and about z-z axis [-1=Rigid, 0=Pin, >0 Semirigid Model] 

IJT: torsional spring [-1=Rigid, 0=Pin] 

IJX: axial spring [-1=Rigid, 0=Pin, >0 Semirigid Model] 

 

6.18 Effective Length 

 

*EFFLEN 

[Mem NO.] [BEAM LE] [LOADING CONDITION] [COLUMN LE-Y, L for <0] [COLUMN LE-Z, L 

for <0][Equivalent Moment Factors (my, mz): 1=Set as 1.0 (Default); 0=By program] 

 

Parameters Steel Design Other Cases 

[BEAM LE] Beam effective length 0 (N.A.) 

[LOADING CONDITION] 0,1 0 (N.A.) 

 

6.19 Combined Member 

To define a complete beam-column element with a number of segments for deflection 

checking. 

 

*SEGMENT 

MEMB [No.] [Start Node] [End node] {[Type]} <Name> 

[Beam-column No. List …] 

 

6.20 Eccentricity 

To define the eccentricity (offsets) of beam-column end. 

 

*BMECCE 

[Mem NO.] [Type=1, End Section Eccentricity] [eyi, L] [ezi, L] [eyj, L] [ezj, L]  

 

[Mem NO.] [Type=2, End Length Offset (for Rigid Zone)] [0=Direct input, 1=By Program][e i>0, L] 

[ej>0, L] [Rigid Zone Factor= 0~1(Default), L1=L-f*( ei +ej)>=0] 

 

Note: The end eccentricities and length offsets are relative to the centroid point of cross section in 

member local axis. 

 

 

 

 

 

ei ej 

End Length Offset 

i-Node j-Node 

y 

z ey 

ez 

End Section Eccentricity 

i/j-Node 

(at centroid) 



Explanation of Input File 
 

NIDA – Nonlinear Integrated Analysis & Design  206 

 

6.21 Shell Element 

To define shell elements. 

 

*SHELL 

[NO.] [SECT] [TYPE,1] [JOT1] [JOT2] [JOT3] 

 

 

6.22 Floor Element 

To define floor elements. 

 

*FLOOR [STIFFNESS, F/L] 

[NO.][Shell Section] [JOT1] [JOT2] [JOT3] {[JOT4]} 

 

[Shell Section] : 0 No shell section assignment 

            >0 Shell section ID 

 

6.23 Beam-Column/Spring Element Local Axis 

To define the local axis of beam-column or spring element. 

 

*ANGL 

[MEMBER NO.] [1=ANGLE; 2=KP] [VALUE, DEGREE for ANGLE] 

[SPRING NO.] [11=ANGLE; 12=KP] [VALUE, DEGREE for ANGLE] 

 

6.24 Node Local Axis 

To define the node local coordinate system. 

 

*NSYS 

NSYS [NO.] [TYPE] <NAME> 

 

TYPE=1(By 3 Nodes) 

[Node i] [Node j] [Node k]  (Right-hand rule) 
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1

'

2

'

3 1 2

2 3 1

{ }     (Local x-axis)

{ }   (Reference axis)

                  (Local z-axis)

                  (Local y-axis)

j i

k j

V ij X X

V jk X X

V V V

V V V

  

  

 

 

 

 

TYPE=2 (By 3 Angles) 

[ROTATION,ABOUT Y G , DEGREE] [ROTATION,ABOUT Z’ e , DEGREE] 

[ROTATION,ABOUT X’’  , DEGREE] 

 

6.25 Assignment of Node Local Axis 

To assign the node local coordinate system to nodes. 

 

*NLAXES 

NLAXES [NSYS NO.]  

[Node No. List …] 

 

6.26 Spring 

To define spring element and node support spring. 

 

*SPRI 

SUPP … 

ADJA… 

 

6.26.1 Support Spring 

SUPP [NODE] [DOF] [SRMODEL NO.] 

 

 

6.26.2 Spring Element 

ADJA [No.] [Type=2] [iNode] [jNode] [Ka] [Kby] [Kbz] [Kt] [Kvy] [Kvz] 

Ka :  Local axial element stiffness (along x-axis) 

Kby :  Local bending element stiffness about y-axis 

Kbz :  Local bending element stiffness about z-axis 

Kt :  Local tortion element stiffness (about x-axis) 

Kvy :  Local shear element stiffness along y-axis 

Kvz :  Local shear element stiffness along z-axis 
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  Note: (1) Ka, Kvy, Kvz refer to *SEMIRIGID (SRMODEL NO.) – Force vs Disp; 

       (2) Kby, Kbz, Kt refer to *SEMIRIGID (SRMODEL NO.) – Moment vs Rotation; 

       (3) Ka, Kby, Kbz, Kt, Kvy or Kvz =0 is for ignorable spring. 

 

6.27 Boundary Condition 

To define the boundary conditions for nodes. 

 

*BOUN 

[NODE] [VALUE] 

 

[VALUE]: Max. 6 number together, 0=Free, 1=Restraint, e.g. 110101 

 

6.28 Group 

*GROUP [NO.] <NAME> 

@NODE 

… [Node No. List, Max. Num per line = 10 (if any)] 

@BEAM 

… [Member No.List, Max. Num per line = 10 (if any)] 

@SHELL 

… [Shell No.List, Max. Num per line = 10 (if any)] 

@FLOOR 

… [Floor No.List, Max. Num per line = 10 (if any)] 

@SPRING 

… [Spring No.List, Max. Num per line = 10 (if any)] 

@AREA 

… [Area No.List, Max. Num per line = 10 (if any)] 

 

6.29 One/Two-Way 

To define one-way direction for floor/shell pressure assignment.  

*ONEWAY 

[Obj. Type: 1=Floor, 2=Shell] [Obj. No.] [Direction: 1=Side 1-3, 2=Side 2-4] 

 

6.30 Load Case 

 

*LOADCASE [NO.] [FACTOR] [TYPE]<NAME> 
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Number Load Case Type 

0 OTHER 

1 DEAD LOAD 

2 LIVE LOAD 

3 WIND LOAD 

4 TEMPERATURE 

5 SEISMIC 

6 EARTH 

7 WATER 

 

6.30.1 Self Weight 

SELF [-1][SYS][+/-][DIR][ Amplification Factor]         !FOR ALL MEMBERS 

SELF [-2][SYS][+/-][DIR][ Amplification Factor]         !FOR ALL SHELLS 

SELF [-3][SYS][+/-][DIR][ Amplification Factor]         !FOR ALL FLOORS 

 

[SYS] 

 = GL : Global axis (Not allowed local axis) 

 

[DIR] 

 = X : X-axis; = Y : Y-axis; = Z : Z-axis 

 

6.30.2 Pretension (Cable) Force 

PRES [MEMBER][PRE-TENSION FORCE, F] 

 

6.30.3 Joint Load 

JNTL [NODE] [FX, F][FY, F][FZ, F][MX, F*L][MY, F*L][MZ, F*L] {[SYS]} 

 

[SYS] 

 = LO : Nodal Local axis 

 = GL : Global axis (Default) 

 

6.30.4 Member Point Load 

PNTL [MEMBER][VALUE, F][DIST FROM LEFT, L][SYS][DIR] {[IsNodalLoad]} 

 

[SYS] 

 = LO : Local axis 

 = GL : Global axis 

 

[DIR] 
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 = X : X-axis; = Y : Y-axis; = Z : Z-axis 

 

[IsNodalLoad] 

 = 0 : Consider as Member Load (Default) 

 = 1 : Convert to Nodal Loads Only 

 

6.30.5 Member UDL 

UDL [MEMBER] [q, F/L] [SYS] [DIR] {[IsNodalLoad]} 

 

 

 

[SYS] 

 = LO : Local axis 

 = GL : Global axis 

 = TG : Global axis (Distributed along Member) 

 

[DIR] 

 = X : X-axis; = Y : Y-axis; = Z : Z-axis 

 

[IsNodalLoad] 

 = 0 : Consider as Member Load (Default) 

 = 1 : Convert to Nodal Loads Only 

 

6.30.6 Member TRAP 

TRAP [MEMBER] [q1, F/L] [q2, F/L] [d, L] [c, L] [SYS] [DIR] {[IsNodalLoad]} 

 

 

 

 

 

 

 

6.30.7 Member TRAPT 

TRAPT [MEMBER] [q, F/L] [a, L] [SYS] [DIR] {[IsNodalLoad]} 

 

 

q1 

q2 

d c 

q 
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6.30.8 Member TRAPQ 

TRAPQ [MEMBER] [q1, F/L] [q2, F/L] [a, L] [b, L] [SYS] [DIR] {[IsNodalLoad]} 

 

 

 

 

 

 

 

 

6.30.9 Settlement 

LODP [NODE][DOF=1,2,3][DISPLACEMENT, L] {[SYS]} 

 

[SYS] 

 = LO : Nodal Local axis 

 = GL : Global axis (Default) 

 

6.30.10Temperature 

TEMP [MEMBER][VALUE, 
o
C] 

 

 

6.30.11Floor Pressure 

FPRE [FLOOR] [TYPE] [DIR=N,X,Y,Z] [P1, F/L
2
] {[P2~ P4]} 

 

[TYPE] 

 = 0 : CONVERT TO MEMBER LOADS AND THEN TO NODES 

 = 1 : CONVERT TO NODES DIRECTLY 

 

6.30.12Shell Pressure 

SPRE [SHELL] [TYPE] [DIR=N,X,Y,Z] [P1, F/L
2
] {[P2~ P4]} 

q 

a b 

q1 
q2 

a b 
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[TYPE] 

 = 0 : CONVERT TO MEMBER LOADS AND THEN TO NODES 

 = 1 : CONVERT TO NODES DIRECTLY 

 

6.30.13Area Pressure 

APRE [Area No] [TYPE] [DIR=N,X,Y,Z] [P (Uniform) , F/L
2
] 

 

[TYPE] 

 = 0 : CONVERT TO MEMBER LOADS AND THEN TO NODES 

 = 1 : CONVERT TO NODES DIRECTLY 

 

6.30.14Member Pressure 

MPRE [MEMBER] [P, F/L
2
] [SYS] [DIR] [Loaded width]{[IsNodalLoad]} 

 

 

 

 

 

 

[SYS] 

 = LO : Local axis 

 = GL : Global axis 

 = TG : Global axis (Distributed along Member) 

 

[DIR] 

 = X : X-axis; = Y : Y-axis; = Z : Z-axis 

 

[Loaded width] 

< 0 : width input by user, L   

= 1 : Section “B” 

= 2 : Section “D”, (Default) 

= 3 : Max (B, D) 

= 4 : SQRT(B*B+D*D) 

 

[IsNodalLoad] 

P 

Note: Similar to UDL. 

Loaded width 
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= 0 : Consider as Member Load (Default) 

= 1 : Convert to Nodal Loads Only 

 

6.31 Load Combination 

*COMBLOAD  

COMB [NO.] [FACTOR] <NAME> 

[LOADCASE NO.][FACTOR]  

... 

COMB [NO.] [FACTOR] <NAME> 

[LOADCASE NO.][FACTOR]  

... 

 

6.32 Response Spectrum Function 

 

*SEISFUNC 

SFUNC [NO.] [TYPE] [Relationship] [Function Damping Ratio, 0.05] [Direction]<NAME>  

 

[Relationship] 

       =1 Period [L/s
2
] vs. Sa/g 

       =2 Period [L/s
2
] vs. Sa [L/s

2
] 

 

[Direction] 

       =0 Horizontal 

       =1 Vertical 

 

[TYPE] = 0 User defined  

[T1, s] [Sa(1)/g]  

[T2, s] [Sa(2)/g]  

… 

[Ti, s] [Sa(i)/g] 

 

[TYPE] = 1 GB50011 (2010)  

[Max Influence Factor: Amax=0.12] [Seismic Intensity: SI=7.5] [Characteristic Ground Period: 

TG=0.35] [PERIOD REDUCTION FACTOR, 1.0] 
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[TYPE] = 2 Eurocode8 (2004) 

Note: All data should be in one line.  

No. Parameter Description 

1 ag Horizontal Ground Acceleration 

2 Spectrum Type Spectrum Type (1~2), 1 

3 Ground Type Ground Type (1~5 = A,B,C,D,E), 2 

4 Soil Factor Soil Factor( S), 2 

5 Accel. Ratio Acceleration Ratio(avg/ag) , -1 (<0 not 

applicable) 

6 TB Spectrum Period(TB) , 0.15 

7 TC Spectrum Period(TC) , 0.5 

8 TD Spectrum Period(TD) , 2.0 

9 Beta Lower Bound Factor(Beta) , 0.2 

10 q Behavior Factor (q) , 2 

   

 

[TYPE] = 7 IS 1893 (2002)  

[Seismic Zone Factor: Z=0.16] [Importance Factor: I=1.0] [Response Reduction Factor: R=3] [Soil 

Type I~III = 1]  

 

6.33 Dynamic (Time History) Function 

 

*DYNAFUNC  

DFUNC [NO.] [TYPE] [Relationship] [Time interval, s] [Scale Factor] <NAME>  

 

[Relationship] 

       =1 Acceleration [L/s
2
] vs. Time 

       =2 Displacement [L]vs. Time 

       =3 Force [F] vs. Time  

 

[Scale Factor] 

       >0 Scale by this factor 

       <0 Scale to this value (Scale factor = This value / Peak value) 

 

[TYPE] 

       =1 User time history record (Constant time interval) 

            [value1] [value2] … [value i] … 

       =2 User time history record (Variable time interval) 
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            [Time0] [value] [Time1] [value] … [Timei] [value] … 

       =3 Time History Sine Function:  

            [Total No. of cycles] [Period: T] [Amplitude: A0] 

            
0

2
sin(  )A A t

T


  

       =4 Time History Cosine Function:  

            [Total No. of cycles] [Period: T] [Amplitude: A0] 

            
0

2
cos(  )A A t

T


  

       =5 Time History Ramp Function:  

            [Total Time] [Ramp time: t0] [Amplitude: A0] 

            
0 0 0 0 0

0 0

, ( ) where  /

, ( )

k t t t k A t
A

A t t

 
 


 

       =6 Time History Sawtooth Function 

            [Total No. of cycles] [Period: T] [Ramp time: t0] [Amplitude: A0] 

            

0 0 0 0 0

0 0 0

0 0 0 0 0

0 0 0

0 0 0 0

, ( ) where  /

, ( 0.5 )

( 0.5 ), (0.5 0.5 )

, (0.5 )

( ), ( )

k t t t k A t

A t t T t

A A k t T t T t t T t

A T t t T t

A k t T t T t t T

 


  



       
    

      

 

       =7 Time History Triangular Function 

            [Total No. of cycles] [Period: T] [Amplitude: A0] 

            

0 0 0

0 0

0 0

, ( 0.25 ) where  4 /

( 0.25 ), (0.25 0.75 )

( 0.75 ), (0.75 )

k t t T k A T

A A k t T T t T

A k t T T t T

 


    
    

 

 

6.34 Area 

Areas are not structural objects and therefore all their properties such as section assignment and loading 

assignment are invalid in the analysis before they are converted to floor or shell elements. The area 

properties will be converted to the corresponding floor/shell properties after they are converted to 

floor/shell elements. The function of AREA is to help to create complex structures with floor/shell 

elements. 

 

*AREA 

AREA [AREA NO.] [NODE NO. LIST] 

AMESH [SHELL SECTION NO.] [AREA NO. LIST] 

ALSIZE [Area No.] [M1(S1)~ Mn(Sn), Mi<0 for parts , Si>0 for size, Mi/Si =0 for at least one] 
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ASHELL [AREA NO.] [MESHED SHELL NO. LIST] 

AFLOOR [AREA NO.] [MESHED FLOOR NO. LIST] 

 

6.35 Diaphragm 

To group a number of nodes to consider the diaphragm action. 

 

*DIAPHRAGM 

DIAPH [No.] [STIFFNESS] [CG Node] <Name> COLOR 

{NODE List} 

 

[Stiffness] =-1 : Rigid, the stiffness is determined by Program; 

       = 0: No stiffness, the diaphragm will be ignored in Program; 

       > 0: Semi-rigid 

 

[CG Node] = Node of diaphragm at Geometrical centroid 

 

 

6.36 End of File 

To indicate the end of the input file. 

 

*END 
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7. APPENDIX – FLOW CHART FOR ANALYSIS 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Program Initiation

Input Material and Section Properties,

Topology, Connection Stiffness,

Loading and Boundary Conditions

Nodal Coordinates and Control Parameters

Form Transformtaion Matrix using
updated coordinates

Transform Element Stiffness Matrix

from Local to Global Coordinates

Assembling to form the

Complete Structural Tangent Stiffness Matrix, [K]
T

STEP1

STEP 2

STEP 3

STEP 4

STEP 5

STEP 6 Newton R
aphson M

ethodLoop ove
r all mem

bers

Form Element Stiffness Matrix in Local Coordinates
using updated initial forces, [k]  = [k]  +[k]

e l G

B F
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Solve for Incremental Displacement 

[Δu] = [K]   [ΔF] 

[X]   =  [X]  +[Δu] 

Updating of Geometry 

Addition of Spring Stiffness from Supports 

Impose Boundary Conditions 

Apply Incremental Force Vector, [ΔF] 

-1 

T 

i+1 i 

STEP 7 

STEP 8 

STEP 9 

STEP 10 

STEP 11 Modified Newton 

Raphson Method 

C 

B 

E 

F 
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Extract Local Displacement vector from

Global Displacement Vector and Transform to Local Axes

[u]  =[L]  [u]T
l e

Form the Element Resistant Force Vector

[F]  = [k]  [u]

and Transform to Global Coordinate

l l

[F]  =[L] [F]
e l

Add Spring Forces, if any, to Global Resistant Force

[R]  =[R]  +[u][k]
springs

STEP 12

STEP 13

STEP 14

STEP 15

Add Element Force Vector to Global Resistant Force Vector

[R]   =    [F]
e

No. of members

D

C
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Compute Equilibrium Error

[   F]=[F] - [R]

Error = [  F]  [  F] / [F]   [F]
T T

Calculate Norm of Equilibrium Error and Express in Percentage Form

If Error > 0.1%

Print Results

STOP

Yes

STEP 16

STEP 17

STEP 18

STEP 19

STEP 20

No

Appendix I  FLOW CHART FOR NON-LINEAR ANALYSIS (CONT'D)

Next Load Increment ?

No

Yes

F = Applied Force

R = Resistant Force

D E

Section capacity check &

Plastic hinge/element insertion

STEP 21
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